Shadowrun Returns

Shadowrun Returns

View Stats:
Aljernon_HBS Oct 15, 2013 @ 4:42pm
BETA: Shadowrun Returns Update 1.1.0
We have begun public beta testing for the next update. This is COMPLETELY OPTIONAL, but if you'd like to try out the latest and greatest before it's available to the rest of the world, here's how you can participate:

- Go to Steam Library
- Right click on Shadowrun Returns
- Select Properties
- Select Betas
- Then a drop down says: "Select the beta you would like to opt into"
- Choose: Public Beta

You should see some 'updating' traffic as Steam fetches new files for Shadowrun Returns.

Please report bugs to Include the bug in the subject of the email and include as many details about the bug including the steps you took to produce this bug.

If you ever want to opt out of the Public Beta and return to the normal public build that everyone else has, you can repeat the process above and choose NONE from the drop down list.



New Features, Improvements
- Initial Linux Release!
- Item use now fires a triggerable event.
- Items can have passive status effects that are enabled by holding in inventory.
- Items can be set to automatically be used on actor death. (e.g. cast spell on death).
- Light transitions scripts allow for gentle or abrupt, repeatable, light patterns via triggers
- Moving to an invalid tile in free-move will try and walk to the nearest valid tile automatically.
Actor spawners can scale difficulty via naming convention using a story variable: e.g. Guard_Lv1 Lv2 Lv3 and a story variable CharacterScaleAmount = 1,2,3...
- Enhancements to the archetype auto-spend during character creation to allow for higher starting karma within stories.
- Mission objective style screen labels can display a bar as well as text to track progress toward goals.
- Actors can now have floaties disabled via character sheet flag
- Optimized visibility calcs on larger maps
- Regions can now be set to displayed in game (to denote feedback to players).
- Fixed an issue with hiding some props via trigger.
- Add ability to have keypad & keyword input nodes in conversations.
- Physical Adepts: Chi abilities have been changed to provide passive benefits. They can be “activated” as before to get the full benefit.
- Physical Adepts now should be able to use Roundhouse Kick and Disarm while Killing Hands is active.
- New Hi-Res UI Scaling option.

New Trigger Events
- On Item Used
- On Store Closed

New Actions
- Set Prop Visible By {Individual | Tag | Proximity to Coordinate}
- Activate Spawner By Tag
- Retain Other Trigger
- Wait for Motion to Complete
- Interrupt Team Movement
- Set Region Visible, Set Region Color
- Delete Prop By Proximity To Coordinate With Tag

New Data Functions
- Triggering Item
- Item’s ID, Attribute, Skill, Specialization
- Player and Team’s Attribute, Skill, Specialization
- Get Actor Karma Level
- Extra values including min-max, magnitudes, and rotation of actors

Bug Fixes
- Revamped asset caching system to avoid using unnecessary disk space (fixes issue of using extra C: space when run from a drive other than C:).
- Performance, crashing, and memory leak improvements
- Warp motion no longer costs AP, to allow a drone to freely enter a vent passage
- Matrix VFX no longer left behind in the world
- AI Wander Patrols no longer stop and wait for player to move
- Allow blue spawners to appear in triggers that use interactable actors
- Modified constants will be reset between each level
- Barriers immediately apply to someone on the tile
- Added rotation ability to player preview in the equip screen.
- Improved AI logic regarding some weapons with limited capacity.
- Fixed issues installing cyberware upgrades
- Fixed “typo” showing Double Tap in the Rifle tree.
- Add debug console command to display current scene/story variables.
- Fixed rotation issue when re-enabling rain FX after disabling it via trigger.
- Fixed issue causing riggers to sometimes spawn without their drone(s).
- Fixed issue showing light gizmo when showing lights via trigger/tag.
- Fixed issue with game “hanging” when quitting in Steam on Macs.
- Miscellaneous small bug fixes.
- DMS: Fixed conversation bug in Planeyard with Shannon Half-Sky.
- DMS: Fixed issue with conversation with Jake after stash fight.
- Editor: You can move things by 0.01 by using alt+shift+arrow_keys.
- Editor: Fixed several obscure crash issues.
- Editor: Fixed crash bug when loading certain assets from compressed content packs.
- Editor: Can now toggle to see cover icons for props.
- Editor: Fixed a copy & paste issue when pasting between content packs
- Editor: Zooming with mouse wheel enhancements and increased zoom range.
- Editor: Added a more user-friendly “play animation” trigger with dropdown.
Last edited by Aljernon_HBS; Oct 30, 2013 @ 4:43pm
< >
Showing 1-15 of 121 comments
folk Oct 15, 2013 @ 5:24pm 
I don't see how I can access the Linux beta though?
Steam says that SRR is not available for my platform even though I changed to the beta profile.
Aljernon_HBS Oct 15, 2013 @ 5:28pm 
Give it a try now, folk.
NeXuS Oct 15, 2013 @ 5:31pm 
Sorry but it still does not show in the "Games for Linux" section of the Library, and it keeps on saying that "Shadowrun is not available for yoru platform" if I try to force the install from "All games".
d10sfan Oct 15, 2013 @ 5:31pm 
I just tried to subscribe to the public beta on Linux, but it dosen't seem to be downloading anything. I've tried to restart Steam. If I click Play, it says missing executable
Last edited by d10sfan; Oct 15, 2013 @ 5:33pm
Aljernon_HBS Oct 15, 2013 @ 5:38pm 
Looks like there's a propagation issue happening in some areas. Give it a little bit and see if it works after that. We're keeping a close eye on the status.
NeXuS Oct 15, 2013 @ 5:38pm 
Originally posted by =(eG)= d10sfan:
I just tried to subscribe to the public beta on Linux, but it dosen't seem to be downloading anything. I've tried to restart Steam. If I click Play, it says missing executable

Same here. Steam restart, game shows up in the Linux section, click Install and it downloads nothing (the install directory is empty).
NeXuS Oct 15, 2013 @ 7:05pm 
Still downloading nothing in Korea.
Nothing downloading here in NY.
dkropfuntucht Oct 15, 2013 @ 7:39pm 
Nothing here either. Just activated the game via a backer code. Subscribed to the public beta. When I click play: "missing executable". "Browse game files" comes up with an empty folder and it's size 0 on disc.
only the deluxe stuff downloading here. it looks like the same issue that other games have had

the linux depot isnt linked to the store packages
if you look here( theres 2 depots which are the win/mac versions. the linux depot needs to be added too. snapshot devs couldnt figure it out i think they got valve to do it and air conflict pacific carriers had the same issue

real pity its not working i have been looking forward to this for some time
Unaccounʇed4 Oct 15, 2013 @ 8:25pm 
According to the History, it seems someone removed the Linux Depot, 3 months ago.

- 3 months ago Removed Unknown Depot 234653 from the package
Last edited by Unaccounʇed4; Oct 15, 2013 @ 8:26pm
Aljernon_HBS Oct 15, 2013 @ 8:33pm 
For those having issues, here's a few things to check for:

* Ensure that the public_beta branch is opted in the tag.
* In the Properties tab, make sure Automatic Updates is set to 'Always keep this game up to date'
* In the Local Files click the 'Verify Integrity Of Game Cache" to ensure that the client is referencing the right depot.

@Slacker[Linux] - We currently have only two depots in the production branch, which is what is reflected in the link. The beta should have three. That said we're in contact with Steam and will try to get this up and working for those having issues ASAP.
d10sfan Oct 15, 2013 @ 8:36pm 
Made sure of all three earlier and still having the issue. Restarted Steam again for good measure
NeXuS Oct 15, 2013 @ 8:36pm 
@Aljernon_HBS Everything checked but still no download. :( Hope the guys at Valve can help soon.
Last edited by NeXuS; Oct 15, 2013 @ 8:41pm
thats a link to the store package i thought all depots have to be available in the package then you define what branch gets access to what depots

you guys probably dont see the issue because the Shadowrun Returns Early Access Comp package has the linux depot. has anyone been able to download it on linux?

i could be wrong about it i havent done anything on steam its just how i think it all works. im sure you guys or valve will fix whatever it is sooner or later
< >
Showing 1-15 of 121 comments
Per page: 15 30 50

Date Posted: Oct 15, 2013 @ 4:42pm
Posts: 121