Shadowrun Returns

Shadowrun Returns

View Stats:
Chromeo May 2, 2014 @ 3:45pm
Bug at Universal Brotherhood
I tried googling it but I couldn't find any other reference to it anywhere, when my character enters the Brotherhood building for the first time, alone, after the game loads up, I get the descriptive text at the bottom of the screen and then my character starts randomly walking around on his own and casting buffs on himself every time he moves. I can't control anything though I can open the PDA, reloading didn't help or going into the brotherhood again, I also tried checking the cache. Help?
< >
Showing 1-15 of 79 comments
Static May 2, 2014 @ 3:54pm 
That's weird... You might pop open the debug screen and look for some clues. Hit F1 and then check your scene vars, I'm thinking. Haven't seen that myself.
Pietoro May 2, 2014 @ 9:40pm 
I've just reached the UB as well, and my character just stands there after it loads up; I'm unable to move them at all or even pan the camera. Restarting the level or the game doesn't seem to help. I can only interact with the PDA menu.

None of the troubleshooting suggestions make a difference. I've submitted the debug dump files and I guess I won't be playing any more til I get a reply.
Last edited by Pietoro; May 2, 2014 @ 10:10pm
Chromeo May 3, 2014 @ 4:46am 
Any help with this? I basically can't progress now.
Pietoro May 3, 2014 @ 5:27pm 
On the other thread about this bug, someone said they got around it by rewinding to an earlier autosave after the cemetary fight, and then going to the UB from the Union. I just tried that right now, and now loading the UB seems to be working properly. I can zone in and interact normally, so I hope that's all resolved now.
Last edited by Pietoro; May 3, 2014 @ 5:30pm
Chromeo May 4, 2014 @ 6:53am 
But I did go there from the Union!

Plus I stupidly haven't manually saved since back at the decking to find the ripper data. I really don't want to go back through all that just to find it may not work.
cireful May 4, 2014 @ 3:10pm 
Well, dealing with the same issue. Once I enter UB, the char starts wondering around on his own. In the PDA I see the name as MyNameIsATroll8800 and all my stats are set to 9, except HP which are at 99.

I did everything under the sun - reload, rewind, replay the game even; nothing helps. This is beta quality software at best.
Pietoro May 4, 2014 @ 3:15pm 
Are you a Rigger too? Seems the entire UB section hates us for some reason. I got past this hangup just to be blocked by lockups at a later point in the UB basement. It seems to primarily be a Rigger issue.
Chromeo May 4, 2014 @ 5:20pm 
Yeah, I'm a rigger. And I also got the Troll character thing. It seems pretty pathetic that this hasn't been fixed yet, it's clearly affecting a ton of people.
jshepler May 5, 2014 @ 9:41am 
Try entering UB without a drone. That worked for me.
cireful May 5, 2014 @ 12:58pm 
Rigger here too.
Finally entered by doing this:
1) remove 1 drone; only have 1 drone on you.
2) rewind (you MUST rewind, cannot just load) to something prior to the mission.
3) replay by going to the SU, NOT directly to UB mission.
4) I skipped talking to anyone in the mission area prior to entering UB and had only one hired gun with me, plus the ♥♥♥♥♥ with the shotgun. Not sure if this matters.

I finished the mission by going through the secret door, NOT through the doors to the Inner Sanctum. I am not sure if this matters or not for getting stuck in basement.

Fantastic game. Crap code.
Pietoro May 5, 2014 @ 2:05pm 
In the reply to my buig report of the OTHER UB freeze I was having, I mentioned this issue ws happening to several of us as well and directed them to the Steam threads. So hopefully we get a reply about this.

I've rewinded the saves to the SU multiple times, tried different party makeups plus going in with no Drones. Same deal every time. But at least it's not locking up when I first zone into the UB anymore. >_>

Looking at the screen more closely now, I see that when it freezes up, I have my main character (Rigger) selected I can still open my character's inventory and skills windows (they're the only functioning UI parts once this happens), but the weapon selection window is showing the basic attack for my Mage party member. Also, the ghost bug has disappeared and is replaced by it's normal self with 91% hp (not sure if thats supposed to happen after the dialogue or not).
Last edited by Pietoro; May 5, 2014 @ 2:09pm
Pietoro May 5, 2014 @ 2:46pm 
Okay, I finally got around this. Here's what worked:

Rewound again all the way back to the Union.
Went in with only Coyote.
Killed the smaller bug first, then quickly finished off the big one (Despite all of the other party makeup changes I tried before, I had been killing the big one first -- not sure if that mattered).

This time through, the dialogue went off properly and I was given control of Marie. Everything else went normaly.

Last edited by Pietoro; May 5, 2014 @ 2:48pm
Chromeo May 5, 2014 @ 4:05pm 
I managed to get past it by restarting the level before and removing all my drones from equipment, kind of a pain but worked for me. Good game overall, just an annoying bug.
Pietoro May 5, 2014 @ 4:42pm 
Apparently there aren't other gamebreaking bugs like these past the UB area, thank gawd. For some reason this section is just really flaky.
Last edited by Pietoro; May 5, 2014 @ 4:42pm
Thank you for reporting this issue. We are currently looking into this issue and what may be the cause. If you have any further information about this issue or the steps that you are taking to reproduce or work around this issue please let us know.
< >
Showing 1-15 of 79 comments
Per page: 15 30 50