Shadowrun Returns

Shadowrun Returns

View Stats:
This topic has been locked
Harebrained Schemes  [developer] Jul 16, 2014 @ 4:44pm
Beta Release 1.2.7
Beta Instructions
We have begun public beta testing for the next update. This is COMPLETELY OPTIONAL, but if you'd like to try out the latest and greatest before it's available to the rest of the world, here's how you can participate:
  • Go to Steam Library
  • Right click on Shadowrun Returns
  • Select Properties
  • Select Betas
  • Then a drop down says: "Select the beta you would like to opt into"
  • Choose: Public Beta
You should see some 'updating' traffic as Steam fetches new files for Shadowrun Returns.

If you ever want to opt out of the Public Beta and return to the normal public build that everyone else has, you can repeat the process above and choose NONE from the drop down list.

Before reporting a bug please read the known issues section of this post, if you are unable to find a bug listed that matches what you are experiencing then leave a comment in this thread. Include as many details about the bug including the steps you took to produce this bug.

Bug Fixes
  • Fixed issue where level start triggers could be refired when loading a saved game.
  • Fixed issue that caused Drones to not heal with Shadowrunners upon return to a safe area.
  • Fixed issue that caused Drones to not heal last damage with Shadowrunners when combat ended.

Bug Fixes: Dragonfall Campaign
  • Fixed issue that caused players to potentially enter into a state where Optional Objective should not be completed in MKVI mission.
  • Fixed issue where game could enter into a bad state in Bloodlines mission.
  • Fixed issue that caused incorrect conversation option in Epilogue.
  • Fixed issue in Bloodlines conversation that caused player to enter into combat with non hostile enemies.
  • Shadowland post spelling/grammar/punctuation fixes.

Bug Fixes: Dead Man's Switch Campaign
  • Fixed issue that allowed players to save into a state where the Main character is Immortal.
  • Fixed issue that allowed Players to save into a bad state in Family Debts level.
  • Fixed issue causing enemies to spawn without orders resulting in a blocker in Family Debts level.
  • Rebalanced hired character Dodger for Telestrian Industries mission.
  • Rebalanced hired character Harlequin for the Hunt Begins mission.
  • Rebalanced hired character Tir Tairngire Ghost for the Hunt Begins mission.
  • Removed collision from prop that was causing potential play blocking issue in The Hunt Begins mission.

Known Issues
  • Loss of team in The Universal Brotherhood mission for save files that are updated in this level, Rewinding and re-hiring team will resolve this issue.
  • Inspect icon in Loose Ends mission can not be reached.
Last edited by Harebrained Schemes; Jul 29, 2014 @ 3:40pm
< >
Showing 1-15 of 30 comments
DivineForceSmash Jul 16, 2014 @ 5:17pm 
I just tried to, but it won't let me. When I am in Betas, and I click on the drop down menu, nothing happens. It is fixed on "NONE".
Harebrained Schemes  [developer] Jul 16, 2014 @ 5:29pm 
You may have to close the properties page and reopen it, one of our testers also was having simmilar issues with the drop down menu to work.
Sentient_Toaster Jul 16, 2014 @ 5:45pm 
Interesting. That makes riggers more interesting; I'd been leery of them since they appeared very dependent on non-stacking consumables.
xcooljox Jul 16, 2014 @ 7:11pm 
Mb some localization for Dragonfall plz :D
Last edited by xcooljox; Jul 16, 2014 @ 7:25pm
Hozomeen Jul 17, 2014 @ 2:39am 
Originally posted by xcooljox:
Mb some localization for Dragonfall plz :D
Фанатский перевод уже есть
Dead Aim Jul 17, 2014 @ 10:19am 
Hope we see a fix for dragonfall loading times because they take too long compared to dead man switch
13thGeneral Jul 17, 2014 @ 11:03am 
Looking forward to trying this out tonight. This could make riggers more useful with the drones now being healed betwen enemy encounters; it has been a point of frustration for a while.
cirion Jul 17, 2014 @ 7:59pm 
Thanks for giving us the chance to try this out! I'm seeing a bug that affects two of my UGC modules. This isn't a new bug - it was introduced sometime between 1.2.0 and 1.2.6 - but since you're doing an update, it would be fantastic to fix it!

Steps to reproduce:
1. Add an actor to Team Shadowrunner via a trigger during a scene (not via hiring).
2. Open the Equip screen (either by purchasing from a merchant or opening your stash).
3. Use the arrows to switch to your newly-added runner. [This is the critical step to reproducing this bug.]
4. Close the Equip screen.
5. Load a new scene with at least 2 Player Spawners.
6. Your second runner will now be named with an "_Avatar" suffix. They will have lost all their equipment, including their outft, and will appear "naked" (bra for females, underwear for males).

Let me know if you need any more details or anything. I can whip up a stand-alone Content Pack to illustrate the problem if that would help.

Thanks again!
Advent Tutly Jul 17, 2014 @ 11:35pm 
It's nice to see HBS still hard at work on updating this. I'll give my input. I haven't opt-ed for the beta, but I've started making my own campaign in the editor and came across a massive bug if you have a decking sequence.

If you're fighting in a decking sequence and lose, you get forced-jacked out of the Matrix (dump shock) and you lose HP, but if you log back into the Matrix and resume fighting where you left off and defeat your enemies, at the end of the combat round, the camera teleports back to your character in the real world world to do the auto heal and the camera stays stuck in the real world and just shows your character looped in this perpetual typing away on their data jack. You can't click to move or anything. The camera is stuck in the same camera region as your decking character's Host, it doesn't revert back to the Persona in the Matrix.

I've tried using triggers to fix this, like if the camera switches to the real world's camera region, to camera switch to the Persona, camera teleport to the Persona, remove the decking Host from camera focus, ignore it, all sorts of things, but this is something that appears hard coded. I can't get around it. The only thing that you can really do is give yourself a med pack before re-entering the Matrix to try again, to prevent the auto heal occuring in the first place.

And this doesn't just apply to dump shocks, it also applies to receiving any sort of Host damage in the Matrix, like from the Black IC enemies, who only specialize in doing Host damage. Same sort of deal. At the end of the combat round, the camera teleports back to the character's Host in the real world to do the auto heal. There really isn't going to be an easy fix to this, because this isn't just a coding issue, it's a design issue. The dump shocks are there to penalize the player if they screw up in the Matrix, and fairly so, but if the auto heal is implemented as it is, it sort of destroys that aspect of decking, removing any challenge. I'll do my best to offer ways to fix this with varying degrees of effort involved from the development team.

Possible Solutions:

Easy - Include a hard coded trigger that ignores the auto heal camera switch if a character is jacked into the Matrix.

Medium - Only apply the auto heal after a character has manually jacked out, but not if they were dumped shocked.

Hard - Remove the auto heal sequence altogether from a character who's jacked in.

How you fix this, or if you even fix it, is your choice. I'm not telling you guys how to do design on every microscopic thing of the game, just giving you an in-depth report on an issue that seems to be glazed over in favor of other things. You only have X amount of resources and Y amount of time to be addressing Z amount of things. Most gamers don't understand that, and they shouldn't. Their job is to enjoy the content or deride it.

DivineForceSmash Jul 18, 2014 @ 4:30am 
I hope vampires are in the next DLC.
locksheer Jul 18, 2014 @ 6:21am 
@ Advent Tutly Ran into that glitch in a nightmare harvest mod. Found that if I wait a couple seconds for system to finish loading assets (slow computer) then click the button to direct camera to main character at top of screen it jumps back into the matrix and to my avatar. I believe you have to have the camera unlocked to get the button to show up at the top (but maybe not.). The button looks like an arrow and it is just underneath the button that looks like a power button at the top of screen. Hope that helps.
Harebrained Schemes  [developer] Jul 18, 2014 @ 11:07am 
Hello all, and thank you for reporting these issues. Our testers will start looking into all of these issues. While they are doing this I would like to offer some possible feedback.

@Advent Tutly,
You may want to investigate forcing the game to remain in turn based mode until all actors are not jacked in. You can acomplish this with the Gameplay trigger Enable/Disable Manual Turn Mode, and have it trigger On Host Jacked Out or when all Shadowunners exit the Matrix dimention (On Region Exit).
The Defenestrator Jul 21, 2014 @ 10:03pm 
Awesome that updates are still being worked on, HBS really goes above and beyond most other game companies with their support, thank you.
Skysect Jul 22, 2014 @ 1:22pm 
Here is my latest report about remaining issues about glitches , [link][/link] . sorted for all races and genders . without cyberware parts . Please also test them with cyberware parts . Thanks .

Hope they will fix in 1.2.7 :)

I was posted that message long time ago . Game and engine is awesome I think and I bought both dlc and base game triple times , and will buy next dlc's too . but that texture issues butchering my joy . Please fix them . Thanks .
Harebrained Schemes  [developer] Jul 22, 2014 @ 2:10pm 
Thank you for bringing that to our attention, and we will look into what can be done to fix these texture issues that you are seeing.
< >
Showing 1-15 of 30 comments
Per page: 15 30 50

Date Posted: Jul 16, 2014 @ 4:44pm
Posts: 30