Prison Architect

Prison Architect

View Stats:
Blackice010 Aug 1, 2014 @ 8:28am
Resolution and mouse cursor problems (display scaling) [fixed]
In fullscreen mode the cursor is not at the same place as the actual mouse pointer. To be able to click on something i have to aim to the right and down from whatever i want to click. In windowed mode the cursor is at the right place but the window is much larger in size. A 1600*900 window will not fit on my 1920*1080 screen. It is unplayable at full sceen mode and if i want to play in windowed mode i have to set it to a very low resolution.

I normally use two monitors (1: 1920*1080, HDMI - 2: 1600*900, DVI). But for the sake of trying fix this i disabled the second monitor and the problems were still there. I figured the game might see both desktops as one or something.

My system:
Win 8.1 64bit
AMD R9 290X
Windows is set to 135% custom size option, perhaps this has something to do with it. (Control Panel\All Control Panel Items\Display > Change the size of all items)


Edit: I found a solution!

The custom size was the problem. The PA window was at 135% size and in full screen it somehow still finds the wrong location for the mouse cursor (135% of the actual position of the cursor).

To solve it you go to the game's .exe file, select properties, go to the Compatibility tab and enable 'Disable display scaling on high DPI settings'. Things are back to normal now, but the devs should disable scaling by default.

The problem can also be caused by a vertical taskbar (thanks osh24lager).

The new Win 10 Creator's update has changed the DPI setting. It is now called Override high DPI scaling behavior. Scaling performed by: Application
Last edited by Blackice010; Jun 18, 2017 @ 4:36am
< >
Showing 46-59 of 59 comments
GamerCasual Nov 22, 2018 @ 8:59am 
Originally posted by CaptainDiptoad:
Here we are 4 years later, and its still a problem. Thank you!

Not in FFXIV anymore .. they grew a brain and incorperated mouse configs in the settings. In SWTOR it is still and issue. I havnt come across any other game that has the Teenie Tiny mouse issue yet though.
Faux Nov 30, 2018 @ 9:19am 
omg thank u so much :firewalk:
Where exactly are the games .exe file located for me to do this? because I am unable to find Sid Meier's Civilization VI.exe in order to change it.
Blackice010 Dec 5, 2018 @ 8:43am 
Originally posted by o·°TheGuru°·o:
Where exactly are the games .exe file located for me to do this? because I am unable to find Sid Meier's Civilization VI.exe in order to change it.
Right click the game's properties in the Steam library and go to Local Files > Browse
Do a search for exe if you can't find it (might be located in some Bin or x64 folder)
Last edited by Blackice010; Dec 5, 2018 @ 8:44am
ArcadeKingz Dec 6, 2018 @ 8:28pm 
i have this problem with the steam itself in windowed mode. Will someone walk me through changing steams DPI settings to fix this?
Blackice010 Dec 7, 2018 @ 2:04am 
Originally posted by ArcadeKingz:
i have this problem with the steam itself in windowed mode. Will someone walk me through changing steams DPI settings to fix this?
You should probably try Steam's own Interface settings (Scale text and icons). Other than that its the same, find the Steam.exe file where you've installed it.
StormReavan Dec 31, 2018 @ 4:10am 
Windows 10 had an update (as of 31DEC18). The DPI scaling not only caused the offset issue, but it also caused drop down menus (like in the Steam Workshop), to close when you moved the mouse or after releasing your mouse button during the action of clicking.

The W10 update changes the compatibility settings, allowing you to use application DPI scaling, System Scaling, or 'enhanced' System Scaling. Make sure the DPI scaling is set to application and it may fix the issue.
One_Spooky_Glove Jan 11, 2019 @ 1:51pm 
Originally posted by static:
A silver bullet solution!
Indeed! I got here from "spore mouse offset" on google, and this worked for me in both Spore and OpenTTD!
『Połało』 Mar 14, 2019 @ 4:15pm 
Its not working for menplease help
Gulzar Jul 11, 2019 @ 1:07pm 
I cant believe this is still an issue today.
Thank you for this !
Happy gaming
Kovi Aug 21, 2019 @ 6:59pm 
The god amongst men! really saved me. Couldn't find an answer for a while!
Noxria Nov 16, 2019 @ 2:26pm 
I found that if you remove fullscreen then apply it, it fixes the problem
None of these fixes are working for me :(

1. The Compatibility tab no longer has the 'Disable display scaling on high DPI settings' option.
2. There is now a checkbox for 'Override high DPI scaling behavior.' - unchecking that box did not solve the problem.
3. With the box checked, there are three options available in a 'Scaling performed by:' dropdown
- 'Application' (picking this option did not fix)
- 'System' (picking this option did not fix)
- 'System (enhanced)' (picking this option did not fix)

I tried checking 'Disable fullscreen optimizations' (did not fix)
I tried re-checking 'Disable fullscreen optimizations' (also did not fix)

I tried changing my taskbar to vertical (did not fix)

I see that nobody has posted on this thread for 7 months... happy for all the people who got it working, but I don't know what to do.
seco18 Jul 29 @ 8:46am 
had to log in to thank you! really good , thanks
< >
Showing 46-59 of 59 comments
Per page: 15 30 50

Date Posted: Aug 1, 2014 @ 8:28am
Posts: 59