Company of Heroes 2

Company of Heroes 2

View Stats:
Guntrip Jul 13, 2013 @ 8:15pm
Intermittent freezing
I'm having a strange issue where the game freezes for 3-5 seconds at seemingly random intervals throughout a game. This happens in single player as well as multiplayer. I've tried turning all the settings down but that doesn't seem to affect it, and FPS is pretty high all the rest of the time I'm playing. Has anyone else experienced anything similar?

My hardware: i5 4670K, GTX 770, 16GB RAM
< >
Showing 1-15 of 35 comments
Mechles (Banned) Jul 13, 2013 @ 9:58pm 
yeah i get them two i feel like my game is gonna crash then BAM its back to normal and its random could just be FPS lag
ex0toxic Jul 14, 2013 @ 4:26am 
Same happens to me although it it more 1-2 seconds, the sound gets stuck/repeats too.
StarStorm Jul 14, 2013 @ 5:10am 
For me it is longer and results in a crash... Haven't been able to finish a single game since the update.
Symptoms are the same though, if more lengthy..
Guntrip Jul 14, 2013 @ 10:50am 
I've tested it a few more times with low settings and high settings, nothing seems to make a difference to how frequent it is. I've watched the entries being written to warnings.log during a game and nothing appears to be logged when it happens. I also tried setting affinity of the RelicCOH2.exe process to a single core, that didn't seem to do anything positive either.

If I run the game windowed, the title bar changes to have "(Not responding)" appended, so Windows definitely knows it's stalling which I guess also explains why everything else on the system keeps running happily.
mkza Jul 15, 2013 @ 2:49am 
Ditto. Happening to me too.
Guntrip Jul 15, 2013 @ 4:03pm 
It doesn't seem to be happening any more (fingers crossed), but since I've not changed anything I was assuming they'd updated but I've not seen any patch notes...

Now a friend with a different Nvidia card is having problems, this time a freeze followed by having to kill the application.

Swings and roundabouts.
mkza Jul 16, 2013 @ 7:42am 
I disabled the 2nd LCD on my system. That seemed to help a bit. My desktop is now not extended to the 2nd screen.
Guntrip Jul 20, 2013 @ 12:56pm 
It seems to be back, I'll try disabling the other monitor.
PipzaLover Jul 20, 2013 @ 2:17pm 
I have gotten the same issue. Well, it's more like a 2 seconds freeze.
It began when I got a new cpu and mobo: i5 4670K on Asus Z87-A
I didn't do a clean install, because Windows booted perfectly. I came from an i5 750 on an Asus P7P55
I have of course updated all relevant drivers.
No other games or programs show this behavior
Only one monitor is connected
Last edited by PipzaLover; Jul 20, 2013 @ 2:23pm
mkza Jul 20, 2013 @ 11:25pm 
Yeah, also about 2 seconds freeze for me. Weird.
AlexanderTheGr8 Jul 21, 2013 @ 12:42am 
Same thing happens to me. Switching to one monitor doesn't fix it.
mkza Jul 21, 2013 @ 5:57am 
Process of elimination I guess.

I changed my graphics settings to:

Display Resolution 1920 x 1080 @ 59.94Hz (widescreen)
Gameplay Resolution 100%
Image Quality Low
Anti-Aliasing Off
V-Sync Off
Texture Detail Low
Snow Detail Low
Physics Off

Then played Mission 7 and only found it froze once and for about 1 second.
PipzaLover Jul 21, 2013 @ 4:10pm 
Just reinstalled the game, reinstalled newest drivers. Made game auto setup graphics, audio on default.
Didn't fix the problem....
This problem wasn't there on the old cpu+mobo. But II can't rule out a possible game update coinsiding with my hardware upgrade.
Last edited by PipzaLover; Jul 21, 2013 @ 4:22pm
mkza Jul 21, 2013 @ 10:28pm 
I changed GamePlay Resolution to 66%, then played Mission 9 on Captain. Seemed to make it worse. Got more intermittent freezing. Will try on 33% tonight. Not hopeful.

If not the graphics settings ... what else to try?
mkza Jul 22, 2013 @ 9:56am 
Try VSYNC set to OFF
< >
Showing 1-15 of 35 comments
Per page: 15 30 50

Date Posted: Jul 13, 2013 @ 8:15pm
Posts: 35