Cities XL Platinum

Cities XL Platinum

Cities XL Platinum > 総合掲示板 > トピックの詳細
Game crashes 60 seconds into loading a map
Here are the last two lines in the log files:

[18:58:45] SCRIPT csLuaState.cpp ( 291) ErrorBuild LUA_ERRRUN : runtime error ([string "data\design\script\tutorial\achievement.lua"]:251: bad argument #2 to 'max' (number expected, got string) stack traceback: [C]: in function 'max' [string "data\design\script\tutorial\achievement.lua"]:251: in function 'Update' [string "data\design\script\tutorial\achievementsmgr..."]:174: in function 'Update' [string "AchievementsMgr:Update()"]:1: in main chunk)
[18:58:45] SCRIPT csScriptFunction.cpp ( 164) ErrorBuild csScriptFunction::Call Lua exception in : AchievementsMgr:Update()

Doesn't matter if I load up a brand new map, or an existing map with 6.6m people, or anything in between. This always comes up. Any ideas?
< >
1-11 / 11 のコメントを表示
were u using mods?

looks like ur achievement file got toast

try renaming

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012\live\offline\solo\adat.cxl

or editing it

they should be in the form

<tab key='<name>' >
<itm key = 'completed' value = 'false' />
<itm key = 'completedLevel' value = '0' />
<itm key = 'active' value = 'true' />
<itm key = 'id' value = 'TransportCapacity' />
<itm key = 'completion' value = '0' />

so look for corruption of invalid entry

if that persists

if the problem persist try creating a new map, saving it, exiting it, loading it again and see if it occurs with your new map

if that occurs then there is something w your game, did u verify game cache, and make sure u are not loading any 3rd party mods/patches/addons, ect

also each map has its own acheivement section

if the map achievement data has become corrupt look in

C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012\live\offline\solo\solosaveregion<r>map<m>\auto

autosave in that folder has achievements


and each save in that folder has achievements


where r,m,n are numbers

look in there and make sure the map saves are good

<tab key="AchievementStats">-<tab key="BuildingCount"><itm value="0" key="fuel"/><itm value="4" key="education"/><itm value="7" key="manufacturing"/><itm value="0" key="landmark"/><itm value="12" key="hightech"/><itm value="0" key="water"/><itm value="12" key="office"/><itm value="369" key="General"/><itm value="0" key="electricity"/><itm value="0" key="environment"/><itm value="16" key="civicservice"/><itm value="0" key="waste"/><itm value="0" key="hotel"/><itm value="0" key="leisure"/><itm value="3" key="fireservices"/><itm value="262" key="residence"/><itm value="30" key="retailgoods"/><itm value="4" key="security"/><itm value="24" key="heavyindustry"/><itm value="4" key="health"/><itm value="6" key="field"/></tab><itm value="89" key="RoadLengthCount"/></tab>

see the numbers if u look at above error it says there is some string (text) where there should be a number!

could be the xml is corrupt
最近の変更はThe doctor is inが行いました; 2013年3月30日 19時42分
I am not using any mods. I have not downloaded or installed any mods.

I have 8 support citites that feed my primary 6.6million population city.

You mention to rename or edit "C:\Users\<username>\AppData\Local\Focus Home Interactive\Cities XL 2012\live\offline\solo\adat.cxl" What should I rename it to? What effect does this have?

My adat.cxl has the same structure that you mention. It looks like an XML tree. Each "tab key" has a different value, but has the same xml structure.

Each XML node has the same structure of:
<tab key='<name>' >
<itm key = 'completed' value = 'false' />
<itm key = 'completedLevel' value = '0' />
<itm key = 'active' value = 'true' />
<itm key = 'id' value = 'TransportCapacity' />
<itm key = 'completion' value = '0' />

How am I supposed to regonize "a corruption of invalid entry?"
u can rename it anything

it will hopefully create a new one

u just resetting your achievements

the problem is that y have corrupt achievements file

how do u know its corrupt look at yours it must match that pattern for each entry and make sure where the value is a number like above yours has a value too

look at the error it says it all

the file is corrupt and when its trying to read a number it gets a string instead

try renaming it first if that fixes it u know its that file

else if could be a game save that went bad

hopefully u have more than the autosaves, hopefully u have been backing up your cities as well
Renaming the adat.cxl file worked. Thank you. Will my achievements slowly roll in over time then as a play? Also, since renaming the file worked, I should be able to go into the old achievements file and try to find the corrupted XML block and fix it, correct?

While I'd like to keep my achievements, its not of the utmost goal for me. Building up interdependent cities are.

Again, thanks for your help.
I think I found the problem.

<tab key='RoadLength' >
<itm key = 'completed' value = 'false' />
<itm key = 'completedLevel' value = '2' />
<itm key = 'active' value = 'true' />
<itm key = 'id' value = 'RoadLength' />
<itm key = 'completion' value = '1.#QNAN' />

I'm guessing the completion value for the RoadLength achievement should not be "1.#QNAN' I should be able to put in the proper number there (if I can figure out what it is) and rename the adat.cxl back to its original name and see if it works, correct?
look at the value

<itm key = 'completion' value = '1.#QNAN' />

its nan, so the floating point operation resulted in nan

most likely


or arithmetic operations on infinity

and it stored it there and unforunately deserialization cant handle nan

so change it to 0

nan should not be 0 but its the closes im guessing else try putting some number

and yes u can rename it back and yes u can edit it

u just have to fix all the problems like this one
最近の変更はThe doctor is inが行いました; 2013年3月31日 9時07分
so the game was running great, you did what and this happened

do u recall what what was
I dont specifically remember doing anything. I just loaded up my primary city as usual, and about 60 seconds into it - WHAM - crash. It then did the same thing to any current or new map from there on out until i applied your fix. Maybe somehow I got to the next level of the road achievement on the previous session and it got messed up then, and only felt it the next time I loaded up a game? Its the only thing I can think of.

please create support ticket with focus

what issue is basically their serialization code can handle writing nan

but the deserialization code cannot handle how they serialize nan

now they may not be able to fix it cause they didnt write lua and i suspect the problem is with the lua library they are using
Unfortunately it occured again. Even after renaming the file, having a new one built, the same 1.#QNAN occured again. Seeing how this problem re-occurs even with a file rename, I'm not sure how I can ever play this game again since the error comes back after a short period of time.

Oh well, I had over 500 hours into this game, got a 6.6m pop city with $3mil in positive cash flow, so I felt like I pretty much did everything I could do. Time well spent - fun game but I'm not sure how I can overcome this.
please create support ticket with focus

they will hopefully fix it

also there is no need to stop playing the game, its just a bug

if it just

<tab key='RoadLength' >

if so you may have some road whose length is invalid!

see which map you have opened and fix it

最近の変更はThe doctor is inが行いました; 2013年4月1日 16時54分
< >
1-11 / 11 のコメントを表示
ページ毎: 15 30 50

Cities XL Platinum > 総合掲示板 > トピックの詳細
投稿日: 2013年3月30日 17時15分
投稿数: 11