War for the Overworld

War for the Overworld

View Stats:
This topic has been locked
Noontide  [developer] Jul 7, 2015 @ 5:55am
Common Issues & Solutions & FAQ (Incl. Laggy UI Workarounds)
Hey Folks,

With 1.1.15 now out we've decided it's high time to tidy up the forums a little and focus some potential solutions to commonly faced issues as they're discovered. Due to the wide range of hardware configurations we can't promise that all solutions will work for all users, in addition you may find that they will be rendered obsolete or unneeded in future patches.

Common Issues & Solutions

Issue 1: My game is crashing on start-up

We've become aware of a few common issues for a small subset of Hardware and Software configurations that are preventing War for the Overworld from launching correctly. The work-around's below are known to prevent these common crashes if you're suffering from them.

Case 1: The game is crashing before the WFTO Logo splash appears
This issue occurs when the automatic installation of the .NET framework failed. This software is necessary for WFTO to launch and if the installation failed you may find that you do not have the correct version of this framework.

To solve try manually installing the correct .NET framework from the Microsoft website[www.microsoft.com] using their offline installer.

Case 2: The game crashes on launch, after the splash screen
This has been known to occur when certain wireless headset drivers are running, you may also experience this issue in other unity based games. To test and potentially solve follow this troubleshooting process:

  1. Unplug your Wireless USB Headset/Headphones
  2. If the game now starts, make sure your headphones are set as the main audio device via windows playback devices and try again
  3. If your game still crashes try the workaround in this post[forum.subterraneangames.com]

Case 3: Black Screen after WFTO Splash
Believed to be caused by an unknown driver incompatibility when runnning on latest Windows OS. This has only affected one person to date but please let us know if you are affected.

  1. Navigate to your WFTO Steam Folder
  2. Right click WFTO.exe and open properties
  3. Open the compatibility tab and set the compatibility mode to Windows 7
  4. Do the same for WFTOGame.exe

Case 4: AVG Anti-Virus false positive (Should be fixed in latest versions of AVG)
AVG Antivirus has a heuristic algorithm that detects WFTO as malicious, this is a false positive that to our knowledge only presents on AVG. If AVG is running you may find that your WFTO fails to launch or crashes on start-up.

  1. Disable your Antivirus to see if WFTO now runs
  2. If so then add an exception for WFTO and it's folder contents in the steam library

General Crash Troubleshooting
  • If WFTO has suddenly started crashing after an update be sure to verify your steam cahce for the game. Do this by opening the properties menu on the library entry, select "Local files" and click "Reverify steam cache"
  • If push comes to shove try reinstalling the game

Issue 2: My UI has not appeared on the main menu or the game/UI is extremely laggy on start-up

This is usually an issue that occurs when you have both an in-built and dedicated graphics card in your system. In some cases the primary card is incorrectly reported to WFTO and the game is instead loaded using the inferior in-built card. In this case some settings will need to be changed in your graphics control panel to ensure WFTO uses the correct card.

Another case which appears to have arrived with the 1.1.15 patch is that some systems are not correctly picking between DirectX 9 and 11, which is not working correctly on some systems. We're investigating the cause of this and expect it to be resolve in the near future, but in the meantime be sure to try both Case 1 & Case 2 solutions below.

Case 1: WFTO Loading on incorrect Graphics Device.

Follow the instructions below based on what GPU you have (NVidia or AMD).

How to force the more powerful AMD GPU to turn on:
  1. First, go to the AMD website[support.amd.com] and download and install the latest drivers for your GPU.
  2. Right click on your desktop -> Select "AMD Catalyst Control Center"
    This should open your graphics card control panel.
  3. Select "Power" -> "Switchable Graphics".
  4. In the page displayed, disable Switchable Graphics.
  5. Launch the game to test.

How to force the more powerful NVidia GPU to turn on:
  1. First, go to the NVidia website[www.nvidia.co.uk] and install the latest drivers for your GPU.
  2. Right click on your desktop -> Select "NVIDIA Control Panel"
    This should open your graphics card control panel.
  3. Select "3D settings" -> "Manage 3D settings" -> "Global settings".
    In the drop-down menu "Preferred graphic processor" select "High-performance NVIDIA processor" instead of "Auto-select".
  4. Launch the game to test.

If the above doesn't work you can attempt to force the switch specifically on WFTO.

Forcing WFTO to use your Nvidia GPU
  1. Open Nvidia control panel as above
  2. Select 3D Settings and reset your settings to default
  3. Select "Program Settings" tab from the 3D Settings menu
  4. Add WFTOGame.exe from your WFTO Directory (You can find this by rightcliking the game in steam, going to properties and clicking "Browse local files")
  5. In addition be sure to add "CoherentUI_Host.exe" with the same settings below.
  6. Select "High-performance Nvidia Processor" as the preferred graphic processor as above.

Case 2: Incorrect rendering mode (DX11 instead of DX9 loaded or vice versa)

If you have tried the above Case 1 solution but that has not worked and you are on a Windows system then you can try forcing WFTO to launch in DX9 mode or DX11 mode. To do this follow these instructions.

  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add "-force-d3d9" in this box (No quotation marks)
  4. If this fails and you have a DX11 compatible GPU then add "-force-d3d11" instead.

Please report if either of these solutions have or have not worked for you.

Case 3: AMD Crossfire Incompatibilty

We've received a report from our UI Middleware provider that there are some incompatibilities with certain AMD Crossfire setups. In their tests they found that users with AMD Crossfire were more likely to suffer from the missing UI issue.

Coherent are continuing to investigate this issue for now you should attempt to disable AMD Crossfire via your catalyst control center if you are suffering from this issue. Please report back if this helps to resolve your issue.


Issue 3: People can't see or join my Multiplayer Games

If other players are unable to see or join your Multiplayer games it suggests that your router or personal firewall is blocking connections to your computer/WFTO.

We've written an extensive thread on this topic and you can find that here
Last edited by Noontide; Jun 24, 2016 @ 3:57am
< >
Showing 1-15 of 73 comments
Noontide  [developer] Jul 7, 2015 @ 5:55am 
Frequently Asked Questions

Q: I've heard I can unlock Dungeon Themes for use in Skrimish & Multiplayer, which themes can I unlock and how?

There are Eight playable themes in the game including the Standard theme available to everyone. Three other themes are unlocked via gameplay, while the four remaining are unlocked through special editions of the game.

Gameplay Unlockable Themes

Rhaskos: The Theme of Underlord Rhaskos who you defend in Level 7, this theme is unlocked by completing the entire campaign start to finish

Mira: The Theme of Underlord Mira, encountered in Level 10 and 11, this theme is unlocked by completing all special achievements in the campaign i.e. Scott Richmond, Leeerrrooooy

Korvek: The Theme of Underlord Korvek, encountered in Level 12, this theme is unlocked by completing all speed run achievements in the campaign i.e. 50 Shades

Edition Specific Themes

Sovereign: The Theme used by Underlord Marcus in Level 4, this is a special theme available only to players who have purchased the "Underlord" edition

Kickstarter: The Theme used by Underlord Draven in Level 12, this is a special theme available only to Kickstarter Backers who pledged at tier 4 and above.

Founders: The Theme used by Underlord Kasita in Level 12, this is a special theme available only to Kickstarter Backers who pledged at tier 8 and above.

Evil Arcane: This Theme is a corrupted version of the Empire theme seen in Level 10, it is only available to owners of the Physical edition or players who purchased the game before April 2nd.

Non-Unlockable Themes

Empire: The Standard Empire theme seen on many levels, this theme is not currently available to players.

Dwarven: An Empire Theme that is used on several levels, the theme is not currently available to players.

Arcane Fortress: An Empire Theme used on Level 10, this theme is not currently available to players.
Last edited by Noontide; Jul 7, 2015 @ 6:46am
Noontide  [developer] Jul 7, 2015 @ 5:55am 
Reserved
nutter666 Jul 7, 2015 @ 7:46am 
Reserved for replying to Lee's Reserved Post :P
Noontide  [developer] Jul 7, 2015 @ 7:48am 
Reserved for banning Nutter after reading his reserved reply to my reserved post
Last edited by Noontide; Jul 7, 2015 @ 7:48am
nutter666 Jul 7, 2015 @ 11:00am 
Originally posted by Noontide:
Reserved for banning Nutter after reading his reserved reply to my reserved post
Banning me? Or Mega Banning me? :P
123 Jul 14, 2015 @ 9:49pm 
my game still wont load it worked fine in beta and now wont even load since it went live ive already done everything suggested and i want it fixed now you have had my info and settings since the game went live its time you fixed my issue or i want my money back this is getting beond a joke
ladyheather_86 Jul 15, 2015 @ 3:08pm 
My game is still lagging really badly... 1. Tried the DX9 change. 2. Tried the AMD website thing, the download won't work on my system apparently :( 3. Tried the Nvidia thing, I get it to scan my system then it just keeps asking me to download the updated version of Java, so it can run the scan... Even after downloading it! Seemed to work ok before the latest patch... any more suggestions please :)
RwCC Jul 15, 2015 @ 4:50pm 
Sick of my game not working with your work arounds. I want a refund.
Noontide  [developer] Jul 15, 2015 @ 7:00pm 
Originally posted by oostyduo:
my game still wont load it worked fine in beta and now wont even load since it went live ive already done everything suggested and i want it fixed now you have had my info and settings since the game went live its time you fixed my issue or i want my money back this is getting beond a joke

Hi oostyduo,

Sorry to hear your concerns have not been addressed. Please can you link me to your original topic on our official forums and I'll see if I can get it addressed.

In the meantime have you tried the standard solutions. Verifying your steam cache, reinstalling the game, graphics driver updates etc?

Originally posted by RwCC:
Sick of my game not working with your work arounds. I want a refund.

Can you provide some more information please RwCC? I need to know exactly what is wrong with your game to even begin helping.

Originally posted by ladyheather_86:
My game is still lagging really badly... 1. Tried the DX9 change. 2. Tried the AMD website thing, the download won't work on my system apparently :( 3. Tried the Nvidia thing, I get it to scan my system then it just keeps asking me to download the updated version of Java, so it can run the scan... Even after downloading it! Seemed to work ok before the latest patch... any more suggestions please :)

Very unusual indeed, I wonder if you'd be able to chuck us your system specs as per the stickied thread

And to clarify is this issue permanently present in game or only at certain points?
westicules Jul 16, 2015 @ 10:30pm 
"Select "3D settings" -> "Manage 3D settings" -> "Global settings".
In the drop-down menu "Preferred graphic processor" select "High-performance NVIDIA processor" instead of "Auto-select".
Launch the game to test."

my Nvidia control panel does not have the drop-down menu under the global settings tab or the programs setting tab.

any ideas? i'm stuck

also, i tried the -dx9, which did not work.

GPU- GeForce GTX 550 Ti
CPU- AMD Phenom(tm) 9650 Quad-Core Processor
Memory- 8GB RAM
Current resolution- 1920-1080, 60Hz
Operating system- Microsoft Windows Vista, Home Premium

Please help, i love dungeon keeper, and i think i would really love this game if i can ever actually play it. the game opens, but no menu shows up on the title screen.
Last edited by westicules; Jul 16, 2015 @ 10:38pm
Noontide  [developer] Jul 17, 2015 @ 8:00am 
Originally posted by westicules:
also, i tried the -dx9, which did not work.

Hey Westicules,

Can you try -force-d3d9 instead?
Noontide  [developer] Jul 17, 2015 @ 8:07am 
Added a third known case where the missing UI bug would occur. This is exclusive to certain hardware configurations using AMD Crossfire. If you're using AMD Crossfire and suffering from this issue please see Case 3 in the OP.
westicules Jul 17, 2015 @ 10:06am 
hoooooly♥♥♥♥♥♥the -force-d3d9 actually worked! thank you so much!!!
Noontide  [developer] Jul 17, 2015 @ 7:16pm 
Originally posted by westicules:
hoooooly♥♥♥♥♥♥the -force-d3d9 actually worked! thank you so much!!!

Great to hear that westicules, hope you enjoy the game! I've updated the OP with this property as I suspect this will help more players than the original will.
Karasique Jul 19, 2015 @ 5:59am 
It started out alright for the first few missions but since mission 7 I'm experiencing micro stutter every few seconds that is especially noticeable while panning.
I tried googling the issue and found this thread - https://steamcommunity.com/app/230190/discussions/0/594820656473202049/ - but it isn't resolved as far as I can see.

My configuration is:
CPU - i5 2500K
GPU - Geforce GTX 970
RAM - 16 GB
Running Windows7 64bit

Changing graphics settings ingame didn't make any difference whatsoever.
< >
Showing 1-15 of 73 comments
Per page: 15 30 50

Date Posted: Jul 7, 2015 @ 5:55am
Posts: 73