War for the Overworld

War for the Overworld

View Stats:
Noontide  [developer] May 28, 2016 @ 5:16pm
Patch 1.4 Known Issues & Workarounds
Hello Underlords,

We are aware of a number of issues that appear to be affecting a small number of users. This thread will track known issues in the current patch and any workarounds we have for them.

We'd also like you to report if you have this issue to us on our bug tracker[brightrockgames.userecho.com] by doing so you'll be able to see the progress on a fix for the issue as well as help us identify the root cause. When reporting a bug be sure to follow our reporting guidelines.[forum.subterraneangames.com]

Help my game crashes or my UI is missing!

Firstly if you're experiencing a crash then it's extremely important you try the solutions provided in this thread.

The vast majority of crashes are resolved by following these simple instructions and many of the crashes caused by those are beyond our remit to fix. (They're a result of missing dependencies or driver conflicts) but the instructions there will help you resolve the issue.

If you're still experiencing a crash after trying the solutions provided then submit a bug report to us directly as described above.

Known Issue: Extremely low resolution on startup (Hotfixed 1.4.0f5)

We are aware some users were experiencing their game defaulting or dropping to a low resolution when they first start it up after the patch. This has been hotfixed in Patch 1.4.0f5, if you are still having issues please use the following workaround and report back to us!

Workarounds

https://youtu.be/z2QdUeVNfSw

  1. Open the game and wait for the main menu to appear
  2. Open the options menu
  3. Change the display mode to windowed
  4. Change the resolution to a higher resolution (preferably your native resolution) You may need to click around a little for it to apply. (When clicking resolution you may see a small line appear above the box, click the line and you should change the resolution to something usable)
  5. Change back to fullscreen mode

Alternatively try the solution proposed in this thread (OS X users see the last comment on page 1 for the path to your options.txt)

Known Issue: Unable to Tag or Select blocks

A very small number of users has reported this issue and we are still investigating the cause. We have provided a potential workaround below. if you are suffering from this issue please report it directly to us with all the information requested. The more reports we have of this the sooner we will be able to hotfix.

Workarounds

Some users report that forcing DX9 rendering mode addresses this issue.

  1. Right click the game in your steam library and go to properties
  2. Click "Set launch options"
  3. Add "-force-d3d9" in this box (No quotation marks)
Last edited by Noontide; May 30, 2016 @ 11:51am
< >
Showing 1-15 of 26 comments
puck_theprankster May 28, 2016 @ 9:03pm 
Just bought and installed and unable to tag any blocks. tried both with mouse control and touchpad on my laptop.
PottedPlantofDeath May 28, 2016 @ 11:02pm 
I can't tag blocks.
imran.white5 May 29, 2016 @ 1:23am 
Hi Noontide. The 'window mode' solution worked for me! One thing I would suggest editing in the OP is that the 'Display mode' option is the third option within the Display Options menu - it took me a long time finding it when viewing in low resolution.
wolf2440 May 29, 2016 @ 2:20am 
digging
i have just got war for the overworld and for some reason i cant dig out rocks. any idea why???
BlackBeard May 29, 2016 @ 2:23am 
probably some corrupted files ..


try this:

1) verify the integrity of the game cache through Steam

2) reinstall the Directx that you find in the following location

D: \ Program Files (x86) \ steamapps \ common \ War For The Overworld \ _CommonRedist \ DirectX \ Jun2010

if it does not help contact the official support
https://brightrockgames.userecho.com/

following this guide
https://forum.subterraneangames.com/threads/please-read-how-to-report-a-bug.4689/#post-51529
wolf2440 May 29, 2016 @ 2:24am 
thanks ill give it a try
Sbiancolo May 29, 2016 @ 3:09am 
I have the exact same issue. @wolf24400 did @blackbeards advice help?
Amduscas May 29, 2016 @ 3:21am 
Just bought this since I've been after it for a while and saw it on sale. Can't tag blocks. Give me my instant gratification. :P
wolf2440 May 29, 2016 @ 3:22am 
Hi, ive verified the steam cache and made sure the directx is installed properly, unfortunately it hasnt worked. I will report the issue via the links above
Noontide  [developer] May 29, 2016 @ 3:49am 
Originally posted by puck_theprankster:
Just bought and installed and unable to tag any blocks. tried both with mouse control and touchpad on my laptop.

Originally posted by allison_n131:
I can't tag blocks.

Originally posted by Amduscas:
Just bought this since I've been after it for a while and saw it on sale. Can't tag blocks. Give me my instant gratification. :P

Hi guys, really sorry that you're affected by this issue, it's our highest priority ticket right now and we're feverishly investigating.

To help us out please can you comment in this thread[brightrockgames.userecho.com] and include your hardware specs and a link to your output log. (You can find instructions here[forum.subterraneangames.com]

We have a few working theroies but the more data we have from you the quicker we can find a solution!

Originally posted by imran.white5:
Hi Noontide. The 'window mode' solution worked for me! One thing I would suggest editing in the OP is that the 'Display mode' option is the third option within the Display Options menu - it took me a long time finding it when viewing in low resolution.

Good to hear I'll change the op now.
Noontide  [developer] May 29, 2016 @ 5:39am 
Heads up: Added a workaround for the unable to tag issue. Let us know if it works.
wolf2440 May 29, 2016 @ 10:09am 
this fixed the issue for me:

Known Issue: Unable to Tag or Select blocks

A very small number of users has reported this issue and we are still investigating the cause. We have provided a potential workaround below. if you are suffering from this issue please report it directly to us with all the information requested. The more reports we have of this the sooner we will be able to hotfix.

Workarounds

Some users report that forcing DX9 rendering mode addresses this issue.

Right click the game in your steam library and go to properties
Click "Set launch options"
Add "-force-d3d9" in this box (No quotation marks)
Simburgur  [developer] May 30, 2016 @ 6:00am 
Hey guys,

We've managed to repro the resolution issue - it seems to be only occurring on specific AMD cards, possibly only older ones. Now that we've got it isolated we can work on a fix. Thanks for all the info you've provided!
guitar_chick05 May 30, 2016 @ 6:29am 
The work around for the screen resolution issue would work better if one could see the menu for the screen resolution options. Unfortunatelly the list of available resolutions is supposed to be a drop-down menu, but it does not drop down, but rather displays above the current screen resolution (640 x 480) and then disappears out of the window so that the user can only pick one option. It would have been easier if this menu had "dropped down" like it was intended. I was still able to fix my screen resolution though. Hopefully we can get some fixes soon! :)
Ratak the Warden May 30, 2016 @ 11:24am 
No change for me, not even the hotfix, seems i was putting trust into the impossible, i'll be playing another true dungeon keeping title.
< >
Showing 1-15 of 26 comments
Per page: 15 30 50

Date Posted: May 28, 2016 @ 5:16pm
Posts: 26