A Valley Without Wind 2

A Valley Without Wind 2

View Stats:
skin2yard Jan 3, 2013 @ 6:37am
gamepad doesnt work properly
so i can use A,X,Y,B, RB,LB, RSB, LSB, buttons, but i cant move, and i cant remap the controlls, please fix it... i play on a razer onza and it works perfect with almost every game except this and 30 sec hero... i also have a nostromo installed, someone mentioned i should uninstall the nostromo, but how about devs doing their job? since my onza works on every other game (except those few exceptions).
< >
Showing 1-15 of 23 comments
tigersfan  [developer] Jan 3, 2013 @ 6:48am 
I'm sorry you are having issues. When you say you can't remap them, what does that mean? What happens when you try to do so? Do you get any errors?

Could you test it with out the nostromo installed? I'm not saying it's a permanent solution, but, it would help us to know if the issue is related to that or not.

skin2yard Jan 3, 2013 @ 6:57am 
sorry for being unclear, i tried just now every button, and the game doesnt recognize LT,RT, LS, RS, up, down, left, right on the pad.... so i cant remap any of those... ill try to uninstall the nostromo, but just so you know, im taking this one for the team, i have alot of profiles on my nostromo.... btw... nice to have some devs answer questions so fast for a change
skin2yard Jan 3, 2013 @ 7:06am 
i uninstalled my nostromo and it works fine now... but please guys, fix this, its pretty anoying... i didnt mind stuff like that, but lately, i spend more time configuring controlls than actually playing games...im just tired of it

ps. i forgot my manners...thx for the free game guys
Last edited by skin2yard; Jan 3, 2013 @ 7:09am
tigersfan  [developer] Jan 3, 2013 @ 7:12am 
Hmmm, well, if the Nostromo is causing the problem, it might well be an issue in their software, not ours. That said, I'll pass this along so that someone can look at it, but, no promises.
tigersfan  [developer] Jan 3, 2013 @ 7:14am 
Also, make sure you have the absolute most recent nostromo drivers running. Maybe it was something on their end and they fixed it already. :)
tigersfan  [developer] Jan 3, 2013 @ 7:51am 
... Unfortunately, there really isn't anything we can do about this. The way our engine works, there's not much we can really do about this. We don't have access to the parts of the engine that would cause something like this, even if we knew it was our engine (which we don't). I wish I had a better answer for you, but, I don't. Sorry.
Yamihe Kazeto Jan 3, 2013 @ 2:51pm 
Connect the gamepad before launching the game - doing it after launching the game causes it not to recognise the gamepad.
skin2yard Jan 5, 2013 @ 8:56am 
well, i wont complain much since i got the game for free :), but thats bad news, guess ill have to install another system on a new partition without the nostromo software so i can play these games without having to uninstall nostromo drivers everytime. i dont know which engine you use, but thats a problem i have only with some indie games, dont know if some of you guys use the same engine or what, but there is something wrong, i mean, if it was something on my part, it would happen more often... im not a developer so im just using plain logic, maybe im wrong.
tigersfan  [developer] Jan 5, 2013 @ 11:15am 
We use the Unity engine. It may well be a problem with that.
Solarist Jan 18, 2013 @ 8:00pm 
I have similar issues with my system - and I think the culprit here is my G13. So instead of utilizing the gamepad's joysticks, it only uses the G13. I think the ability to specify which input device to use would solve this. I wouldn't doubt the original poster's issue is the same.
Lusid Jan 19, 2013 @ 12:07pm 
I really don't feel like registering on another message board just to try to fix a game i want to try out, so here's hoping tigersfan is still checking these. I am having the exact same issue as solarist.

Here is all i am using. I have a PS3 controller, using DS3 tool to make the computer treat it as a USB 360 controller. I also (like solarist) have the G13 gamepad. It will bind the buttons, the analog stick clicks, and the L1 R1/LB RB. It will not recognise the Dpad, the analog stick tilts, or the L2/R2. Pretty much any of the Axis or hihat inputs.

I have tried without DS3 tool, so just the straight input of the controller, Same issue (only maps buttons
I have tried with the G13 unplugged before starting the game, same issue.
I have NOT tried uninstalling the G13 completely, and i am not going to as i would need to go re-download the software installer again.

A similar issue has happened with the Belkin something, similar to the G13 on Trine 1, where if it was installed and in it would not let Trine see any controllers plugged into it. I suspect as Solarist stated this is a similar issue, but oddly enough it lets you rebind the buttons, just not the axis. Please figure this out. AVWW 1 showed potential albeit a bit boring, but this style seems like it could be more interesting provided there are new spells/schools to learn. I'd love to play it and get my friends to play with, but with no mouse support and poor gamepad support i'm not going to be able to.
tigersfan  [developer] Jan 19, 2013 @ 12:35pm 
Sorry I've been absent guys. I've been ill for more than two weeks now. As for this, it REALLY sounds like the problem is between our engine (Unity) and the G13. Since none of us on staff have access to a G13, we'd need one of you to uninstall it and verify that. That said, I understand you not wanting to because if that IS the case, there's not a whole lot we could do about it.
Solarist Jan 19, 2013 @ 1:13pm 
The solution that a lot of games have, and it works, is to allow us to specify which input device to use. I believe the Unity engine does expose this: http://docs.unity3d.com/Documentation/Manual/Input.html

It appears there is a setting for "Joy Num" defined as "The conencted Joystick that will control this axis.". I am not a Unity dev, so I obviously am a bit neieve, but I would urge the devs to look into allowing the user to customize which controller's axis' to map. I feel the issue is it defaults to the first joystick axis it finds, which seems to be the G13's in our cases, and ignores the axis' on the second and onward joysticks (which would be our actual controllers in this case).

I realized that Rochard also uses Unity, so I fired it up and it works perfectly fine with my controller while my G13 is attached, so I think that your engine shouldn't be a barrier... Heck, they are a fellow indie dev - perhaps they could point you in the right direction.

I really do hope this gets resolved, as I do not feel I am willing to use the current keyboard/mouse control either, which pretty much means I won't be playing - which is a shame as I was looking forward to after playing AVWW1.
Last edited by Solarist; Jan 19, 2013 @ 1:25pm
Lusid Jan 19, 2013 @ 2:39pm 
Solarist is correct. I don't know if Trine works on the unity engine, but one of their patches allowed just as he said: Select input device. That fixed the whole issue. Please make it so!
tigersfan  [developer] Jan 21, 2013 @ 8:42am 
Ok, so, I just heard back from Chris, our lead dev, and he says this might be something we can look into doing. I'll update you as I get more info.
< >
Showing 1-15 of 23 comments
Per page: 15 30 50