Company of Heroes

Company of Heroes

View Stats:
HolyGoalie730 Jul 16, 2014 @ 6:18pm
Failed to find a supported hardware rendering device
The demo worked fine on my laptop but the fullgame is giving me this message. What do I do?
"Failed to find a supported hardware rendering device"
< >
Showing 1-15 of 29 comments
Locke4 Jul 17, 2014 @ 4:11am 
Create a shortcut from the .exe that you use to launch CoH, place it on your desktop, and add this to the target line: "-minvidmem 29" (without quotes).
This is presuming your laptop video card is the Intel HD4000 (from your previous thread I also replied to without seeing this ^_^). The reason for this is that your graphics solution uses shared memory with other things (like SDRAM, I believe), setting minimum video memory to something low (like 1->31) should hopefully force a solution.
I think this also works with steam launch options, but you'd have to ask someone else about that because I can never get them to work.
HolyGoalie730 Jul 17, 2014 @ 7:22am 
I tried adding it to the target line with a space before it and without and it gave me a message saying that it was invalid when I tried to accept the chages. I do put the -minvidmem 29 within the quotes that are already there, correct? BTW, thank you for helping me out.
HolyGoalie730 Jul 17, 2014 @ 7:34am 
I put -minvidmem 29 outside the quotes with a space in between and that was acceptable. I tried out training to test it and it was choppy. Would lowering the 29 help?
HolyGoalie730 Jul 17, 2014 @ 7:48am 
I lowered it to 10 and upped all of the graphics. It runs much better now. Is there anything wrong with lowering it even more? Is it harmful to my laptop? Thank you very much for helping me fix this, I really appreciate it.
Locke4 Jul 17, 2014 @ 8:30am 
Nothing harmful at all in doing that, it just basically forces the system to run allocate a minimum amount of video ram for that application.
I believe your laptop probably has an inherent manufacturers issue with allocating RAM to video purposes.
Ordinarily, a graphics card would have its own dedicated memory, but in laptops with onboard graphics, that is not always the case, and in your case it has to share RAM with the system (You might be short on RAM, which would explain why the full version of the game failed to initialise, the demo version would likely have lower minimum requirements for the application to start).
Laptops should never really be used for gaming, but ones with combined chipsets (HD 4000 chipsets are contained on the CPU thanks to new advances in migrations from the northbridge) usually have specific issues with OpenGL and DirectX applications that are often random and difficult to solve.

Hope the above information clarifies the situation, just experiment with it, avoid setting it too high (You can try 0, though I don't know what that would do) as that might cause a system crash (I wouldn't go above 1/4 of your system's total RAM).
Ϯ Ooooosh Ϯ Jul 17, 2014 @ 8:38am 
You could try changing the bios settings for your video chip and give it more dedicated memory.
Locke4 Jul 17, 2014 @ 9:00am 
Originally posted by Ϯ Tut Tut Ϯ:
You could try changing the bios settings for your video chip and give it more dedicated memory.

Theres no such thing as "increasing dedicated memory" through the BIOS, you can only increase dedicated memory by physically adding RAM (which is impossible to do with graphics cards in general anyway).
I presume you mean to set a minimum amount of VRAM allocated at any one time from the systme memory, which I would highly doubt would be a BIOS setting, it would be firmware or even hardcoded.
In this situation, the way this laptop handles it (and all others like it, afaik) is on an as-needed basis. It assigns RAM to either system or video requirements as the need demands, so there should be no BIOS settings to increase that to a suitable minimum.

Regardless as to whether that suggestion was valid, to Holygoalie, I would really advocate against any BIOS changes, if what I've suggested works, thats really all you need, its an intermittent problem with a single game, that'd be like using a sledgehammer to hang up a picture. If you encounter similar issues with other games, then there would be another opportunity to examine the viability of other solutions.
Ϯ Ooooosh Ϯ Jul 17, 2014 @ 10:17am 
OK you obviously do not have a onboard dual chip gpu
and have no idea how to add the max amount of shared dynamic memory to your gpu.
so I added a few pictures to show you what the setting is if you have plenty of memory on your laptop you can let the gpu have more becuase i do not think you will be rendering in 3dmax while playing a game at the same time.

You may or may not have setting in your bios for this you might have to update your bios to get more settings but then yuo might not get any setting if you have a cheap laptop.
Yes I have mine set to 1024meg of memory which is all you will need for a game.

http://postimg.org/image/uebepyfqh/
http://postimg.org/image/4hhqdcc2x/
Last edited by Ϯ Ooooosh Ϯ; Jul 17, 2014 @ 10:20am
Locke4 Jul 17, 2014 @ 10:23am 
Shared dynamic memory is not dedicated memory, your terminology was incorrect, so I apologise for not understanding what you meant from that.
Regardless, changing BIOS settings is a pointless endeavour because the situation is resolved.
Ϯ Ooooosh Ϯ Jul 17, 2014 @ 10:32am 
It is easier to just set the bios settings correctly than do work arounds may happen again for another game which there is no easy fix I am not say he needs to do it but just a easy way to add more memory to the onboard gpu when its needed.

Yes should have been dedicate more memory rather than add dedicated memory sorry.
Last edited by Ϯ Ooooosh Ϯ; Jul 17, 2014 @ 10:34am
HolyGoalie730 Jul 18, 2014 @ 6:35am 
Thanks for the assist Ghost, it's running great.
Locke4 Jul 18, 2014 @ 11:04am 
No problem, glad I could lend a hand.
ya boye Dec 13, 2014 @ 1:30pm 
when i type -minvidmem 29 it says that's invalid . what should i do ? :((
Locke4 Dec 14, 2014 @ 4:06am 
Make sure its outside of the speech marks in the target line. Its an error in your input.
ya boye Dec 14, 2014 @ 4:08am 
i put a space between '' and - . It worked . Thx for the post ;)
< >
Showing 1-15 of 29 comments
Per page: 15 30 50

Date Posted: Jul 16, 2014 @ 6:18pm
Posts: 29