Company of Heroes

Company of Heroes

View Stats:
CColtManM Nov 5, 2017 @ 10:53am
LAG when in Full Screen
If I have the game in windowed mode, it is smooth and has high FPS, as soon as I go full screen it is choppy, my GPU goes to 100% and it is hard to play. Any suggestions?

I have reinstalled the game, updated my GPU drivers, and lowered my settings like crazy. GPU still forced at 100%.
< >
Showing 1-15 of 15 comments
CColtManM Nov 5, 2017 @ 10:55am 
Also, it runs perfect in the menu for the first 5 seconds, and then the lag starts.
haNZ Nov 5, 2017 @ 12:38pm 
set these launch options then try: -novsync -notriplebuffer -refresh "ur monitors number of hertz"
Neutral Nov 5, 2017 @ 4:09pm 
Just keep on playing on windows mode, you could be doing a multitude of other productive actions while waiting for an automatch!
NinjaSalo Nov 7, 2017 @ 12:18pm 
DId you find a solution?
NinjaSalo Nov 9, 2017 @ 9:00pm 
It is working for me now. What I did was to set these launch options to: -novsync -notriplebuffer -refresh
zoo Nov 11, 2017 @ 1:19pm 
I'll try those settings, in the meantime i installed the legacy version (i have both) and the legacy ran -at the same settings as CoH Steam, smooth...
Severinshot Nov 21, 2017 @ 3:25pm 
I am having the same FPS drops when playing in full screen, about 24fps. Window mode brings it right back up to 60FPS. GTX970
[Clever Moniker] Jan 18, 2018 @ 11:39pm 
Does anyone have a solid solution to this? Same issue for me, 24fps in full screen and jumps to 60 if windowed. I feel like I’ve tried every solution in the forums at this point and not getting anywhere.
Battias Mylund Feb 2, 2018 @ 10:20am 
1. Go to the folder where you have COH installed and look for RelicCOH.exe

2. Right click on RelicCOH.exe and select Properties. Select the Compatibility tab and check the box that says "Disable fullscreen optimizations"

Thx to user Chillin.
Eclipse Feb 4, 2018 @ 7:53am 
Originally posted by sosA:
set these launch options then try: -novsync -notriplebuffer -refresh "ur monitors number of hertz"
Worked for me!
WhiteKvist Dec 15, 2018 @ 7:06pm 
Originally posted by Veni, Vidi, Vicious:
1. Go to the folder where you have COH installed and look for RelicCOH.exe

2. Right click on RelicCOH.exe and select Properties. Select the Compatibility tab and check the box that says "Disable fullscreen optimizations"

Thx to user Chillin.

Worked wonders! Thanks :)
[CSF] MotorDead Jan 11, 2019 @ 5:47am 
Originally posted by Veni, Vidi, Vicious:
1. Go to the folder where you have COH installed and look for RelicCOH.exe

2. Right click on RelicCOH.exe and select Properties. Select the Compatibility tab and check the box that says "Disable fullscreen optimizations"

Thx to user Chillin.

Fullscreen work but not in 1920x1080 => game crash and computer no answer during some second until 1 minute... :cozywolfensteinII:
NoNotU-K Jan 17, 2019 @ 5:51am 
turn down the model detail slider
Originally posted by haNZ:
set these launch options then try: -novsync -notriplebuffer -refresh "ur monitors number of hertz"

Chiming in here years later. This one actually worked for me. Disabling vsync by itself increased the nominal frame count (from 30 originally to between 200 and 800 after disabling) but there was still significant input lag and it still looked to be running at 30fps. I also tried disabling the fullscreen optimizations but that didn't work either. I'm not sure if it's because of triple buffering or limiting the refresh rate, but this actually worked
< >
Showing 1-15 of 15 comments
Per page: 15 30 50