Euro Truck Simulator 2

Euro Truck Simulator 2

View Stats:
roughnecks Mar 7, 2017 @ 4:25pm
Automatic Gearbox won't stick
Hello.

I've set Real Automatic and assigned dpad-right to drive and dpad-left to rear but every time I press any of those buttons, gearbox won't stick... I have to keep the key pressed or it will go back into neutral.

I'm playing with a XBOX 360 Controller but ETS2 says I'm using Keyboard + XInput 1 and XBOX 360 as secondary. I also tried deleting all of the config and .sii files in global and user profile, nothing worked.
Originally posted by play3r_93:
Unassign Automatic Gearbox: Drive and Reverse in the Controls options. They are for a shifter rather than a button (hence why you need to hold them down to stay in gear). Instead assign Shift Up and Shift Down in the Keys and Buttons settings.
< >
Showing 1-5 of 5 comments
Nono54Fr Mar 7, 2017 @ 4:31pm 
XInput and 360 are the same and they might be cancelling each other out. Remove the 360.
roughnecks Mar 7, 2017 @ 4:34pm 
I just tried but it didn't work, same issue.
The author of this thread has indicated that this post answers the original topic.
play3r_93 Mar 7, 2017 @ 8:12pm 
Unassign Automatic Gearbox: Drive and Reverse in the Controls options. They are for a shifter rather than a button (hence why you need to hold them down to stay in gear). Instead assign Shift Up and Shift Down in the Keys and Buttons settings.
roughnecks Mar 7, 2017 @ 9:52pm 
Originally posted by play3r_93:
Unassign Automatic Gearbox: Drive and Reverse in the Controls options. They are for a shifter rather than a button (hence why you need to hold them down to stay in gear). Instead assign Shift Up and Shift Down in the Keys and Buttons settings.

You're my man, thanks!
I could swear I set it up with "drive" and "Reverse" last time I had it working but it's not important now, problem solved, you made my day :) :freebeer:
Troll Jan 22 @ 10:11am 
Originally posted by play3r_93:
Unassign Automatic Gearbox: Drive and Reverse in the Controls options. They are for a shifter rather than a button (hence why you need to hold them down to stay in gear). Instead assign Shift Up and Shift Down in the Keys and Buttons settings.

Thanks a lot ! I just had the same issue after reinstalling ets2 on a new computer.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Mar 7, 2017 @ 4:25pm
Posts: 5