Galactic Civilizations III

Galactic Civilizations III

View Stats:
alexjpiragis Apr 21, 2021 @ 4:57pm
Starting a game
I'm unable to load a game or start a new one. It freezes at the setting up a player section. I know it loads the game itself but the screen stays stuck on the loading portion. Anything I should do to fix it?
< >
Showing 1-15 of 40 comments
Rhonin the wizard Apr 21, 2021 @ 11:15pm 
Sorry to hear you are having trouble.

Have you tried any of the suggestions in the Support FAQ?
https://forums.galciv3.com/486732/galactic-civilizations-iii-support-faq

Thank you for your patience and patronage.
alexjpiragis Apr 25, 2021 @ 1:05pm 
I have tried, but the screen stays stuck at the loading screen saying "setting up players"
Rhonin the wizard Apr 26, 2021 @ 5:32am 
Which of those suggestions have you tried?

And what are your system's specifications?
alexjpiragis Apr 28, 2021 @ 6:19pm 
I have tried restoring the files as well as re downloading the game. Let me check my specs. "Device name DESKTOP-FJ8CLP0
Processor Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz 1.80 GHz
Installed RAM 8.00 GB (7.89 GB usable)
System type 64-bit operating system, x64-based processor"
alexjpiragis Apr 28, 2021 @ 6:29pm 
Also I tried validating the files again but it said 4 files could not be validated
the_charch Apr 28, 2021 @ 10:01pm 
4 files is normal. some get changed basically every time the game launches so they always come up.

I was using a system with worse specs and the load times were very long, have you tried and been able to launch a game on the smallest map size verse only one opponent? It may not help or do anything but it should load pretty quick and might not hurt to try.
Rhonin the wizard Apr 28, 2021 @ 11:29pm 
What type of graphics card do you have?
alexjpiragis Apr 29, 2021 @ 1:58pm 
Intel (R) UHD Graphics 620
Rhonin the wizard Apr 30, 2021 @ 12:13am 
Have you checked if your video card drivers are up to date?

Have you tried running the game(and Steam) as administrator?

Have you tried Re-Installing Redistributables or DirectX?

Have you tried to disable Windows Controlled Folder access?
https://mywindowshub.com/how-to-enable-or-disable-controlled-folder-access-in-windows-10/
alexjpiragis Apr 30, 2021 @ 10:56am 
I've checked everything and everything is up to date at this moment. Though I did notice that I need more memory for most of the game. I've managed to clear as much memory as I can. Regardless, it still stays stuck at that loading screen
sean.drohan  [developer] Apr 30, 2021 @ 1:51pm 
Hello,

Sorry to hear you are having trouble.

Did you indeed ensure this was done in Windos 10?

https://www.tenforums.com/tutorials/113380-how-enable-disable-controlled-folder-access-windows-10-a.html

Do you have this folder and what is in it?

\Documents\My Games\GC3Crusade

t. Though I did notice that I need more memory for most of the game. I've managed to clear as much memory as I can. Regardless, it still stays stuck at that loading screen

RAM or disk space?

Sean Drohan
Stardock Support Manager
Last edited by sean.drohan; Apr 30, 2021 @ 1:51pm
alexjpiragis Apr 30, 2021 @ 3:19pm 
Indeed, I re-updated every one of my apps/games after I updated my laptop to windows 10. Also, regarding the folder I have "cache folder, CustomMaps folder, Debug folder, Designs folder, Exports folder, Factions folder, FlavorText folder, Mods folder, MPSaves folder, Saves folder, ShipStyleSet folder, debug.drr, Hotkeys, Prefs and RebuildDate"... looks like everything I should have. Sorry I had to write it all out.
alexjpiragis May 2, 2021 @ 4:19pm 
But to double check everything is 100% is there a service or app I can use to check and update everything if needed? Preferably at no cost
the_charch May 2, 2021 @ 6:12pm 
you have said you validated, that would be the service that checks and updates the game for you. comes free with all steam games and is is usually automatic. doing it manually (as you did) should fix most basic stuff. If you meant drivers and other software for your computer the only free option I know of is doing it manually one at a time.

It may also help Sean if you answer Ram or disk space, both are types of memory, but would cause some very different issues.
alexjpiragis May 3, 2021 @ 6:16pm 
RAM. System says I have 7.89 GBs available
< >
Showing 1-15 of 40 comments
Per page: 15 30 50