Galactic Civilizations III

Galactic Civilizations III

View Stats:
Krell Collective Civilization Not Working
I can't get the Krell Collective civilization (It's from the Omnibus collection) to work. I've tried resyncing at the start menu, veryified game files, then performed a game and computer restart. The civ portrait doesn't appear on the new game/civ selection screen, and the ships don't show up in the ship designer but the files (designs, factions and ShipStyleSet folders) do appear in my workshop content folder C:\Program Files (x86)\Steam\steamapps\workshop\content\226860\1722090322. I've also tried unsubbing then resubbing after unchecking the Enable Mods box in the game play menu.

Is anyone else having a problem getting this to work? Any suggestions, civ looks interesting and I want to try it.
< >
Showing 1-2 of 2 comments
P.Shaw  [developer] May 10 @ 1:59pm 
Can you see if the optin fixes the problem for you?
https://steamcommunity.com/app/226860/discussions/1/1679190184061949039/
fdwalker May 10 @ 3:20pm 
Sorry to report, using the Beta for the 3.7 opt-in, doesn't fix this problem. Applied the beta, no luck, repeated all the previous steps no luck, validated the files with no reported errors. Really wanted this to work as I've not had any problems loading and using workshop items before. Thanks for your help, if you can think of anything else that might be at issue, please drop by.

I know a long time ago Workshop had a few bugs you could workaround if you had a GalCiv3 install outside of the Steam client, but my setup is through Steam only.
< >
Showing 1-2 of 2 comments
Per page: 15 30 50