Galactic Civilizations III

Galactic Civilizations III

View Stats:
Low vision accessibility issues and suggestions
I am a visually impaired gamer using the Gold edition of Gal.Civ 3 from Steam, with all of the associated DLC.

Figureing its better to say something then say nothing.

First, a technical item:
I cannot seem to get this game out of fullscreen display.
This is important because I need to dock a windows magnifier
bar at the top of my screen - and windowing a game is the best way to do this.
The game allows for the ideal (in my case) 1280x800 in the video settings, Sometimes I wonder if I'm the only one that still needs to use this res. When the
game fires up it quickly reverts into a fullscreen view.
Same thing happens when Alt-Enter, a standard fullscreen toggle, is pressed. It immediately reverts back, insisting
on taking up the entire screen.
This problem did not seem to occur in Intrigue or previous expansions.
Tinkering the relevant Video settings within the config file also has no affect on this behavior.


The windows magnifier bar will superimpose itself over the fullscreen game. Inhibiting use of the critical buttons at the top of the UI. I thought I could circumvent this with a hotkey to open the Civilization manager screen, and others... but this does not seem to exist ??? [F1...F4] I would imagine this would be simple to implement.


The GUI in the game was otherwise quite visually friendly.

I have two more GUI feature suggestions:

The main map, has a back drop that contains distant nebulea and such. usually this is harmless and cool, but a few of these randomly choosen back drops make foreground features more difficult to see. An option/hotkey to turn off this backdrop (to solid black) would be appreciated.

Pretty much the same thing with the terrain in the planet view. Some of the brighter terrain images... seeing where the buildable hexes are - the important aspect - is tough. Please present a way to toggle the terrain backdrop to solid black for best contrast.

If anything to combat these issues already exists, please forgive and inform me, thanks!



< >
Showing 1-3 of 3 comments
I tried Alt-ENTER and indeed it does not work but if you disable full screen option (in options->graphics) and set lower resolution than your screen resolution game is displayed in a window. Other than that I can't help you.
P.Shaw  [developer] May 6 @ 7:34am 
As Karl said, you need to uncheck the "Full Screen" checkbox. It can be found on the Game Options > Graphics tab, underneath the Display resolution.

Unfortunately, we currently don't have the ability to disable the backdrops. I'll add it to list.
KrowBar May 6 @ 11:50am 
I indeed missed that checkbox, Unchecking did allieviate the main issue. Thanks

The back drop toggles are a "would be nice" thing. Should be strictly optional. The hotkeys for the management screens seem easier and more urgent, if thats on your list already.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50