Galactic Civilizations III

Galactic Civilizations III

View Stats:
lechuck1 Mar 6, 2019 @ 8:19am
outreach II / explorers benevolent trait broken?
just picked the trait where you get a class 10 planet but no planet appeared anywhere
< >
Showing 1-4 of 4 comments
Horemvore Mar 6, 2019 @ 8:30am 
Its hit and miss, also been reported and reported like many of the bugs in the game it is probably not classified as important enough to fix. Or its on the todo list, which takes years anyways.
Last edited by Horemvore; Mar 6, 2019 @ 8:31am
CariElf  [developer] Mar 18, 2019 @ 5:37am 
Hi, I wasn't able to reproduce this in the debugger, but I added additional code to make it try again if it failed to find or spawn a new planet on the first try. If you see this bug again and have a save game a bit before it happens, please upload it to a cloud drive like Google or dropbox and provide a link. My changes are not in the latest patch, but should go out in the next one.
Dray Prescot Mar 26, 2019 @ 12:35pm 
It may have spawned too far away from you to notice the new habitable planet, or even be able to see it, depending on how far you have explored already.

I always Play Benevolent and the first 3 Ideologies in the 1st row are always my first 3 Ideologies chosen since I want to get the the +2 Population (and since the minimum population on a colony ship is 1, the new colony will always have have at least 3 population (or more if the colony ship had more than 1 population), so I sometimes send a 2nd colony ship out to bring population back to my Home World) to all new colonies as quickly as I can.

I have NOT noticed any failures of the new class 10 Hab planet to appear in my games. The only problem I have that early in the game is that brand new colonies with 3 Population, which is their normal starting max population limit, will have morale problems depending on what choices you made in Game Setup. (The wrong choices can lead to BAD morale problems with those new 3 Population colonies)
Last edited by Dray Prescot; Mar 26, 2019 @ 6:38pm
Shizznitskii Sep 24, 2020 @ 5:48pm 
Ive just gotten this bug as well, it happened on the ionia 16 planet start with 3 dead planets, and then you get the event that spawns a class 9 nearby.

under those circumstanced i got no class 10 when i selected the perk.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Mar 6, 2019 @ 8:19am
Posts: 4