Brütal Legend

Brütal Legend

View Stats:
Freya Mar 1, 2013 @ 2:12pm
Performance - How I fixed mine
Hi there
I had really bad performance in my game and the animations seemed weird and the game was stuttering. It didn't matter if I changed the graphic settings or anything. It was just unplayable.
I have had a lot of trouble with console ports in my time and it has taught me a little about what the usual problems.

What I did to get Brütal Legend to run smooth 60 fps on my old rig is as follows...
In the game, go to options -> game -> enable "Hi-Fi sim".
Go to your control panel for you graphics card and Enable "Vertical Sync", "Triple buffering" and set "Max pre-rendered frames" to 3.

My game went from a funky stuttering weirdofest wearing white pants to a proper rockout!
I hope this can guide some of you with performance problems to a solution.
Last edited by Freya; Mar 1, 2013 @ 4:50pm
< >
Showing 1-15 of 43 comments
Son of Riggnarok Mar 1, 2013 @ 2:22pm 
O.O
DFDavid Mar 1, 2013 @ 3:00pm 
That is really interesting! Thanks for the information, Xadion. Does that help anyone else? I'm going to look into what affect those settings have on the game engine, and it would be really helpful to know if anyone else with performance problems was helped by this.
VenomBlade Mar 1, 2013 @ 3:20pm 
Nope. Still the tiniest frequent micro stutter with those settings on. It's leagues smoother than what it used to be though.
Son of Riggnarok Mar 1, 2013 @ 3:24pm 
Originally posted by farrell_david:
That is really interesting! Thanks for the information, Xadion. Does that help anyone else? I'm going to look into what affect those settings have on the game engine, and it would be really helpful to know if anyone else with performance problems was helped by this.
Helped me I can use ALL setting now lol. I get some studdering but I mean I can have SHADOWS on now that is insaine.
Freya Mar 1, 2013 @ 3:30pm 
There are a few areas and such where my framerate drops below 60 fps and vsync slows the framerate to 30. But it is very few places and I can help it by running with 2/3 view distance.
But I blame that on the game engine and my old worn out cpu ^^
It is still a hell lot better than running with the lowest resolution and everyting else turned off or to a minimum and still getting choppy frames and weird animaitons.
I am glad I could helped some of you a little bit :)

Oh another trick I sometimes use for consol ports with less-than-adequate optimization for pc.
Let the application chose and control vsync and such (enable it ingame) but set the "max pre-rendered frames" to 1 (never seen a game happy with anything other than 0, 1 or 3).
I used this with Farcry 3 to remove constant micro-stutters.
Last edited by Freya; Mar 1, 2013 @ 3:41pm
Wolf Mar 1, 2013 @ 3:43pm 
Somehow it still seems weird to work this laggy. my laptop has an i5 3210m, 12gb of 1600mhz ddr3 ram and a 2gb gt630m.. On Crysis 3 I've got 40 fps on medium quality settings, but in this 3 year old game I get 20-30 fps with everything set to off? Your post did help, I now have around 40-45 fps, but still, not what I expected...
Freya Mar 1, 2013 @ 3:56pm 
I don't think we can expect Brütal Legend to run half as well as Crysis 3 which is running on one of the best game engines available. All game performance is limited by its programming and its engine. I've seen ugly games run like crap on powerful machines and vice versa.
I think the developers did rather well with their Brütal Engine. My gut feeling is that Double Fine isn't a huge enterprise with tons of experience with 3D game engines and huge budgets. It turned out rather well in my opinion. It just needs a little PC love!

My rig is an old charred (literally) i7 920 and a gtx580. I bet I can make double the frames in Crysis 3 than I can in Brütal Legend.
I never expect anything made for a console to run decently on a pc. It's usually a struggle and sometimes I just have to accept that I can't get a smooth ride no matter what I do. For an example with Darksiders 2 I get a little bit of stuttering when it loads. I can't change that. And if I set the shadows to maximum in Darksiders 2, it just begins to micro-stutter constantly even though there are no signs of a bottleneck anywhere.
That is just how it is with software performance.
It must not be easy being a game developer having to port a game from one platform to another, even harder going from a locked configuration of hardware to the random world of PCs :)
Last edited by Freya; Mar 1, 2013 @ 4:48pm
Freya Mar 1, 2013 @ 4:36pm 
OH! One more ting I'd like to mention about vsync.
If your machine can't / won't run the game with atleast as many fps as your monitors refrehs rate it will clamp at half.
For an example, without "Hi-Fi sim" but with the vsync options enabled. My game would run "smooth" at 30 fps (half my monitors refresh rate) becuase it could not, for whatever reason, draw 60 fps.
Any fps of 59 or below clamps at 30 when using vsync on a 60 Hz monitor.
This image shows a bit of what I mean (notice the white line).
http://www.geforce.com/Active/en_US/shared/images/articles/introducing-the-geforce-gtx-680-gpu/AdaptiveVSync-1.png

This might explain why, even with the correct settings, the game still runs slow and stutters a tiny bit all the time. Simply because it is forced to do so becuase of vsync if your game can't run with an optimal framerate.

(I don't know what "Hi-Fi sim" does, but I think the game is limited in fps by default in some way, this option seems to remove that. In any case, it allows my game to run 60 fps. Maybe even more if I didn't use vsync).
Last edited by Freya; Mar 1, 2013 @ 4:48pm
DFDavid Mar 1, 2013 @ 4:49pm 
Originally posted by Xadion:
(I don't know what "Hi-Fi sim" does, but I think the game is limited in fps by default in some way, this option seems to remove that).

The hi-fi sim means the game will simulate and render at 60 frames per second. By default, the game renders at 30 frames per second. If your machine can handle it, you definitely want to enable the hi-fi simulation.
Freya Mar 1, 2013 @ 5:10pm 
Originally posted by farrell_david:
Originally posted by Xadion:
(I don't know what "Hi-Fi sim" does, but I think the game is limited in fps by default in some way, this option seems to remove that).

The hi-fi sim means the game will simulate and render at 60 frames per second. By default, the game renders at 30 frames per second. If your machine can handle it, you definitely want to enable the hi-fi simulation.

Ah ok! Thanks for clarifying :)

If "Hi-Fi sim" is off by default. It will cause all Brütal Legend PC players, that has any feel for framerates, be annoyed by the performance of this game until they find this option (if they do). And I think that includes the majority of the PC playerbase.

In my personal subjective opinion (no offense) this option should not exist. At least not for the PC.
I am sure there is some reason for it to be there, but I can't see why (I probably just don't know).
A game should either run as fast as it can (be that 20, 42 or 157 fps) or match the speed of the monitor used. Unless there is some special reason as to why.
Please educate me on the matter if possible :)

And by the way. thanks a lot for taking interest in the thread farrell_david.
Last edited by Freya; Mar 1, 2013 @ 5:27pm
J.P. Mar 1, 2013 @ 5:19pm 
I think the framerate is unlimited (limited by hardware) when you have vsync off. I heard a dev say that in yesterday's Giant Bomb livestream.
Hackmed Mar 1, 2013 @ 5:21pm 
They explained it in another thread, even with hi-fi sim off some parts of the game still run >30fps (Camera movements and the world), some animations are atill locked at 30fps. And with Hi-FI sim on, my machine can't handle the battles.
Freya Mar 1, 2013 @ 5:22pm 
Originally posted by {GmT}J.P.:
I think the framerate is unlimited (limited by hardware) when you have vsync off. I heard a dev say that in yesterday's Giant Bomb livestream.

It normally is with almost all games. it just seems it's a little different with Brütal Legend.
Last edited by Freya; Mar 1, 2013 @ 5:22pm
Freya Mar 1, 2013 @ 5:25pm 
Originally posted by Hackmed:
They explained it in another thread, even with hi-fi sim off some parts of the game still run >30fps (Camera movements and the world), some animations are atill locked at 30fps. And with Hi-FI sim on, my machine can't handle the battles.

Uh, do you have a link? I'd love to read it if there are explanations on how the game handles. Maybe even some really juicy technical bits!
It could help me understand why there is a fps limiter in the game.
Last edited by Freya; Mar 1, 2013 @ 5:28pm
DFDavid Mar 1, 2013 @ 5:55pm 
Originally posted by Xadion:
Maybe even some really juicy technical bits!

If you are interested: Brütal Legend's engine uses a fixed timestep for its simulation. That timestep is either 30 or 60 Hz, depending on whether the hifi sim is disabled or enabled. There are various reasons to use a fixed timestep, but mostly it works best to keep physics simulations stable. A great introduction to these issues is http://gafferongames.com/game-physics/fix-your-timestep/

Brütal Legend was originally designed for the XBox360 and PS3, where a 30 frame rate is common. PC's are much more powerful than those consoles, though, so a big upgrade to Brütal was to use a 60 Hz simulation rate. However, not all PC's are powerful enough to handle that, as 60 Hz takes twice as much processing power as 30 Hz. We have it off by default, and leave it to the player to enable. I would encourage everyone to try it out, though, because 60 Hz looks much better.

It would be best if the engine could determine when the PC is capable of running at a 60 Hz simulation, and automatically switch to a 30 Hz simulation when there's not enough processing power (such as on a slower PC, during a large battle, etc). Improving that area is on our list of things to improve, but for now we just expose the "high fidelity" 60 Hz simulation as an option to the user.

Although the simulation thread runs at exactly 30 or 60 Hz, the rendering thread operates asynchronously, and uses a new feature we call "interpolated rendering" to run at higher framerates. What happens is that we have one thread which runs the simulation at a fixed rate, but changed the rendering thread to draw as many frames as possible, interpolating between the last two simulated frames. This interpolation is done by interpolating the camera position, object transforms, skinning matrices, etc., and then rendering that frame. So although the simulation thread is limited to 30 or 60, the renderer is unlocked to run at the highest possible framerate.
< >
Showing 1-15 of 43 comments
Per page: 15 30 50