Brothers - A Tale of Two Sons

Brothers - A Tale of Two Sons

View Stats:
poxtops May 5, 2014 @ 11:39am
Bug or because I use keyboard?
At chapter 2 in the caves, when opening the bridge. I have both brothers positioned correctly to push that thing either side. But it just doesn't move despite me pressing as much directional buttons as I can think of (wont even move forward to start with..)

^ This is a picture of what I mean.

Is it because I am using keyboard? I wouldn't have thought so as I read people completed this game with just keyboard.

Also, I've restarted the chapter twice now, to no avail, cant be arsed reinstalling the game...
< >
Showing 1-15 of 19 comments
SpectatorX May 5, 2014 @ 12:47pm 
Keep pressed action keys (space and right ctrl) and press forward keys (W and upper arrow), this will make brothers push the lever forward.
poxtops May 5, 2014 @ 12:50pm 
Originally posted by SpectatorX:
Keep pressed action keys (space and right ctrl) and press forward keys (W and upper arrow), this will make brothers push the lever forward.

Already done & tried many times..

It doesn't work.
SpectatorX May 5, 2014 @ 2:41pm 
Weird... Did you have any problems before in this game with controlling brothers with your keyboard?

Pretty crazy but worth trying idea is to verify game cache files in steam.

Also, try to change controls to something else, for example move one brother's control scheme to other keys, for example from arrows to numpad keys. Some people who had issues with controls said rebinding keys fixed their problems.
greatscott May 7, 2014 @ 1:20am 
I too had issues getting the younger brother to go left when the older brother's action button (spacebar) was pressed. I had to remap the younger brother's left arrow to solve this.
poxtops May 7, 2014 @ 3:57pm 
I will try this, thanks :)
poxtops May 7, 2014 @ 4:03pm 
Seems I cannot change the controller settings, although I remember I could when i first started this game..
Maybe you can only do it when starting a new game?

If so, this is really offputting, having to restart, with no guarentee of this happening again even further into the story.. :/
SpectatorX May 8, 2014 @ 3:57am 
You can rebind keys in launcher.
ser121149 May 8, 2014 @ 4:20am 
I've been having the same issues. Isn't there a way for the developers of the game to fix the bug?
SpectatorX May 8, 2014 @ 5:02am 
They protected themselves from fixing this bug by saying in game requirements controller is required.

Anyway, i have no idea why devs and gamers are using word "controller" to describe gamepad, i think mouse and keyboard are also controllers.
Deadpan Serious May 8, 2014 @ 7:48am 
i think of Controller unambiguously as what you call a 'gamepad'. might be local differences in language use. (don't know, foreign language for me). oh, keyboard can also mean music instrument...

anyway, this is caused because you use a keyboard. i had some difficulty here as well. i did manage to push it eventually by using some really strange combinations, such as pushing forward for one brother, and left for the other, stuff like that. just try every combination or change keybindings using the Launcher.
Last edited by Deadpan Serious; May 8, 2014 @ 7:50am
ser121149 May 10, 2014 @ 10:56am 
Ah, okay. But you'd think that a lot of people would complain about it still and the developers would fix it...
Deadpan Serious May 10, 2014 @ 11:00am 
like me, you're probably using a cheap keyboard. apparently many users like to overspend on a tool and don't have this problem.
poxtops May 10, 2014 @ 3:53pm 
Originally posted by Deadpan Serious:
like me, you're probably using a cheap keyboard. apparently many users like to overspend on a tool and don't have this problem.

ahaha, actually its a £100 keyboard (but was given to me by an extreme gamer friend as he bought an even better one.. dont even get me started)

But yeah, changing the bindings worked like a treat.. until the next level.. where i then had to change the bindings AGAIN.. :p
Leost May 10, 2014 @ 10:49pm 
Keyboards all have different key combinations that they simply can't send to the computer. If you look at how many different keys are on your keyboard and then think of each key needing 1 bit to set the state of that key you see that on most keyboards your sending more than 100 bits (well, for a long time keyboards were called 101-key keyboards, but most today have more than that). But even that isn't enough to really capture the data from a keyboard.

What you'd want is to be able to send events (key down, key up), key states (1 bit yes/no a key is pressed), then you gotta throw in all the extra stuff some keyboards have (volume dials, macro buttons, sometimes more).

It is true that more expensive keyboards sometimes "gamer" keyboards will be able to send more/different key combinations at the same time, but I've never found a keyboard that allows ALL keys to be pressed at the same time and for all those key states to be accurately shown.

The jist I am trying to get at is this is a HARDWARE problem and you can't expect this to be fixed by a software solution. Don't blame the game developers for this.
Last edited by Leost; May 10, 2014 @ 10:50pm
ser121149 May 11, 2014 @ 12:08am 
There's literally nothing wrong with my computer's keyboard. I've had this laptop for 2 years now and I haven't had problems with this keyboard at all. In fact, this keyboard works just like all of the other computers I've used during my lifetime, so I know it's the game itself. I kept turning the mechanism to raise the gate, and it still won't budge. I've hit all of the buttons, and nothing. I know it isn't my keyboard because I don't think there's anything wrong with it. It acts normally. But then again, it ain't no fancy gamer keyboard, but it's a PC laptop. I just don't have the money to get a separate keyboard for this thing, so yeah...
Last edited by ser121149; May 11, 2014 @ 12:08am
< >
Showing 1-15 of 19 comments
Per page: 15 30 50

Date Posted: May 5, 2014 @ 11:39am
Posts: 19