Folk Tale

Folk Tale

 This topic has been pinned, so it's probably important
GF  [developer] Jul 15, 2015 @ 4:23am
Alpha 30a Experimental Build (Patch
Hi Folks,

I'm pleased to provide community members with access to a new opt-in experimental beta. Patches posted here will be rolled together to form Alpha 31. Experimental builds aren't for everyone, and can contain game breaking changes.

Running an experimental build in parallel to the main stable build provides us with a risk free environment where we can experiment and iterate on new changes before releasing them into the stable build. For that reason, experimental builds are not recommended for casual players.

Accessing the Experimental Build
1. In your Steam Library, click ‘Folk Tale’ with the secondary mouse button and select Properties
2. Click the fourth tab labelled ‘Betas’
3. In the dropdown list, select experimental and click close
4. Wait for Steam to auto-update
5. If the update fails to download, quit and restart the Steam Client

Best wishes,

--------------- EXPERIMENTAL PATCHES -----------------

ALPHA 30 just launched so the stable build and the experimental build are currently the same version. A new experimental should follow soon.

Experimental is now available:
Last edited by GF; Mar 31, 2017 @ 10:41pm
< >
Showing 1-15 of 747 comments
DUCK Jul 15, 2015 @ 6:51am 
"This topic has been pinned, so it's probably important" lol ;P

Good streaming, you will tear me apart when the time comes!
Last edited by DUCK; Jun 14 @ 6:54pm
wolf Jul 16, 2015 @ 8:07am 
Hero flickers when zooming out or when hes walking trough trees and fields.
wolf Jul 16, 2015 @ 8:11am 
Playing for 1 hour and 20 min
very nice Jul 16, 2015 @ 2:00pm 
80 minutes logged in. No crash, nothing peculiar noticed. Game ran very smooth on High on somewhat dated hardware.
onitake Jul 16, 2015 @ 4:06pm 
The new build works very well. I also got the impression that performance has improved. But this may be subjective.

I noticed some problems with the build icon descriptions: Sometimes the text bubble is way too narrow, making it scale vertically. Also, some of the resource requirement icons seem wrong; the windmill requires 100 gold instead of metal ingots for example. When I try to build it, it reports the resources correctly, though.
Grumolch Jul 17, 2015 @ 11:44am 
I'm getting a blue overlay over the entire game when running this experimental version. The game previously had run smoothly, and I have not changed any setting from before, where I had played very stable, very long episodes of several hours in length. Has anyone else had this problem? I can post/send screenshots if that would be helpful.
Last edited by Grumolch; Jul 17, 2015 @ 11:44am
DUCK Jul 17, 2015 @ 11:52am 
Originally posted by xandrakkan:
Could be direct X or new unity?
try forcing other direct X version would help? (don't really know, but it seems like some of that maybe being the problem)
Grumolch Jul 17, 2015 @ 12:08pm 
Yes. I posted the comment in the hopes to contribute to a solution without shedding a bad light on what I believe is an excellent game. There are some things I'd like to try, but I want to make sure it helps the development team address any potential issues I've stumbled upon. Before I make any changes, I want to do a little research. I vaguely recall some other blue overlay discussions involving an updated Unity engine. Thanks for the suggestions, Freddy. I'll log potential resolutions before making any changes. If there is any information I can provide prior to trying to fix it, let me know.

My current dxdiag log:
Time of this report: 7/17/2015, 15:05:17
Machine name: xxxxxxxxxxxxx
Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150525-0603)
System Model: HP ProBook 450 G1
BIOS: Default System BIOS
Processor: Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz (4 CPUs), ~2.5GHz
Memory: 8192MB RAM
Available OS Memory: 8074MB RAM
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
DxDiag Version: 6.01.7601.17514 32bit Unicode
Card name: Intel(R) HD Graphics 4600
Last edited by Grumolch; Jul 17, 2015 @ 12:15pm
GF  [developer] Jul 17, 2015 @ 2:43pm 
Interesting. Can you try forcing Direct X 9.0c and 11 separately please? Details on how can be found here:
Grumolch Jul 17, 2015 @ 3:39pm 
I tried -force-d3d9, -force-d3d10, and -force-d3d11. 9 and 10 showed same results. Forcing 11 gave me a pure magenta screen with only the cursor visable on game launch (could not even choose a game to start) (See below)

I took various screenshots with each setting. Screenshots set to "private", but Steam claims that developers and administrators can see them. My only screenshots are of this issue. Perhaps you can take a look and confirm that you can see the various screenshots. I captioned them to add some detail.

Please note that I am using an Intel HD 4600 graphics card, and I realzie the game description shows Intel HD 4000 cards are unsupported with known issues. I did, however, take a chance on this game, and it had been playing flawlessly prior to this experimental beta.
Last edited by Grumolch; Jul 17, 2015 @ 3:47pm
GF  [developer] Jul 17, 2015 @ 11:40pm 
Originally posted by xandrakkan:
I tried -force-d3d9, -force-d3d10, and -force-d3d11. 9 and 10 showed same results. Forcing 11 gave me a pure magenta screen with only the cursor visable on game launch (could not even choose a game to start)

According to Unity, the issue with Intel chipsets was fixed, but clearly it isn't. Presumably you've updated your graphics card drivers?

Also, maybe try forcing opengl.
Last edited by GF; Jul 17, 2015 @ 11:46pm
GF  [developer] Jul 18, 2015 @ 12:09am 
OK, further research (including the Unity beta group) indicates there might be a problem with the latest version of Unity and DirectX 11 on 4600 cards. I've added some of the info you've provided to that post. Hopefully Unity will fix this quickly.

In the meantime, if OpenGL doesn't work, I suggest opting out of the experimental build, and turning off auto-updates for now so that you stay on Alpha 21. That way at least you'll be able to play the game until we receive a fix.
Grumolch Jul 18, 2015 @ 7:28am 
I'll try the above, and appreciate the feedback. Thank you for looking into this for me. I'm a big fan, and hope the new engine will keep me in the playing field. I'll keep you posted.
Paraleo Jul 18, 2015 @ 10:25am 
Is there an estimated date when this leaves the experimental phase?
< >
Showing 1-15 of 747 comments
Per page: 1530 50