Legacy of Kain: Defiance

Legacy of Kain: Defiance

MysT Dec 8, 2012 @ 8:17am
Legacy of Kain: Defiance problem
I can't seem to get Defiance to work. Whenever I start the game it just makes my screen go black, then it flashes back and forth from black screen to Windows. Eventually an error pops up. Has anyone else had the problem and could someone please let me know what the fix is if they know.

Thanking you
< >
Showing 1-11 of 11 comments
Drayzin Dec 10, 2012 @ 8:17pm 
I just bought the game today, it is doing the same for me. No idea how to fix it.
ArchAnge1LT Dec 10, 2012 @ 9:11pm 
Try disabling Steam in-game, not sure if that works, cause dont have the game myelf.
MysT Dec 11, 2012 @ 2:50pm 
Cant get inot the game. It doesnt load. Just a black screen that jitters and them the error shows up
gavinb80 Dec 18, 2012 @ 11:54am 
Hi, I had the same problem. It was fixed by disabling multiple monitors, so only the 1 primary monitor. Once I ran the game, I changed the resolution upto 1920x1200 for my primary monitor then the game ran fine, even once the multiple monitors were re-enabled. I think this is a screen resolution problem, so if you still get it or have only 1 monitor, my next move would be to reduce resolution of your monitor to match the game's default, which I think is something like 800x600 or so.
MysT Dec 18, 2012 @ 1:42pm 
Thanking you very much for the input. I'll give it a try
Khimari Jan 5, 2013 @ 3:51am 

same issue here, I tried to go to:


Right-click "defiance.exe", Properties, Compatibility -> Disable deskto composition -> Apply -> OK.

Problem fixed. I have dual display setup and by allowing to the game to disable AERO it flickers no more + no need to disable second display. Hope it will help to you too.


Edit, Update:

It seems that after launching the game by this method and setting up the in-game resolution to reflect my native desktop resolution this fix is needed no more - game does not flicker even with AERO after in-game resolution is fixed + dual display setup. It seems this is needed only for the 1. run.
Last edited by Khimari; Jan 5, 2013 @ 3:54am
PewPew Jan 26, 2013 @ 2:28am 
my Deviance wants a original DVD.... any ideas to fix? -.-
MysT Jan 31, 2013 @ 1:35pm 
Only thing I could think of to fix that is delete the install and re-download
Orncaex Feb 14, 2013 @ 7:14pm 
What in the nonsence could cause such a silly but massive error? i had to reboot the computer twice because my computer litteraly black screened and refused ALL input... yet all i had to do was go into the properties and check off a box and that fixes everything? Well thanks for the help anyway
pane4l Apr 12, 2014 @ 12:45am 
Unfortunatly for me Khimari's fix has not worked for me. I have also tried running as administrator and putting it in compatability mode, none have worked. I have tried to set my resolution to 800x600 but this doesnt work either.
My rig:
Windows7 x64
8Core AMD A8 8350
2GB Radeon HD6670
(All drivers including BIOS are up to date)
I will endevour to find the answer, but if anyone hasn any other suggestions that would be very appreciated.
pane4l Apr 12, 2014 @ 3:52am 
Ok so I got my issue sorted... I originally had the game installed on a 4TB external drive. I reinstalled the game to the C drive (Default) location and this solved the issue.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50