Ys II > General Discussions > Topic Details
Slip Jul 14, 2013 @ 7:24am
Controler not working right since latest Update
I'm not able to move using the joypad anymore, I'm being forced to use the directional pad instead. I have gone through the config and it shows that it is working but when the game loads it wont work. The joypad still works in Ys 1 though. Any ideas?
< >
Showing 1-15 of 119 comments
Sara  [developer] Jul 14, 2013 @ 8:07am 
Huh? That's really, really bizarre. I'll take a look into it but it seems really weird that this would happen.
Sara  [developer] Jul 14, 2013 @ 9:17am 
So far I'm not able to reproduce this at all. I'm not sure what could cause something like this, and it still works as normal on my own system...
Tsappu Jul 14, 2013 @ 10:11am 
Does not work for me either on Ys II, using X360 controller.
Sara  [developer] Jul 14, 2013 @ 10:14am 
I'm also using an X360 controller, so I'm not really sure what could be up. Are you guys using wireless or third-party controllers? Mine is a wired first-party.
Tsappu Jul 14, 2013 @ 10:18am 
Wired. Not sure if its really made by Microsoft since I bought it from eBay, but atleast Windows thinks its real X360 controller. Everything worked just fine in Ys I.
Sara  [developer] Jul 14, 2013 @ 10:22am 
And it's still working in Ys I even now?
Tsappu Jul 14, 2013 @ 10:27am 
Yes. Loaded save from last night and joystick is working just fine in titlescreen and ingame.
Sara  [developer] Jul 14, 2013 @ 10:33am 
I'll have a look a bit later today. I have a headache right now and it's making it a bit hard to pore over code. But I will get to it as soon as I'm feeling a bit better. Sorry about that. For the time being, you can use the D-pad (I presume it will work) or bind the stick to the arrow keys with Xpadder or JoyToKey.
Slip Jul 14, 2013 @ 10:41am 
It is the X360 wired controller and everything works fine in Ys 1.
InvalidName Jul 14, 2013 @ 1:05pm 
I'm also having the same problem. It works in Ys I, but I have to use the directional pad on Ys II. I'm using an old USB controller made by Thrustmaster.
Ikari Worrier Jul 14, 2013 @ 2:19pm 
I'm using the Wireless Xbox 360 Controller, and I'm having this issue with Ys II as well (though, oddly, not Ys I). I cannot move with the regular joystick, only the d-pad. If it makes any difference, I'm also running 64-bit Windows 7.
makesound Jul 14, 2013 @ 2:45pm 
Same problem. Left analog doesn't work for Ys II but still works fine with Ys I. D-pad works, but what is this, the 90s!?
Penguin-Player Jul 14, 2013 @ 3:17pm 
Same problem here, can move fine with the d-pad, but the analog stick doesn't work. Still works fine on Ys I.
Last edited by Penguin-Player; Jul 14, 2013 @ 3:17pm
Sara  [developer] Jul 14, 2013 @ 6:34pm 
I've pushed a patch that adjusts the input code a little, any luck? Restart Steam if you haven't received the patch yet.
Slip Jul 14, 2013 @ 8:51pm 
Still no change
< >
Showing 1-15 of 119 comments
Per page: 15 30 50

Ys II > General Discussions > Topic Details