Ys II > General Discussions > Topic Details
Krisco Feb 12, 2014 @ 10:04am
Flair Rall Rescue--SOLVED
How do I use the mattock to rescue Flair Rall from the rubble? I press my "use item" key and it does nothing. I just get the text prompt saying I could save him if I had the "mattock(which I have/equipped) but I don't supposed you have that..."

I've restarted 2 times to try a different route each time and that doesn't work. After searching a few people have this problem but have yet to post a solution. Just wondering how nobody else has the issue. ><

Edit: After uninstalling/reinstalling and redoing everything I'm stuck at the same point where I cannot save the doctor--- >< Welp off to a different game. Twas fun.
Last edited by Krisco; Feb 14, 2014 @ 7:51am
< >
Showing 1-10 of 10 comments
Korzic Feb 12, 2014 @ 12:59pm 
If you're still getting dialogue from the doctor, then it sounds like you didn't hit the use item key, or it's just not registering. Just to be sure, the "use item" key looks to be C or underscore by default, although people have reported issues with it in the past - maybe try rebinding it?
Krisco Feb 12, 2014 @ 8:08pm 
I guess it just hates me---I rebound the key and nothing happens when I press it. I reinstalled it ---- also played it up to this point on my laptop and desktop. I dont know why it's bugged for me! I read somewhere you needed to get the doctor before giving any of your books away but I didn't try that yet. I'll give it a shot and see. Sounds ridiculous but worth a try.
Korzic Feb 12, 2014 @ 8:29pm 
I can confirm that it doesn't really matter when you rescue the doctor, just as long as you do so. Heck, if you wanted to, you could do everything else in the Mine before rescuing him.
Krisco Feb 13, 2014 @ 5:46am 
I did it again----before doing anything else I attempted the rescue with no success---cleared the rest of the mine/defeated the boss and still the doctor refuses to be saved! lol. My friend just started playing this morning it should only take a few minutes to get there--I'm awaiting his results. Thanks for the help in any case, Korzic.
Krisco Feb 13, 2014 @ 5:37pm 
:( My buddy had the same problem lol. Then another friend of mine got passed it just fine ugh.
Korzic Feb 13, 2014 @ 6:18pm 
I don't really understand the technical jargon, but does this post (from the Ys I forums) mean anything to you? And if it matters at all, I play with a modified "leftie" setup, using "V" for items.

Originally posted by Sabre3999:
Something I noticed going through this same ordeal: What key are you binding it to?

By default in WASD mode (what I use) the bind is to underscore. Obviously that didn't work. I tried binding it to equals, tilde, and apostrophe before looking at the configs directly. One of them looks to be a super-old style, defining them by keycode rather than explicitly. I gambled on using a key with a lower code, and it worked (old game, maybe it can't read higher ones?). Once I bound it to '1' I had no issues. The highest mapped in the old config is code 104 (8 on a 10-key) so try keeping it below that.

This is what I used to kind the keycodes: http://www.lsauer.com/2011/08/javascript-keymap-keycodes-in-json.html

There are a ton of posts about this, and the only people who have any luck consistently seem to use the default binds on the map that uses a 10-key. That's probably because the default 'C' has a lower keycode. I tried all the other resolutions too, like using the default map and disabling Steam Cloud. None worked, but this did. And I got to keep cloud support.
Last edited by Korzic; Feb 13, 2014 @ 6:19pm
Krisco Feb 14, 2014 @ 7:03am 
Awesome, thanks for that....Sadly I deleted my saves so I'll get back to that point and give it a shot. Once again, regardless of the outcome, you're a bad ♥♥♥ for helping out.
Krisco Feb 14, 2014 @ 7:20am 
So weird---after testing the "1" key for use item I realized no matter what I do the key's I pick don't actually change. Even if I create a custom set and save/use that set....it defaults itself to wasd and the arrow keys with underscore being the use button. Hmm. Going to look through the file system to see if config is kept there.
Krisco Feb 14, 2014 @ 7:31am 
Yep, I've confirmed that I cannot change the key bindings---it's stuck on underscore for use item. ><
Krisco Feb 14, 2014 @ 7:51am 
Fixed it! I had to manually update the .ini file associated with ysII---It's located in C:\Program Files (x86)\Steam\userdata\73052896\223810\remote\ysp_win.ini Simply changed the "KEY_ITEM" to the key of your choice and save ---> play the game. I finally saved the damn doctor!

After you linked the article about the keycodes I found that my game wasn't actually saving my binds and the yes, the underscore would not actually register. I came across the .ini file and found what I needed.

Thanks so much for your help Korzic.
< >
Showing 1-10 of 10 comments
Per page: 15 30 50

Ys II > General Discussions > Topic Details