DCS World Steam Edition

DCS World Steam Edition

View Stats:
Covert_Death Feb 8, 2014 @ 4:22pm
Cant launch mission with joystick plugged in
I have a Saitek Cyborg Evo Force Feedback joystick and when it is plugged in I cannot launch any missions. The main menu loads fine but if i click instant action and select ANY mission it acts like it will load and then when it reaches %100 the mission crashes and the game goes back to the main menu.

when i unplug my joystick the game launches fine and i can fly with my keyboard.... obviously this sucks though.

I have reinstalled the game MULTIPLE times. this is now a FRESH install of windows 8 Pro x64 as well. I should not be having any problems but I have never been able to launch this game since it went to World with a joystick plugged in... ( i used to be able to play my a-10c standalone just fine but when world came out and switched over to that, all joystick support went to crap)

if anyone can help me or have suggestions I would really appreciate it!
< >
Showing 1-4 of 4 comments
Chameleon_Silk Feb 8, 2014 @ 8:30pm 
are you using the latest drivers for your joystick?
Covert_Death Feb 8, 2014 @ 9:43pm 
yes... i solved the issue from other similar thread. I had to use regedit and delete a registry entry for my joystick and it works now. this really should have been resolved by now because apparently this issue dates farely far back in DCS world...
Chameleon_Silk Feb 9, 2014 @ 2:11am 
sounds like a windows issue and not related to DCS world at all
Covert_Death Feb 10, 2014 @ 5:31am 
except my stick works flawlessly in every other game i've ever tried to use it in... (10+ titles) so that narrows it down pretty specifically to DCS's implementation
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Date Posted: Feb 8, 2014 @ 4:22pm
Posts: 4