Left 4 Dead 2 Beta

Left 4 Dead 2 Beta

TRololo 14. mai, 2013 @ 17:36
Almost all textures are black or white L4D2 Beta Linux
Im running L4D2 on linux and I have a problem; the game start but all textures are black or white as you can see in the images above:



I tried to change the video settings to severals combinations but I got the same results.

System Specs:

- Video: Intel HD4000
- Processor: Core i5 3210M
- System: Arch Linux x86_64
- Kernel: 3.9.2-1
- Mesa Driver: 9.1.2

Excuse me for my english but is not my native language.
< >
Viser 1-8 av 8 kommentarer
WiRE 14. mai, 2013 @ 18:57 
I am also having problems with my graphics. I see color but some times the walls become see-through. Sometimes this helps because I can see where the Tank is but I know it is not normal.

Have you tried to install the latest drivers to your graphics card? I did that but it did not help me, maybe it will help you.

I hope Valve is reading these comments and fix them.

-Video: ATI Sapphire Radeon HD 5770
-Processor: AMD Phenom II X4 965
-OS: Ubuntu 13.04
I've been having some textures flicker invisible like WiRE too. Nice to know there's a solution.
TRololo 16. mai, 2013 @ 17:25 
Thanks for the answer. Well... I'll wait until mesa 9.2 be in the arch's repositories, because the git version needs some unstable packages right now and they could break my system.
juliobritomg 15. juli, 2013 @ 16:44 
My hd 3000 have this issues and im using the lastest mesa.
glxinfo output.

OpenGL version string: 3.0 Mesa 9.2.0-devel
OpenGL shading language version string: 1.30
TRololo 15. juli, 2013 @ 19:04 
Hi juliobritomg, this issue seems to be fixed in that version(or maybe they are still working on that), in my case, I just installed libtxc_dxtn package and it fixed the problem. If you're running Linux 64bits you need to install libtxc_dxtn and lib32-libtxc_dxtn for 32bits applications. More info here: https://wiki.archlinux.org/index.php/Intel_Graphics (see Troubleshooting)
Drekyn 8. jan., 2014 @ 1:50 
Got the very exact problem on a machine with intel i5 and integrated intel HD4000 running linux mint. this thread made my day: https://01.org/linuxgraphics/comment/358#comment-358

for me the solution was then to simply run:

sudo apt-get install libtxc-dxtn-s2tc0 libtxc-dxtn-s2tc0:i386

Hope this helps!
novarobot 3. mars, 2016 @ 2:13 
Problem solved:

Linux terminal run:


Or add only L4D2 launcher parameter steam client.

< >
Viser 1-8 av 8 kommentarer
Per side: 15 30 50