Left 4 Dead 2 Beta

Left 4 Dead 2 Beta

Galiral May 5, 2013 @ 7:12am
ubuntu 13.04 raring not starting
launching ./hl2.sh in Left 4 Dead 2 Beta give this error:

Failed to load the launcher ($HOME/.local/share/Steam/SteamApps/common/Left 4 Dead 2 Beta/bin/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by $HOME/.local/share/Steam/SteamApps/common/Left 4 Dead 2 Beta/bin/libtier0.so))

the file libstdc++.so.6 is present

using fglrx-updates (12.9) on raring 13.04
< >
Showing 1-11 of 11 comments
Never May 5, 2013 @ 7:15am 
Works for me on ubuntu 13.04, using wrong drivers could be the problem
BeryJu May 5, 2013 @ 7:37am 
newest is 13.4 for Radeons, so it can be driver problems
Galiral May 5, 2013 @ 7:44am 
i switched to the open source drivers and i get the same problem
bubexel May 5, 2013 @ 9:45am 
its not about drivers, is about the version of glibc you have. I'm not user of Ubuntu... but try update ur glibc.
Galiral May 5, 2013 @ 2:33pm 
i guess it's not that, because it is not referring to the system library libstdc++.so.6 , but to the embedded one in "Left 4 Dead 2 Beta/bin".
i did update glibc with this ppa https://launchpad.net/~ubuntu-toolchain-r/+archive/test , but the error is the same, because its not dependent on the system library.
Last edited by Galiral; May 6, 2013 @ 8:03am
I had the same problem on 12.04, I think I screwed it up a bit by restoring a backup of the non-beta L4D2 onto my Linux steam installation. I found:

$ find . -iname "libstdc*" ./left 4 dead 2/bin/libstdc++.so.6 ./Left 4 Dead 2 Beta/bin/dedicated/libstdc++.so.6 ./Left 4 Dead 2 Beta/bin/libstdc++.so.6

The hl2.sh script selects the libraries in "Left 4 Dead 2 Beta/bin/". The library file in "Left 4 Dead 2 Beta/bin/dedicated/" was a different size to the others, so I copied it into "/Left 4 Dead 2 Beta/bin/" and the game worked.
Galiral May 14, 2013 @ 10:55am 
it is quite strange since my left4dead 2 is a copy of the windows version (i didn't want to download all the 18 gb). Steam downloaded the missing files, and even with the integrity check nothing surfaced as wrong. i am now trying to copy or simlink the file in the dedicated and let you know if it works :)
Galiral May 14, 2013 @ 11:03am 
yep, it works :)
thanks grantek
LamerTex Jul 12, 2013 @ 1:19am 
Thanks it works for me too :)
corvusdeux Jul 21, 2013 @ 12:47pm 
Work for me... is very simple and stupid bug... no?
Nod Aug 27, 2013 @ 11:02pm 
Hi I had the same problem on LTS 12.04 64bit with latest nvidia drivers, the fix worked for me :)

What I did:

$ cd ~/.local/share/Steam/SteamApps/common/Left\ 4\ Dead\ 2 $ find . -iname "libstdc*" -exec md5sum {} \; 4f9c911de2276f988afaf47659a8367f ./bin/dedicated/libstdc++.so.6 8580ee564c50a2371bae7adbd1ab31cc ./bin/libstdc++.so.6 $ mv ./bin/libstdc++.so.6 ./bin/libstdc++.so.6.old $ cp ./bin/dedicated/libstdc++.so.6 ./bin/libstdc++.so.6 $ find . -iname "libstdc*" -exec md5sum {} \; 4f9c911de2276f988afaf47659a8367f ./bin/dedicated/libstdc++.so.6 8580ee564c50a2371bae7adbd1ab31cc ./bin/libstdc++.so.6.old 4f9c911de2276f988afaf47659a8367f ./bin/libstdc++.so.6
< >
Showing 1-11 of 11 comments
Per page: 15 30 50