Left 4 Dead 2 Beta

Left 4 Dead 2 Beta

Issue Report - Xbox 360 Pad Not Functioning Properly
The title says it. The directional pad works in the menus and stuff, but not in a game. Now before all the unhelpful elitist comments flood in saying "YOU'LL BE AT A DISADVANTAGE WTF," some people prefer using a gamepad. I primarily use the standard mouse and keyboard setup, but this might cause some woes for people utilizing Big Picture Mode if this issue is left unaddressed.

I posted the issue on GitHub as well.
< >
Показані коментарі 115 із 17
This issue is happening to me too. I have a Logitech wireless gamepad F710 in X-box pad mode, and it works fine except for the two analog sticks, making the game unplayable. I am running Debian Wheezy, but it doesn't seem to be distribution specific based upon the multiple reports of the exact same problem at the link.

I have problems with my wrists that often make mouse and keyboard play a non-starter, please fix this Valve.
Автор останньої редакції: Carpenter; 4 тра 2013 о 20:49
I have a xbox 360 wireless controller and I have the same problem
Same problem here. I commented on your github bug report.
Are you all running on Linux? Because a 360 controller should function properly on Windows at least. Also, are any of the buttons functional when in-game, like (A) to jump? Because you may need to change some settings in the 360controller.cfg file.
Автор останньої редакції: Rayman1103; 5 тра 2013 о 6:55
All Linux here, I think. Basically everything works as expected except for the analog sticks. Manually binding them via config file or developer console has no effect.
Цитата допису Linux Benjamin:
All Linux here, I think. Basically everything works as expected except for the analog sticks. Manually binding them via config file or developer console has no effect.
If it's just the analog sticks that aren't working, I may be able to assist you. Make sure the joy_axis settings in your 360controller.cfg file are as follows:

joy_advaxisx 3 // x-axis controls GAME_AXIS_SIDE (strafing left and right) joy_advaxisy 1 // y-axis controls GAME_AXIS_FORWARD (move forward and back) joy_advaxisz 0 // z-axis is treated like a button joy_advaxisr 2 // r-axis controls GAME_AXIS_PITCH (look up and down) joy_advaxisu 4 // u-axis controls GAME_AXIS_YAW (look left and right) joy_advaxisv 0 // v-axis is unused

I had to change some numbers around in order for my 360 controller to work, and I have Windows. Let me know if that helps.
Автор останньої редакції: Rayman1103; 5 тра 2013 о 7:37
May or may not be helpful.. I just came from playing a few hours of the Portal beta on Linux, was playing w/ a Logitech controller the whole time, no issue. Fired up L4D2 and found the same issues as reported above; no analog sticks. This controller doesn't have any XBox360 mode or such.
Yeah, I appreciate the help Rayman, but it appears to just be a bug. I guess that's expected, as it is a beta.
Alright, just trying to help if I could. I hope the issue gets sorted out for you.
I too wanted to add that I'm having trouble with the gamepad analog sticks with my wireless xbox 360 controller on Ubuntu LInux using the "xboxdrv --trigger-as-button" module.
I'm having the same problem, buttons respond fine but the sticks don't work at all. I'm assuming it's a bug or something. And yes I'm also running Linux.
Автор останньої редакції: [LOGANG] Logan Paul; 8 лип 2013 о 17:03
+1 that. Left 4 Dead 2, XBox 360 controller on Ubuntu Linux. Everything but the analog sticks is working.
I am also having this issue with Ubuntu 13.04/Linux. The analog sticks do not work, and it is definitely a problem with the game. The analog sticks work in Half-Life 2, Half-Life 2: Episode One, Half-Life 2: Episode Two, Team Fortress 2, Portal, and Half-Life 2: Deathmatch. It seems to be affecting everyone using the Xbox 360 controller on Linux.
i too am having an issue with my xbox 360 wired controller. it works fine in bastion and seriuos sam 3 bfe but not in L4D2. any help would be appreciated. i am using xpad i believe. i even tried enabling the console and issuing exec 360controller but still not even my buttons or the dpad work in the menus.
This bug has been fixed. Do you have any updates pending? If not, try configuring the controller from within Big Picture mode, then launching L4D2.
< >
Показані коментарі 115 із 17
На сторінку: 15 30 50