The Elder Scrolls III: Morrowind

The Elder Scrolls III: Morrowind

Fireeye Apr 19, 2014 @ 1:05pm
Your worst f**k-ups?
What was your biggest failure in Morrowind? Your most emberassing moment?

For me, one of the worst moments was when I was clearing some random cave in Molag Mar with my Altmer Mage. Now, being an Altmer and a mage has certain advantages - you have a metric ton of magicka and high int -, but also certain disadvantages - you are about as tough as a soft tissue and god help you if someone hits you with a destruction spell.

Anyway, I was merrily blasting my way through the cave with a ranged AoE destruction spell - so long as my fireballs landed in the rough vicinity of the enemy, he or she'd be toast. After four or five bandits, I finally stood before the "boss" of the group; a sorceress by her looks. Well, sorcerers can be a pain, and in fact she was already summoning something while I was casting my fire spell.
I thought she could summon a bonewalker at worst, nothing to worry about. What she summoned instead was a Fire Atronach. Which was immune to fire attacks. And - had spell reflect.

Cue to my mage's health bar vaporizing within the fraction of a second and me gnawing at my keyboard because I hadn't saved for the last two hours.
< >
Showing 1-15 of 53 comments
Acidently deleting my Argonain character shortly after beating the main quest. Refuesd to play the game for several months.
D_loaded Apr 19, 2014 @ 1:32pm 
Trying to install mods, WAY to complicated, wanted me to download winzip, wich wanted me to download linkd wich changed my webbrouser settings to show me a strange search engine that shows me pictures of naked simsons.... WTF!!!! so i unintalled all that infecshous ♥♥♥♥, and now morrowind wont even run because i may have ♥♥♥♥ed it up.
Originally posted by D_loaded:
Trying to install mods, WAY to complicated, wanted me to download winzip, wich wanted me to download linkd wich changed my webbrouser settings to show me a strange search engine that shows me pictures of naked simsons.... WTF!!!! so i unintalled all that infecshous ♥♥♥♥, and now morrowind wont even run because i may have ♥♥♥♥ed it up.
Where the bloody hell are you downloading Winzip from?
Edit:By the way, 90 percent sure you hit the wrong download button, because Linkd from what I can tell, shows up alot as those ads on download pages that look like download buttons but arent.
Last edited by Nerevars Goat Volkbert; Apr 19, 2014 @ 1:46pm
LearonR Apr 19, 2014 @ 3:57pm 
exiting while the game is saveing and getting so spoiled by shiny new graphics you cant get back into this great game
Dutchgamer1982 Apr 19, 2014 @ 6:50pm 
My worst mistake would be my first ever play around in this game ever. (like when it was first released oh so many years ago), got it like a week after it hit the shelves.. and me and my friends at that time all played this game.

(I had the poster-map's than came with this game on my rooms wall, placing little x on them, everytime I discovered a new cave...)

now what mistake I made the first time? :
-not knowing properly about how to save and reload.. well lets say :
*in seyda neen, just after starting a new game, I tried to break and enter into a house.. and had the guards behind my back ASAP.
*but instead of knowing I should just reload, or pay the fine, I ran of, before the guard even could reach me (his shout has scared me off)
*from than on I was TERREFIED of guards in any town, as any town I entered I would get noticed and have them scaring me out of town again.
*so I broke in a house just at the border of pelagiat (ignorant of the sheer size of the map) and declared it my home, slept there, and continued looting everthing, and dragging everyting and dropping everything inside that house (had also no clue of the ability of selling).. and I mean EVERYTHING (there was not a single fork, knife, plate, bowl or cup I did not take)
*but I did not do this by sneaking, but instead just by entering a town, run inside a house before I was caught, and than run off again, with my loot, no missions, no nothing.
So I had a deathwarrant on my head (bout 14.000 on my head) without ever taking a life, and only by stealing the common items that are all around seyda neen and pelagiat.
*my friend visited me later, and was like, and how you like balmorra?
*I than responded with ignorance : balmorra?
*he : err you HAVE been playing this game for 2 weeks, and for like 100 hours like we didn't you?
*me : yup, 130 hours actually.
*he : than WTF have you been upto
*me showing "my" house at the border of pelagiat... it was litterly STUFFED floor to roof, with HUNDREDS UPON HUNDREDS of items, mostly pottery.
*he laughed big time...;) helped me to get into the thieves guild, clear my name and start actually playing.

This one event, has made my reputation in the gaming community :
Even till upon this day, at lan's and such when I play game's with them, whenever I am needlessly wasting time on unessential parts of a game, while necleting the main focus, my friends shout to me NO POTTERY TRICKS!
Last edited by Dutchgamer1982; Apr 19, 2014 @ 6:57pm
EmptyK Apr 20, 2014 @ 3:02pm 
Harry Pottery and the Goblet of Fire.
I have two stories.

1. I was in the middle of finishing the main quest and I killed one of the character nessacary to complete it. Fortunatly I had a save from a few days before the murder but I lost all the artifacts I had collected as well as 5 levels :(

2. This happened before the previous story. I first got the game and decided to do some of the guild and side quest. After about a month I decided to do the main quest. When I went to do it I noticed that I didn't have my papers and I couldn't find them. This was when I was new to the elder scrolls and didn't know about console commands. I deleted my level 40 bosmer with one shot one kill archery and glass armor and level 100 sneak. The day after I found out about console command ...
WolfWrag Apr 21, 2014 @ 5:05am 
well, long time ago, on one of my first game play or maybe my first one i was exploring to far in ashlands with my low level orc barbarian and guess what... i get bullied by cliffracers 4 or 5.... i run, i traid fight, presence of them didnt let me rest and no matter what i did they just kept coming... i run out of healt potions and each minute was struggle for life... run in some random cave's with hope, that when i will come out they will be gone... but no! as well cave's was full with more stronger foe... my save was made so long time ago.... 3 h or so and i didnt want to lose my progress so i just try survive... when i finally get back in balmorra i was so terrified from going back in ashlands... when ever i get quest what involved going there i just start some thing else... even now i have great respect for ashlands
GDSpectra Jun 20, 2014 @ 2:14am 
Oh my gods, when I accidentally discovered that Vivec Foreign Quarter has a tomb in the Canalworks ... containing a Greater Bonewalker, Claymore-yielding Skeleton and Skeleton Archer with paralyzing arrows right at the door. Even though I didn`t have Restore Strength spells or anything on me, I had managed to take down both the GBonewaler and the Skeleton, but at the end, I rushed at Skeleton Archer ... and got destroyed by it as soon as I got paralyzed.
I was mentally devastated, despite the fact that I had saved right before I went in there and even now I still hope that I would not meet anything like that again when I go to Ancestral Tombs (beside Daedra, of course. Atronarchs easily handle my chara`s ♥♥♥ back to me).
Voltronjeremy Jun 20, 2014 @ 5:15am 
Probably the first time I did the Tribunal dlc. I was at that part where you go into the dwarven ruin to see what's going on and see all the constructs fighting against each other. I thought to myself "Hey here's a perfect opportunity to use that absurdly powerful aoe spell I made just for kicks!" so I looked around and picked the perfect spot to drop this magical nuke, and emptied out my mana bar.

Turns out there were a lot of spell reflects up and I ended up dying so fast that I wasn't even able to open up my bag to try and chug a healing potion.

I also hadn't saved since I first arrived in Mournhold. I said ♥♥♥♥ it and just went off to kill some generic frost witches in Solstheim.
Trying to install Morrowind Overhaul, now my computer trys to open .rar files with chrome.
Doit Jun 23, 2014 @ 8:27pm 
Someone told me about them getting traped in a dungeon for a week, leveling up their acrobatics skill to be able to clear a gap and escape. Now thats an RPG.
spaneika Jun 24, 2014 @ 7:56am 
stumbling into Mournhold way way too early, and running into Gaenor...
spaneika Jun 24, 2014 @ 7:57am 
350 days and 600+ journal page entries later, i returned and handed his ♥♥♥ to him.
Mehukannu Jun 25, 2014 @ 5:17am 
I spent two good hours finding one Telvanni wizard at his house, consulting wikies to confirm I was at the right place and wondering where I can use all these nice levitation potions, until I happened to look at the roof, where I saw a handy hole.
Never felt as frustrated. =D
< >
Showing 1-15 of 53 comments
Per page: 15 30 50

Date Posted: Apr 19, 2014 @ 1:05pm
Posts: 53