The Elder Scrolls III: Morrowind

The Elder Scrolls III: Morrowind

Abu Mustard Nov 3, 2015 @ 10:05am
How do I force the game to use my dedicated graphics card?
Hi!

I'm trying to run Morrowind on my laptop (if that matters). When I go into the options menu, in the launcher, there is only the choice to use my integrated intel graphics card, even though I have a gt840M in this computer. Is there a way to force the game to use my dedicated graphics card?
< >
Showing 1-15 of 21 comments
Siziol Nov 3, 2015 @ 10:12am 
type nvidia into your search to find the program "Nvidia Control Panel."

Under manage 3d settings, it might take a second to load (or you might have to click the add button), but look for "Elder Scrolls 3: Morrowind" in the first dropdown box under program settings.

Box 2 says "Select the Preffered graphics processor for this program," click the dropdown and select the graphics card you want to use. For my laptop the two options are "High-performance NVIDIA processor" and "Integrated Graphics"
Abu Mustard Nov 3, 2015 @ 10:17am 
Ah, I've already tried that, but there is still no choice in using the Nvidia card in the launcher, nor has the game performance changed.
Nadlug Nov 3, 2015 @ 12:29pm 
This is why Dual card laptops and gaming laptops in general are a bad idea -.-

Have you treid Disabeling the intergrated card in your device manager?
Abu Mustard Nov 3, 2015 @ 3:48pm 
I haven't done that, but I can give it a try tomorrow!
Nadlug Nov 3, 2015 @ 5:37pm 
Originally posted by Link - Hero of Time:
I haven't done that, but I can give it a try tomorrow!

In general games (especially older ones) have difficulty picking the proper graphics card for dual card laptops which is why i said its a really bad idea.

In pratice they conflict with each other, have priority issues such as what your expierencing, and in general its just wasted space. Better to have one "Great" graphics card than one "Good" one and an "Ok" one that you never really want to use except in power saving mode. Which dosent really prolong a batter charge given how cheaply made laptop batters are thesedays.

But thats a rant all on its own so ill spare you the details and summrise it saying there is no standard set for the battery industry. Anyone can claim their battery has a "quick charge" or "Long life" even though it could take 24 hours to charge and run out of juice in 5 minutes.
Abu Mustard Nov 4, 2015 @ 6:52am 
Originally posted by Nadlug:
Originally posted by Link - Hero of Time:
I haven't done that, but I can give it a try tomorrow!

In general games (especially older ones) have difficulty picking the proper graphics card for dual card laptops which is why i said its a really bad idea.

In pratice they conflict with each other, have priority issues such as what your expierencing, and in general its just wasted space. Better to have one "Great" graphics card than one "Good" one and an "Ok" one that you never really want to use except in power saving mode. Which dosent really prolong a batter charge given how cheaply made laptop batters are thesedays.

But thats a rant all on its own so ill spare you the details and summrise it saying there is no standard set for the battery industry. Anyone can claim their battery has a "quick charge" or "Long life" even though it could take 24 hours to charge and run out of juice in 5 minutes.

Unfortunately deactivating the integrated graphics didn't work either. Now the performance is horrible and the only card it can find is "Microsoft Basic Display Driver". Guess I'll have to play Oblivion instead, or Morrowind with the view distance turned down a bit.

I'm studying at the moment and I've not been able to bring my desktop, so this is all I've got to play on at the moment.
Last edited by Abu Mustard; Nov 4, 2015 @ 6:55am
EgoMaster Nov 4, 2015 @ 7:17am 
Originally posted by Link - Hero of Time:
Unfortunately deactivating the integrated graphics didn't work either.
- Never, ever do that again. Your integrated card is your primary card. As far as I know, it controls the monitor output and everything nVidia card does, passes through it. That's why everything is more sluggish with it turned off. I suggest you reactivate it or install its driver again.

- You cannot select graphics card from a game's (and I mean any game's) setup/launcher etc. (You could in the 90s but not anymore.) Even if you can, it has no effect. The only way to do it is through nVidia Control Panel as suggested. Provided there are no problems with your hardware or software, the game doesn't have any other choice but to run with the GPU you designate. This is handled by OS and drivers. If you're sure it doesn't work, restarting may help. You can see if the game uses nVidia or not via its tray icon. When the dedicated GPU is in use, nVidia tray icon changes color.

- You don't see much performance change because you're probably using MGSO, which contains MGE XE. This program provides fancy modern graphical FX but works as an emulation, which means it's not very efficient. Try to find a balance between visual fidelity and performance. Hint: Distant lands is a performance hog.

Originally posted by Nadlug:
This is why Dual card laptops and gaming laptops in general are a bad idea -.-
Amiga and 3DFX want a word with you. As far as I'm concerned, the only bad idea here is to disable the integrated GPU.
Last edited by EgoMaster; Nov 4, 2015 @ 7:50am
Abu Mustard Nov 4, 2015 @ 8:55am 
Originally posted by EgoMaster:
Originally posted by Link - Hero of Time:
Unfortunately deactivating the integrated graphics didn't work either.
- Never, ever do that again. Your integrated card is your primary card. As far as I know, it controls the monitor output and everything nVidia card does, passes through it. That's why everything is more sluggish with it turned off. I suggest you reactivate it or install its driver again.

- You cannot select graphics card from a game's (and I mean any game's) setup/launcher etc. (You could in the 90s but not anymore.) Even if you can, it has no effect. The only way to do it is through nVidia Control Panel as suggested. Provided there are no problems with your hardware or software, the game doesn't have any other choice but to run with the GPU you designate. This is handled by OS and drivers. If you're sure it doesn't work, restarting may help. You can see if the game uses nVidia or not via its tray icon. When the dedicated GPU is in use, nVidia tray icon changes color.

- You don't see much performance change because you're probably using MGSO, which contains MGE XE. This program provides fancy modern graphical FX but works as an emulation, which means it's not very efficient. Try to find a balance between visual fidelity and performance. Hint: Distant lands is a performance hog.

Originally posted by Nadlug:
This is why Dual card laptops and gaming laptops in general are a bad idea -.-
Amiga and 3DFX want a word with you. As far as I'm concerned, the only bad idea here is to disable the integrated GPU.

I already reactivated the integrated graphics, so that's fine. I already tried setting the GPU in the Nvidia Control Panel as described above, but there is no effect. According to GPU-Z the game is still using the integrated graphics card, as that's the only card showing GPU load.

I've not installed any mods (such as MGSO) either. The game is completely vanilla.
Nadlug Nov 4, 2015 @ 10:07am 
Originally posted by EgoMaster:
Originally posted by Nadlug:
This is why Dual card laptops and gaming laptops in general are a bad idea -.-
Amiga and 3DFX want a word with you. As far as I'm concerned, the only bad idea here is to disable the integrated GPU.

I previously worked in a profession where I performed warrenty repairs on Laptops of a large variety of performance ranges. I stand by my statement. Gaming laptops make me laugh, dual card setups are powderkegs.
EgoMaster Nov 4, 2015 @ 11:25am 
Originally posted by Nadlug:
I previously worked in a profession where I performed warrenty repairs on Laptops of a large variety of performance ranges.
I respect your opinion, but I don't think that makes you more qualified than designers of groundbreaking gaming hardware, who used normal+dedicated processor system decades from today.

I already reactivated the integrated graphics, so that's fine. I already tried setting the GPU in the Nvidia Control Panel as described above, but there is no effect. According to GPU-Z the game is still using the integrated graphics card, as that's the only card showing GPU load.

I've not installed any mods (such as MGSO) either. The game is completely vanilla.
I suspect when you clicked "add", nVidia control panel chose morrowind's launcher instead of game's executable file. Try this:

- Go to "steam\steamapps\common\morrowind" folder. Or right click on Morrowind in your library, choose properties, go to "local files" tab and click on "browse local files".
- Right click on morrowind.exe.
- You should see a "change default graphics processor" (or something like that) option. Click it.
- nVidia control panel will open with settings for morrowind.exe. Change it to nVidia processor.

This is how I did it right now.
Abu Mustard Nov 4, 2015 @ 1:09pm 
Originally posted by EgoMaster:
Originally posted by Nadlug:
I previously worked in a profession where I performed warrenty repairs on Laptops of a large variety of performance ranges.
I respect your opinion, but I don't think that makes you more qualified than designers of groundbreaking gaming hardware, who used normal+dedicated processor system decades from today.

I already reactivated the integrated graphics, so that's fine. I already tried setting the GPU in the Nvidia Control Panel as described above, but there is no effect. According to GPU-Z the game is still using the integrated graphics card, as that's the only card showing GPU load.

I've not installed any mods (such as MGSO) either. The game is completely vanilla.
I suspect when you clicked "add", nVidia control panel chose morrowind's launcher instead of game's executable file. Try this:

- Go to "steam\steamapps\common\morrowind" folder. Or right click on Morrowind in your library, choose properties, go to "local files" tab and click on "browse local files".
- Right click on morrowind.exe.
- You should see a "change default graphics processor" (or something like that) option. Click it.
- nVidia control panel will open with settings for morrowind.exe. Change it to nVidia processor.

This is how I did it right now.

Followed your instructions to the letter but there is still no difference unfortunately. The game is still using the integrated graphics card.
Nadlug Nov 4, 2015 @ 4:39pm 
Originally posted by EgoMaster:
Originally posted by Nadlug:
I previously worked in a profession where I performed warrenty repairs on Laptops of a large variety of performance ranges.
I respect your opinion, but I don't think that makes you more qualified than designers of groundbreaking gaming hardware, who used normal+dedicated processor system decades from today.

Appreciated but Develoeprs and designers make alot of bad decisions (just look at hyperthreading).

IT dosent take design knowledge to realise that the only benifit of having a dual card setup on a laptop is the potential to save power on the weaker graphics processor which could be better achived by having a dedicated one that can downclock itself when processing power is not nessisary. Its completely wasted space that coudl be used on better hardware or heat management. Not to mention the conflicts it frequently produces such as whats happening now.

As for the problem here, I know there was a thread that had the exact same problem around here before. It was resolved eventually but all i remeber was that the solution was rather simple. I just cant remeber exactly what nor can I find the thread -.-
Omgwtfbbqkitten Nov 6, 2015 @ 12:09am 
It sounds like your problem might be with your bios settings.

You need to enter your bios setup and specify which GPU is used. By default it is probably setup to use the integrated graphics, so you need to set it up to use the dedicated card.
Last edited by Omgwtfbbqkitten; Nov 6, 2015 @ 12:12am
Abu Mustard Nov 6, 2015 @ 7:16am 
Originally posted by Omgwtfbbqkitten:
It sounds like your problem might be with your bios settings.

You need to enter your bios setup and specify which GPU is used. By default it is probably setup to use the integrated graphics, so you need to set it up to use the dedicated card.

Thanks! I will try this later.
canyon Sep 20, 2017 @ 2:38pm 
Originally posted by Siziol:
type nvidia into your search to find the program "Nvidia Control Panel."

Under manage 3d settings, it might take a second to load (or you might have to click the add button), but look for "Elder Scrolls 3: Morrowind" in the first dropdown box under program settings.

Box 2 says "Select the Preffered graphics processor for this program," click the dropdown and select the graphics card you want to use. For my laptop the two options are "High-performance NVIDIA processor" and "Integrated Graphics"
I use an AMD Radeon R9 M375X and there is no Catalyst Control center and I need help!
< >
Showing 1-15 of 21 comments
Per page: 1530 50

Date Posted: Nov 3, 2015 @ 10:05am
Posts: 21