Steam for Linux

Steam for Linux

Sentry 2014년 1월 29일 오전 12시 33분
[SOLVED] Error about missing after installing new nVidia driver 331
I'm using Ubuntu 12.04.1 64bit. (And no, I don't want to upgrade right now, I don't have the time.)
Graphics: nVidia GeForce 560 Ti

After some Steam client update last year, it started complaining about the OpenGLX context not using direct rendering, which worked fine before. My (and others) guess was that I needed newer nVidia drivers, which were not available for my version of Ubuntu (I don't want to upgrade right now, see above.)

Yesterday, nvidia-331 and so on became available and I installed them, hoping that would fix the problem. But now Steam is telling me:

Error: You are missing the following 32-bit libraries, and Steam may not run:

I could try to install the fglrx package for AMD cards, but I shouldn't need it and I'm afraid it could confuse and mess up my graphics.

Any ideas? This seems to be a very new problem and Google gives me only 3 search results, all about AMD cards.
Sentry님이 마지막으로 수정; 2014년 1월 31일 오전 10시 27분
< >
1-66개 댓글 표시
Kranky K. Krackpot 2014년 1월 29일 오전 10시 56분 
Maybe this can help:
Nvidia doesn't need ATI libs.
Sentry 2014년 1월 29일 오전 11시 57분 
Thanks, I've already found that site, but there is no
package or similar available. There are only

And I know that Nvidia doesn't need ATI libs ;)
Kranky K. Krackpot 2014년 1월 29일 오후 1시 48분
Both libgl1-mesa-dri and libgl1-mesa-glx are in Steam's and nvidia's dependencies on Ubuntu, that is Steam seems to need both of them. Unfortunately I don't have Ubuntu, and don't know what exactly must be installed... But anyway, installing will hardly solve the problem.
Kranky K. Krackpot님이 마지막으로 수정; 2014년 1월 29일 오후 2시 14분
Sentry 2014년 1월 29일 오후 2시 29분 
I appreciate your effort, but you seem to have misunderstood me. The libgl1-mesa-* packages are available and installed on my system, but not the libgl1-nvidia-* packages.

I openend an issue at github for that, because I think this is an error in the script.
Sentry님이 마지막으로 수정; 2014년 1월 29일 오후 2시 30분
Kranky K. Krackpot 2014년 1월 30일 오후 11시 49분 
Well then. Do glxinfo and glxgears work? Did you try to reinstall 331 driver?
I think it's that wants that for some reason. Several packages (glrfx, nvidia, mesa, etc) install their own variants of lib, that may overwrite each other. Shortly, if glxinfo doesn't work too, it seems to me that 331 just wasn't installed correctly, and now misses its, so reinstalling 331 will bright its lib back.
Sentry 2014년 1월 31일 오전 10시 26분 
Okay, I got it! In the end, it was easy, but still.

Short version

Solution: I deleted /usr/lib32/ and reinstalled libgl1-mesa-glx:i386
Explanation: This is a very old and frequently updated installation of Ubuntu. And back in the days, I had an ATI/AMD graphics card and its drivers installed. Seems like the deinstallation didn't clean everything up and the /usr/lib32/ was still built against the AMD files. After I've deleted this file and reinstalled libgl1-mesa-glx:i386, the symlinks to it were removed, too, and the Nvidia driver is now found. Steam works fine again.

Full explanation at github[]
< >
1-66개 댓글 표시
페이지당 표시 개수: 15 30 50