Steam for Linux

Steam for Linux

OOPMan 2012 年 12 月 12 日 上午 3:11
Serious Graphical Corruption
Okay, just installed Steam Linux Beta on my 64-bit Sabayon laptop and I'm seeing some serious graphical corruption. First off, relevant info:
  • 1.6ghz Core i7 CPU
  • 8gb DDR3 RAM
  • Radeon HD 4570 with 512mb DDR2 VRAM using open-source XF86 ATI 7.0.0 drivers
  • 10gb free on root, 30+gb free on home
  • Kernel 3.6, 1.12.4, KDE 4.9.3 running with OpenGL Compositing
  • Primary display is 1440x900 laptop LCD, secondary is 24" 1920x1080 LCD

The following things:
  • All Steam window content corrupted when Steam windows not maximised (See here[])
  • Some Steam window content corrupted when Steam windows maximused (See here[])
  • Big screen mode looks really good but takes a while to start working and always renders on the primary display. If moved to the secondary display it does not rescale. (See here[])
最後修改者:OOPMan; 2012 年 12 月 12 日 上午 3:12
< >
目前顯示第 1-13 則留言,共 13
voodooelectricj 2012 年 12 月 12 日 上午 10:05 
I think I have the same problem. My card is a radeon HD 4870 and I am using the xf86-video-ati drivers on a gentoo linux desktop. I believe I have all my openGL stuff set up correctly, as I have all the fancy desktop effects working. When I run steam from the command line, I get a whole ton of messages that say: "radeon: The kernel rejected CS, see dmesg for more information." (the dmesg isn't particularly enlightening to me). If I maximise the windows, things work a lot better and that endless stream of kernel rejection messages seems to stop.

Didn't realise that I could get things semi working by maximising, so I haven't tried out any games yet.
OOPMan 2012 年 12 月 12 日 上午 10:12 
Hmmmmm, I also have yet to try any games. I will probably start playing about in that regard tomorrow....
ZiggySpelldust 2012 年 12 月 15 日 上午 6:31 
I'm having these exact issues as well.

Processor Information:
Vendor: GenuineIntel
Speed: 2401 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GT 540M/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xdf4
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 1366 x 768
Desktop Resolution: 1366 x 768
Primary Display Size: 13.54" x 7.60" (15.51" diag)
34.4cm x 19.3cm (39.4cm diag)
Primary VRAM: 1023 MB

Sound card:
Audio device: Intel CougarPoint HDMI

RAM: 5880 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 294231 Mb
Largest Free Hard Disk Block: 222861 Mb

Installed software:

Recent Failure Reports:
Fri Dec 14 15:16:30 2012 GMT: file ''/tmp/dumps/assert_20121214101627_1.dmp'', upload yes: ''CrashID=bp-b848d69c-69be-4c23-b66a-68bc12121214''
Sat Dec 15 04:18:15 2012 GMT: file ''/tmp/dumps/assert_20121214231814_2.dmp'', upload no: ''HTTP response code said error''

voodooelectricj 2012 年 12 月 29 日 下午 2:24 
Alright, so after getting back from Christmas break, I had some packages to update. After doing the update, I don't have the bad graphical stuff that requires the steam window to be maximized to see anything. These are the packages that I suspect made the difference (again, this is a gentoo box):

[ebuild U ] app-emulation/emul-linux-x86-xlibs-20121202 [20121028] USE="opengl -development" 2,416 kB
[ebuild U ] app-emulation/emul-linux-x86-opengl-20121202-r1 [20121028] USE="-development" 60,640 kB
[ebuild U ] app-emulation/emul-linux-x86-gtklibs-20121202 [20121028] USE="-development" 6,047 kB
[ebuild U ] app-emulation/emul-linux-x86-medialibs-20121202 [20121028] USE="-development" 10,124 kB
[ebuild U ] app-emulation/emul-linux-x86-soundlibs-20121202 [20121028] USE="alsa -development" 6,932 kB
[ebuild R ] app-emulation/wine-1.4.1 USE="X alsa cups gecko jpeg lcms ldap mp3 ncurses nls opengl oss perl png prelink%* ssl threads truetype udisks win32 win64 xcomposite xinerama xml -capi -custom-cflags -fontconfig -gnutls -gphoto2 -gsm (-gstreamer) -odbc -openal -opencl -samba -scanner (-selinux) {-test} -v4l (-hardened%)" 0 kB
[ebuild U ] app-emulation/emul-linux-x86-sdl-20121202 [20121028] USE="-development" 579 kB
[ebuild U ] app-emulation/emul-linux-x86-qtlibs-20121202 [20121028] USE="-development -gtkstyle" 17,743 kB

Perhaps I'll try my luck with TF2 again :)

OOPMan 2012 年 12 月 29 日 下午 10:10 
Hmmmmmmmmmm, Sabayon just pushed an update yesterday so I will try again and see if anything has changed. If not, I'lll check the versions against those you listed...
voodooelectricj 2012 年 12 月 31 日 上午 9:00 
TF2 indeed runs now (quite a surprise!). Doesn't run great (low framerate), but that's probably a different problem.
OOPMan 2012 年 12 月 31 日 上午 9:07 
Hmmmm, main layout is now fixed for me but drop-down menus are still busted :-/
RussianNeuroMancer 2013 年 1 月 3 日 下午 3:59 
Maybe driver bug? In this case you need to fill it to freedesktop bugtracker.
OOPMan 2013 年 1 月 3 日 下午 8:34 
Hmmmmmmmmmmm, I don't see this behaviour in any other applications though...

I still need to play around a bit though and trying running a 32-bit version of Steam via my chroot and various other things...
最後修改者:OOPMan; 2013 年 1 月 3 日 下午 8:35
OOPMan 2013 年 1 月 4 日 上午 12:25 
So, as voodooelectricj did, I started steam from the command-line. Any time graphical corruption occurs the following message is display:

radeon: The kernel rejected CS, see dmesg for more information.

The associated dmesg info is:

[ 2491.179581] radeon 0000:02:00.0: r600_cs_track_validate_cb invalid tiling 6 for 0 (0x08110668) [ 2491.179588] radeon 0000:02:00.0: r600_packet3_check:1913 invalid cmd stream 566 [ 2491.179592] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !

I am going to try my luck on the efnet irc channel for the radeon driver and see if the experts have any clue what the issue is...
necrophcodr 2013 年 1 月 4 日 下午 3:03 
I've been getting the same error for a long time on Sabayon as well.
Also running ATi on my desktop and netbook, both have this problem.
NOT a problem on elementary OS running Mesa 9.1 though.
OOPMan 2013 年 1 月 4 日 下午 9:32 
The issues seems to be tied to the 32-bit multi-libs provided for 64-bit sabayon (The steam client is still a 32-bit only applicatio).

I have a separate 32-bit sabayon install that I use for chroot work stuff and after installing steam on that I found that things work perfectly.
< >
目前顯示第 1-13 則留言,共 13
每頁: 15 30 50