Steam for Linux

Steam for Linux

Steam for Linux > Non-Valve Games > Topic Details
Audio doesn't work in Steam and Serious Sam 3, works in TF2
I've got a problem. I've got an Audigy 2ZS sound card, running through ALSA for drivers, and then through pulse. I've also got the pulse-alsa module so the default ALSA card is actually run through pulse. This means that all apps should be running through Pulse.

With TF2, everything works fine - Not only does the audio work(which is going through pulse, as expected), but the microphone works perfectly as well.

With Steam itself, the audio-in part works -- in the 'voice' settings page, I can see the audio-level bar correspond to my voice, so I've got audio-in, but that audio isn't being relayed to my speakers -- i.e. no audio out.

With SS3: BFE, same deal - No audio out(haven't tested microphone).

Now, I've tested everything I can - pacmd shows me that the default-sink is correct, as does alsamixer(Card 0 = pulse)

I've tried testing SDL by having MPlayer route it's output through it, which seems to work, but I'm only testing the x86_64 version.

Here's my system information stats:
Processor Information: Vendor: AuthenticAMD Speed: 3200 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Unsupported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Debian GNU/Linux 7.0 (wheezy) (64 bit) Kernel Name: Linux Kernel Version: 3.6.0-11.dmz.1-liquorix-amd64 X Server vendor: The X.Org Foundation X Server release: 11204000 Video Card: Driver: NVIDIA Corporation GeForce GTX 560/PCIe/SSE2 Driver Version: 4.3.0 NVIDIA 310.19 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 119 Hz VendorID: 0x10de DeviceID: 0x1201 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 2104 Primary Display Size: 20.04" x 11.26" (22.95" diag) 50.9cm x 28.6cm (58.3cm diag) Primary Bus: PCI Express 16x Primary VRAM: 1023 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: SigmaTel STAC9721,23 Memory: RAM: 16028 Mb Miscellaneous: UI Language: English LANG: C Microphone: Not set Total Hard Disk Space Available: 69790 Mb Largest Free Hard Disk Block: 44067 Mb

Note that alsamixer shows me that that SigmaTel chip is part of the Audigy 2ZS card.

Also note that I'm reluctant to post this as a bug just yet, as I'm running a somewhat nonstandard setup.

Any suggestions?
< >
Showing 1-4 of 4 comments
AlenL Dec 25, 2012 @ 2:16pm 
We don't really care which audio setup is underneath, as long as it plays well with OpenAL. You should check the settings on that. If all else fails, please post Sam3.log as that has the data important for us.
Thanks for taking the time to reply. I appreciate it.

That being said, OpenAL seems to be installed and working, but I'm not sure how to test it. Config file seems to be stock, all settings are commented out(which should give them the defaults).

Here's a complete Sam3.log file I just made. I:
1. Started the game,
2. Watched the intro movies(played file, no audio)
3. Started a new game -> Campaign -> Summer in Cairo
4. Watched the intro for that as well, until Sam wakes up after crashing through the building roof and you are able to move.
5. Quitted the game.

I'm running OpenAL 1.14 I believe.

Speaking of which, another minor issue you might be able to offer advice on:
If I have the 'max 3d rendering mpix' setting set to something less than whatever resolution I am trying to display, I just get a black screen where any 3D should be - hitting esc and bringing up the menu works fine. Overlay/HUD also displays.
If I put it in windowed mode and make the window smaller than that mpix setting, it'll display fine. As soon as I scale the window larger, it black screens again and sometimes crashes.
I'm guessing something to do with scaling the 3d or adding black boxes around it isn't working?
Once I set the mpix setting to "unlimited" I had no issues with black screening, but it was seriously confusing at first.


AlenL Dec 26, 2012 @ 5:45am 
The only thing wrong I see in the log is the OpenGL API errors regarding textures. But I don't know why you get those with that GPU and that driver. Is that perhaps a dual-GPU system or something?
Nope, single GTX 560, with the 310.19 beta drivers.
Here's my glxinfo output:

As far as my audio problem, I didn't see anything error-like, so I thought OpenAL might be working, just sending the audio data to an incorrect card/port.
Looks like I found a workaround:
There is a file named ~/.alsoftrc which has the user-specific OpenAL configuration.
If I changed it to use ALSA instead of Pulse by default, it works.
[general] drivers = alsa [alsa] device = default capture = default mmap = true
This fixes Steam audio as well as SS3:BFE, but I'm still not sure why Pulse isn't working(directly anyway). I suppose I'll just have to do some more research, but I've got something working as it is.
< >
Showing 1-4 of 4 comments
Per page: 15 30 50

Steam for Linux > Non-Valve Games > Topic Details