Steam for Linux

Steam for Linux

TF2 Unplayable
TF2 is unplayable for me. Main menu stuff works fine. Loading a map is extremely slow. Game runs at 5-10 FPS, stuttering frequently. Occasionally gets a few moments of high FPS but still stutters.

Arch Linux
AMD Athlon X2 3 GHz Dual Core
NVIDIA GeForce 9600 GT with 310.19 drivers
< >
Mostrando 1-14 de 14 comentarios
Desert Froggo 23 DIC 2012 a las 21:05 
Yes I have a similar issue. Mine is a bit slow, but is at least decently playable. I guess it's because you have much lower-end graphics card as mine is a GTX 560Ti. I think this is a normal problem. After all, the Linux version is still in beta so I guess we can't expect it to perform all that well just yet. Many people still can't even get it to work at all. I sure hope they have a lot more room for improvement though.
Artemis3 27 DIC 2012 a las 1:18 
Do this in the main menu: go to options, video, advanced, and lower all graphic options (multi core rendering is bugged, disable). Then try a training game for testing, and see which option you can increase. Sadly, everytime you change an option, the game takes several seconds (or minutes) for the changes to apply. You can't do this connected to a real server because it will kick you from inactivity.

This game is also eating a lot of memory so you should watch out for excesive swap usage, i hope you have at least 4g of ram to accomodate game + desktop.

To stabilize these "moments of high fps but still stutters" you might want to try vsync enabled with Triple Buffering active (in Xorg.conf options). Do try launching the game with a lower desktop resolution as well to improve gaming performance.

The game is very playable with a 9800GT, and quite smooth with a gtx460. I wish it had FXAA.
Hwkiller 27 DIC 2012 a las 10:28 
I'm having major FPS issues myself. When it's smooth, it's VERY smooth. Then I get 15fps stutters, and my mouse lags. Drives me crazy!
Gambit 29 DIC 2012 a las 15:36 
Ensure that vertical sync is also disabled.
MaPi_svk 19 ENE 2013 a las 1:49 
I also have this problem. I have both Vsync and Multicore rendering disabled. I have this problem only when playing online, in offline practice it is running well at 70 fps.
gutigen 19 ENE 2013 a las 4:42 
Custom server scripts? I've noticed that I got strange stutter at some servers and butter smooth gameplay at other with same amount of players and same maps Oo
MaPi_svk 20 ENE 2013 a las 0:50 
I don't think the problem is a custom server script. It's not just stutter, my fps never goes above 6 fps while playing on a server. And when I'm playing on windows(on the same computer) I don't have this problem. Also, so far it happened on every server.
gutigen 20 ENE 2013 a las 1:12 
Try to turn off VSYNC in NVIDIA settings and in TF2 and turn off HDR.
MaPi_svk 20 ENE 2013 a las 2:36 
Thank you! I turned off Sync to VBlank and HDR and it works quite well now.
gutigen 20 ENE 2013 a las 11:41 
Publicado originalmente por {SvkTrollz} MaPi_svk:
Thank you! I turned off Sync to VBlank and HDR and it works quite well now.

Great :)

Put [Solved] in front of your thread title, so others may know that there is some kind of solution here :)
MaPi_svk 20 ENE 2013 a las 12:12 
I would, but this isn't my thread
gutigen 20 ENE 2013 a las 12:26 
Oh right... lol :)
KIAaze 26 ENE 2013 a las 9:29 
TF2 and TF2 beta also run slowly for me. :(
System info:
Processor Information: Vendor: AuthenticAMD Speed: 2400 Mhz 4 logical processors 4 physical processors HyperThreading: Unsupported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Supported SSE41: Unsupported SSE42: Unsupported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-22-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: X.Org Gallium 0.4 on AMD RV710 Driver Version: 2.1 Mesa 9.0 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID: 0x1002 DeviceID: 0x954f Number of Monitors: 1 Number of Logical Video Cards: 1 Primary Display Resolution: 1440 x 900 Desktop Resolution: 1440 x 900 Primary Display Size: 16.06" x 10.04" (18.94" diag) 40.8cm x 25.5cm (48.1cm diag) Primary VRAM Not Detected Sound card: Audio device: Realtek ALC888 Memory: RAM: 3952 Mb Miscellaneous: UI Language: English LANG: en_GB.UTF-8 Microphone: Not set Total Hard Disk Space Available: 228877 Mb Largest Free Hard Disk Block: 460 Mb Installed software: Recent Failure Reports:
I already tried lowering all settings, disabling multicore, bilinear/anistropic, etc, as well as this:

I might try switching to openbox (using KDE with desktop effects disabled at the moment) and/or lowering the resolution, but the long loading times make this all a bit frustrating to try out...
Other 3D games like Prey, Openarena, etc work fine.

TF2 beta was actually more or less playable the first time I tried it.
When I tried TF2, it started being slow. Tried TF2 beta again, and it's also slow now.
FPS varies from 0 to 30, but is around 10 on average.
Última edición por KIAaze; 26 ENE 2013 a las 9:30
PARTY MAN X 15 FEB 2013 a las 15:03 
I'm also having this issue, but CS:S works fine.
< >
Mostrando 1-14 de 14 comentarios
Por página: 15 30 50

Publicado el: 22 DIC 2012 a las 17:35
Mensajes: 14