Steam for Linux

Steam for Linux

C0ntroller◄Z Dec 22, 2012 @ 11:46am
Get blackscreen and crash when start TF2
Hey, I've got a problem

Every time when I start TF2, I got a blackscreen at the Valve Logo (but I hear the sound) and when I after the second logo the game crashes. I don't have any idea, why because the fail message in the console is veeeery long but the last message is
LLVM ERROR: Program used external function '' which could not be resolved! /home/daniel/.local/share/Steam/SteamApps/c0ntroiier/Team Fortress 2/ Zeile 72: 748 Speicherzugriffsfehler ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
"Speicherzugriffsfehler" means "memory access error" in German (says the Google translator :D)

Befor I was able to start TF2, I must start steam with
force_s3tc_enable=true steam
because, when I don't do this, there is following error when I try to start TF2:
Required OpenGL extension "GL_EXT_texture_compression_s3tc" is not supported. Please install S3TC texture support. X Error of failed request: BadWindow (invalid Window parameter)
so I thing this is the problem.

Anyone got an idea? I've got Gentoo and an NVidia Geforce GT 610 with the newst driver version (310.19).
< >
Showing 1-1 of 1 comments
C0ntroller◄Z Dec 23, 2012 @ 5:08am 
Ok problem solved. I have reinstall the graphik driver, because in all games (examble Minecraft) I have problems with OpenGL. Now it works fine :)
< >
Showing 1-1 of 1 comments
Per page: 15 30 50

Date Posted: Dec 22, 2012 @ 11:46am
Posts: 1