Steam for Linux

Steam for Linux

eat like snake Dec 20, 2012 @ 5:37pm
TF2 OpenGL error "Could not find required OpenGL entry point 'glGetError'...
Kubuntu 12.04
Computer model: Dell Vostro 3550
Processor: Intel i5
Graphics card: AMD Radeon HD 6630M + Intel Integrated graphics

I upgraded to 12.11 beta AMD drivers, but to no avail.

Additionally, Steam client occasionally crashes a few seconds after startup, when ran from terminal/console it gives the following errors:
System startup time: 14.83 seconds ExecSteamURL: "steam://open/driverhelperready" /home/wesley/.local/share/Steam/ line 287: 8046 Segmentation fault (core dumped) $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
< >
Showing 1-5 of 5 comments
Beelzebud Dec 20, 2012 @ 7:17pm 
I'm using an AMD HD5770 with the 12.11 beta 11 drivers, and I'm also getting this error. I even tried rebuilding my drivers, but it didn't work. I played it last weekend, and it was working fine.

I also have Space Pirates and Zombies, and it plays perfectly.

**Edit: I've tried KDE, Window Maker, and fluxbox. I do not have Unity installed to test it on that, as I use Slackware.
Last edited by Beelzebud; Dec 20, 2012 @ 7:58pm
eat like snake Dec 20, 2012 @ 7:45pm 
Same here. TF2 was working for me earlier, and I also have SPAZ and Osmos running fine.
hkparker Dec 21, 2012 @ 12:35am 
Same here. I have a 6970 and today got this message while trying to launch TF2. Worked fine last week, on 12.11 beta drivers as well.
eat like snake Dec 23, 2012 @ 2:20pm 
I tried the reinstalling my drivers, the error still remains.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Dec 20, 2012 @ 5:37pm
Posts: 5