Steam for Linux

Steam for Linux

Avalanche 21. März 2013 um 18:46 Uhr
libGL error: failed to load driver: swrast
OK just to get all of the usual fixes out of the way.

YES i have mesa-utils and libgl1-mesa-glx:i386 installed
YES I have export LD_LIBRARY_PATH=/usr/lib32:$LD_LIBRARY_PATH in a shell file that i use to launch steam

YES I can get glxgears to run

YES I have made symbolic links to ~/.steam/bin


this is the errors that I get when I start steam

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast

and when i start CS:S

Game update: AppID 240 "Counter-Strike: Source", ProcID 12185, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
Xlib: extension "RANDR" missing on display ":0".
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.


< >
Beiträge 115 von 22
Avalanche 21. März 2013 um 18:50 Uhr 
And glxinfo information

glxinfo | grep "version"
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 3.3.0 NVIDIA 313.18
OpenGL shading language version string: 3.30 NVIDIA via Cg compiler
towo01 22. März 2013 um 0:30 Uhr 
You have not installed the 32bit glx part of the nvidia-driver.
If you have used the installer from the nvidia-website, that must fail.
Avalanche 23. März 2013 um 12:52 Uhr 
I have just installed the 310 Driver from Nvidia here is the output for CS;S

Game update: AppID 240 "Counter-Strike: Source", ProcID 6531, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
(steam:6385): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.
...
Xlib: extension "RANDR" missing on display ":0.0".
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 0.0.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
instabilis 23. März 2013 um 13:07 Uhr 
Which distribution are you using? Ubuntu?

Where are you getting the driver from? Your distribution's repository?
Avalanche 23. März 2013 um 18:07 Uhr 
I am using Ubuntu 12.04 I was using the xorg-edgers repo. But just installed 310 from the nvidia website as per towo01 instructions
towo01 24. März 2013 um 8:27 Uhr 
Where you read, i have instructed you to install the driver from the website?
Avalanche 24. März 2013 um 14:20 Uhr 
then what did you mean by "If you have used the installer from the nvidia-website, that must fail." I installed it from nvidia site and it did not fail
Zuletzt bearbeitet von Avalanche; 24. März 2013 um 17:24 Uhr
arc| Gps 23. Apr. 2013 um 17:25 Uhr 
I am on opeSUSE 12.3 64 bit HD 5750 Catalyst 13.3 beta 3
I might have the same problem.

But as soon as steam starts it complains about direct rendering.

Have mesa and mesa 32bit installed.

output of glxinfo

name of display: :0
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_create_context, GLX_ARB_create_context_profile,
GLX_ARB_create_context_robustness, GLX_ARB_get_proc_address,
GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_visual_info,
GLX_EXT_visual_rating, GLX_EXT_framebuffer_sRGB,
GLX_EXT_create_context_es2_profile, GLX_MESA_copy_sub_buffer,
GLX_MESA_multithread_makecurrent, GLX_MESA_swap_control,
GLX_OML_swap_method, GLX_OML_sync_control, GLX_SGI_make_current_read,
GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap, GLX_INTEL_swap_event
GLX version: 1.4
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_MESA_multithread_makecurrent, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group,
GLX_EXT_texture_from_pixmap
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series
OpenGL version string: 1.4 (2.1 (4.2.12173 Compatibility Profile Context 12.10.17))
OpenGL extensions:
and allot more
Zuletzt bearbeitet von arc| Gps; 23. Apr. 2013 um 17:29 Uhr
towo01 23. Apr. 2013 um 23:47 Uhr 
> Have mesa and mesa 32bit installed.

Why? You need the nvidia-gl-libs in 32bit versions.
arc| Gps 24. Apr. 2013 um 8:11 Uhr 
Ursprünglich geschrieben von towo01:
> Have mesa and mesa 32bit installed.

Why? You need the nvidia-gl-libs in 32bit versions.

When using an amd card ?
towo01 24. Apr. 2013 um 8:34 Uhr 
Oh, then sorry i have overread this. The thread-starter was a guy with nvidia card.
For ATI it does even not make any sense if fglrx is used in the system, so even here must be the 32bit fglrx libs installed.
arc| Gps 28. Apr. 2013 um 14:22 Uhr 
For now my problem is solved by a re install of opensuse, leaving home partion in tact.
Then installed latest catalyst from the repo's 13.1

Before beta 6 was working well besides know bugs,

I am now going to install 13.4 which was released this week.
The Wounded 28. Apr. 2013 um 14:53 Uhr 
Well swrast is the software fallback renderer which will never produce anything that would be playable. but it sure looks like it is a driver issue here, looking at your last post where it states opengl 0.0.0 is usually something that happens when drivers get mixed up, you could try to uninstall the drivers and reinstall the most recent one. Also check that you system is not loading the DRI drivers from the nouveau package at boot time.
whoozle 12. Feb. 2015 um 12:19 Uhr 
I have the same problem with steam, and I have solved it. It does not work system wide(putting it into /etc/env.d/00opengl) , but it's sufficient to run steam via command line/alias or shortcut

You need to find the proper directory with nvidia libGL*.so files. I have those in /usr/lib32/opengl/nvidia/lib and /usr/lib64/opengl/nvidia/lib

Then modify your LD_LIBRARY_PATH as follows(note export):
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib32/opengl/nvidia/lib:/usr/lib64/opengl/nvidia/lib"

or run steam just like that:
LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/usr/lib32/opengl/nvidia/lib:/usr/lib64/opengl/nvidia/lib" steam
Zuletzt bearbeitet von whoozle; 12. Feb. 2015 um 12:22 Uhr
babel 14. Okt. 2015 um 17:18 Uhr 
I had the same problem and resolved it using this command found in the Arch Linux Wiki:

find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" \) -print -delete

I had to run it twice: the first one in the first run and the second one just after steam unpacked the package (which makes me think I'll have to run it after every update).

Hope this helps.
Zuletzt bearbeitet von babel; 14. Okt. 2015 um 17:18 Uhr
< >
Beiträge 115 von 22
Pro Seite: 15 30 50