Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Aiheen tiedot
Nevon 15.11.2012 kello 14.04
Issue Report: Black screen on TF2 startup
After installing Team Fortress 2 beta in Ubuntu 12.04 and running it, the game seems to start up and the Valve sound is played. However, no graphics are displayed at all, and no sound is played after the Valve intro sound. Only a black screen is ever shown. The same thing happens if I install TF2 (non-beta version) and run that.

System information[]

Other than what's in the system info, I'm also running Gnome Shell 3.6.

EDIT: I have now tried it in Unity as well, and got the exact same result.
Viimeisin muokkaaja on Nevon; 15.11.2012 kello 14.29
< >
Näytetään 1-15 / 18 kommentista
Keldrim 15.11.2012 kello 16.08 
Duplicate bug report, for the original report go here:
Issue Report: Black screen on TF2 startup

This one also has a few fixes that work.
Viimeisin muokkaaja on Keldrim; 15.11.2012 kello 16.09
Nevon 15.11.2012 kello 16.16 
The LANG=C workaround does not work for me. I get the exact same result with the workaround as without it.
AJenbo 15.11.2012 kello 17.28 
Exiting steam and running:
export LANG=C; steam

Made everything work for me
Darnaku 15.11.2012 kello 18.32 
export LANG=C; steam works for me.
Viimeisin muokkaaja on Darnaku; 18.11.2012 kello 10.28
Nevon 16.11.2012 kello 3.04 
LC_NUMERIC=C does work, however. Strange. I would have thought setting LANG would implicitly also change LC_NUMERIC.
Sith 16.11.2012 kello 4.46 
I have the same problem using Kubuntu 12.04. I tried AMD 12.10, 12.11beta, open radeon driver but it seems there's nothing to do. I will try with Kubuntu 12.10.
Same problem with Kubuntu 12.10
ayr-ton 16.11.2012 kello 9.09 
Same here. With Ubuntu 12.10 64bits with Intel HD Graphics
AJenbo 16.11.2012 kello 16.16 
Did you make sure to fully exit and shut down steam first?
Nevon 16.11.2012 kello 17.27 
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
Nevon lähetti viestin:
anders.jenbo: Yes, but as I said, LC_NUMERIC=C works, whereas LANG=C does not.
I tried this and no go, it seems to be related to Valve's SDL libs not detecting OpenGL libs properly
Kereltis 21.11.2012 kello 10.51 
Neither "LC_NUMERIC=C" or "export LANG=C; steam" work for me with AMD Radeon HD 4670 Mobility graphics using open source driver.
Kereltis 21.11.2012 kello 11.57 
Problem solved for Ubuntu 12.04 "AMD Radeon HD 4670 Mobility graphics" just install the latest open source driver by doing the following in Terminal:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt-get update

Then check for updates and install them, restart your system and you should be good to go. Hope this helps the rest of you!
Fenteale 21.11.2012 kello 14.20 
Im having this problem too. Neither "LC_NUMERIC=C" or "export LANG=C" work for me. I have HD 5770 graphics and have the latest proprietary graphic drivers. I don't know if this has anything to do with this, but I have my home directory saved in a different partition (on a different hard drive). When trying to use the fixes described here, I noticed in the terminal it would say this after tf2 crashes:
/home/mangmasta/Steam/SteamApps/mangmasta/Team Fortress 2/ line 72: 18963 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Cyberworm 22.11.2012 kello 13.34 
I too have my home folder on a different hard drive, and I get the exact same error:

/home/cyberworm/Steam/SteamApps/cyberworm86/Team Fortress 2/ line 72: 10410 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

Setting "LC_NUMERIC=C" or "export LANG=C" didn't work.
< >
Näytetään 1-15 / 18 kommentista
Sivua kohden: 15 30 50

Steam for Linux > Limited Beta > Aiheen tiedot
Lähetetty: 15.11.2012 kello 14.04
Viestejä: 18