Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Λεπτομέρειες θέματος
Issue Report: Backup and Restore 2 games at once
Steps to reproduce:
1. install Serious sam 3 and Team fortress 2

2. go to steam , backup and restore games and select both games to backup at once. ( i made the backup the total size so it is only one disk , like i always did in windows because i throw it over on my server.

3. delete local content for both games

4. go to steam , restore and you can not see the page that lets you select both games to restore and it assumes you are only restoring tf2

5. if you go ahead with the restore it fails and asks you to insert disk 2 , but there is no disk 2 because i made the file size big enough to all fit in 1 disk.

_ system info

Processor Information:
Vendor: AuthenticAMD
Speed: 3300 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-32-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 660/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x11c0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 18.78" x 10.55" (21.54" diag)
47.7cm x 26.8cm (54.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

RAM: 7963 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 61608 Mb
Largest Free Hard Disk Block: 47332 Mb

Installed software:

Τελευταία επεξεργασία από RegSizedRudy; 12 Νοε 2012 στις 21:44
< >
Εμφάνιση 1-6 από 6 σχόλια
thanks for the info!
Something similar happened to me. I wanted to reinstall my distro (Mint 13), but not to have to download TF2 again. I backed up 5 games (TF2, World of Goo, Darwinia, SPAZ and Cogs) at the same time, and without splitting it into several chunks.

After reinstallation of the distro, when trying to restore the games, I was not asked to select the games to restore. Instead Steam proceeded to restore only TF2 (successfully in my case).
Also, if I tried to re-run the restore process, Steam launch a cache check

I retested the backup/restore system with only 2 games (World of Goo and Cogs), and this time it worked flawlessly. Didn't retest with TF2 though, which is a point in common with Roger.
We had some bugs with backups that grew larger than 4GB, but the latest Steam client has some fixes. Are you still seeing problems?
@drewb , I ran the backup again for TF2 and SS3 in 1 large backup file.

The backup worked , but I was not able to check boxes for which games out of the backup i wanted to restore , it just ran and restored ss3 only , not tf2 which is in the backup as well.
@drewb, I ran again a single-chunk backup of the same 5 games, then tried to restore them;
only four games appeared in the list of games to restore, where TF2 was missing.
Also, the four games were restored successfully.
Ubuntu 12.04 x64. Can't restore no one game, just "Calculating cache" and then succes finish screen. ext4
< >
Εμφάνιση 1-6 από 6 σχόλια
Ανά σελίδα: 15 30 50

Steam for Linux > Limited Beta > Λεπτομέρειες θέματος