Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Aiheen tiedot
Issue Report: segfault when launching TF2
I have 2 systems I am testing and one of them crashes with a segfault immediately after I launch TF2. It basically flashes on the screen as if it's going to display and then crashes before it can show the intro (guy with the valve on his head). My other system has 2 Ubuntu partitions and both work fine but has an Nvidia graphics card. This system has an ATI card and I suspect it (or the drivers for it) may be the problem. I'm having a hard time figuring out exactly which ATI driver version I have and whether it's up-to-date. Their version infomation in catalyst is rather cryptic. amdcccle states that my "Driver Packaging Version" is 9.00.11-120920a-147436C-ATI but I'm not sure if that lines up the 12.6 or 12.11 driver that the "Getting Started" post recommends or not. dpkg says the following:

$ dpkg -l | grep fglrx ii fglrx 2:9.000-0ubuntu3 amd64 Video driver for the AMD graphics accelerators ii fglrx-amdcccle 2:9.000-0ubuntu3 amd64 Catalyst Control Center for the AMD graphics accelerators

I launched steam from the command line and redirected stderr. It states that it crashes on line 72 of but this makes no sense as line 72 is simply the end of of a bash while loop (the closing, "done" statement). The output indicates that it core dumped, but I have ulimit set to unlimited for core files and I cannot locate the file. If someone can tell me where the core file is located I would be happy to submit it, or at the very least submit a stack trace (bt) from gdb. Just FYI, I saw another post about a crash apparently related to joystick settings but I tried setting the -nojoy property when launching TF2 and unfortunately still have no joy (excuse the pun).

Here are the last few lines it printed to STDERR/STDOUT as it crashed. I then subsequently exited steam:

(hl2_linux:14758): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine", Gtk-Message: Failed to load module "canberra-gtk-module" [1212/] Failed to load /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/cef_gtk.pak Some features may not be available. [1212/] PAC support disabled because there is no system implementation /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/ line 72: 14758 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@" Installing breakpad exception handler for appid(steam)/version(1355250651_client) Game removed: AppID 440 "Team Fortress 2", ProcID 14758 CCrossProcessPipe::BWrite wrote too few bytes: 32 (Broken pipe). Continuing. saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully unlinked 6 orphaned pipes CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals. CAsyncIOManager: 360012 single object sleeps, 542 multi object sleeps CAsyncIOManager: 89 single object alertable sleeps, 2 multi object alertable sleeps GLError: 1282 Shutting down. . .

Here are my system specs:

Processor Information: Vendor: GenuineIntel Speed: 1734 Mhz 8 logical processors 4 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: Ubuntu 12.10 (64 bit) Kernel Name: Linux Kernel Version: 3.5.0-20-generic X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: ATI Technologies Inc. ATI Mobility Radeon HD 5800 Series Driver Version: 4.2.11903 Compatibility Profile Context FireGL Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x1002 DeviceID: 0x68a0 Number of Monitors: 2 Number of Logical Video Cards: 1 Primary Display Resolution: 1920 x 1080 Desktop Resolution: 3840 x 1080 Primary Display Size: 20.91" x 11.77" (23.98" diag) 53.1cm x 29.9cm (60.9cm diag) Primary VRAM Not Detected Sound card: Audio device: IDT 92HD81B1C5 Memory: RAM: 15974 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 171914 Mb Largest Free Hard Disk Block: 24954 Mb Installed software: Recent Failure Reports:
Viimeisin muokkaaja on Rhymenoceros; 12.12.2012 kello 16.02
< >
Näytetään 1-9 / 9 kommentista
Ok I figured out the GAME_DEBUGGER variable and fired it up with gdb. Here is the backtrace. It looks like it might be a problem with my drivers after all?

Program received signal SIGSEGV, Segmentation fault. 0xf45eddb0 in ?? () from /usr/lib32/fglrx/dri/ (gdb) backtrace #0 0xf45eddb0 in ?? () from /usr/lib32/fglrx/dri/ #1 0xf73980eb in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #2 0xf73ba870 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #3 0xf73ae306 in IDirect3DDevice9::Create(IDirect3DDevice9Params*) () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #4 0xf73ae6e5 in IDirect3D9::CreateDevice(unsigned int, _D3DDEVTYPE, void*, unsigned int, _D3DPRESENT_PARAMETERS_*, IDirect3DDevice9**) () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #5 0xebecf18e in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #6 0xebecf3e8 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #7 0xebecf537 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #8 0xebeb79a8 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #9 0xf1671f63 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #10 0xf20bb12b in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #11 0xf20bb704 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #12 0xf20b5824 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #13 0xf20b68c0 in ?? () from /home/bmayes/.local/share/Steam/SteamApps/gamblor01/Team Fortress 2/bin/ #14 0xf79afda0 in ?? () from bin/ #15 0xf79afda0 in ?? () from bin/ #16 0xf79983bd in LauncherMain () from bin/ #17 0x08048474 in main ()
forrestv 13.12.2012 kello 8.53 
I have the exact same problem and backtrace. We're both running 12.10, maybe that's it?
I don't believe it's an issue with 12.10. My system at home is dual-booting Ubuntu 12.10 64-bit and Ubuntu 12.04 32-bit and BOTH of those partitions work fine. Again though, that system has an Nvidia card in it. If you look at the stack trace above it shows that the last step is a call to the shared library and thus it looks like it's definitely specific to ATI cards. Unfortunately this failing system is my laptop at work so:

a) I cannot simply swap out the graphics card since it is likely embedded into the laptop's motherboard; and
b) I doubt that my company will buy me a new laptop with an Nvidia card in it just so that I can play TF2.

I'm going to try yet again to install the 12.11 beta drivers from but last time I tried (a few days ago) I couldn't get them to work properly with my dual monitors. The only thing that worked was to clone the display which isn't terrible useful. If you want to try them here is the link:

You can then use the script at the following URL to remove the watermark:

I really wish I just had an Nvidia card in here...
Rua 13.12.2012 kello 16.27 
My backtrace is the same too. I'm using the Catalyst 12.9 drivers that come with Mint 14/Ubuntu 12.10.
forrestv 13.12.2012 kello 21.34 
Using AMD's beta drivers fixes the segfault for me, but I can't get dual monitors to work ... one is just all white. :(
marca311 13.12.2012 kello 21.47 
I have a similar issue, however steam gives me:
"Could not find required OpenGL entry point 'glColorMaskIndexedEXT'| Either your video card is unsupported, or your OpenGL driver needs to be updated."

I am working on installing a newer version of fglrx, but I seem to have X server issues when I do so. I am running on a Radeon HD 6800 with the awesome window manager on Ubuntu 12.10.

@Forrest: I recommend using "Multi-display desktop with display(s)" setting under Multidisplay in amdcccle. Also make sure your main screen is selected. If that doesn't work, use a different screen config manager. (like arandr).
Viimeisin muokkaaja on marca311; 13.12.2012 kello 21.47
solazs 14.12.2012 kello 1.14 
It's definetly not AMD related, check out my problem, which is very similar:
solazs lähetti viestin:
It's definetly not AMD related, check out my problem, which is very similar:

Can you try launching with gdb active? Basically try this from terminal (assuming you have gdb installed and if not, I think you can get it with sudo apt-get install build-essential):


It should load up steam. At some point it may hit a breakpoint. Enter the letter "c" (no quotes) and hit enter to continue past that breakpoint. Then try to play TF2. When you see the segfault in your terminal, type "bt" (again, without quotes) and it will show you the backtrace.

I'd be curious to see what yours shows. As I said before, the final call before my system fails is in /usr/lib32/fglrx/dri/ Notice it's lib32 which means this is a 32-bit library. I thought that maybe I failed to install the ia32-libs package but it turns out that I have it and it still doesn't work.

I'm guessing here but given that path to /usr/lib/32 it seems like some sort of 32-bit call failing on my system (which is a 64-bit kernel). Even though you have an Intel card I would be curious to see if your backtrace reports something similar.
solazs 17.12.2012 kello 5.04 
Interesting. Both my system and steam got upgraded, now TF2 Beta starts, but in a window, which must be some misconfiguration, but it causes the mouse cursor to be misplaced, so i can't really do anything.
My terminal output is too long, it's on pastebin:

To use the NVIDIA card, i it run with primusrun.

It segfaults, but it seems steam can't preload, however it fails to do so without primusrun, so it can't be the problem.
I'm clueless, as to what to do.
< >
Näytetään 1-9 / 9 kommentista
Sivua kohden: 15 30 50

Steam for Linux > Limited Beta > Aiheen tiedot