Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Téma részletei
Issue Report: symlinking Steamfolder to a different partition doesn work
I do have a separate partition for my /home but its not large enough for installing games, so i tried to symlink the Steam folder "/home/<username>/.local/share/Steam/ (its the folder where Steam is actually installed) to another partition which is ext4.
Simply said: I have a Symlink thats called "/home/<username>/.local/share/Steam" that points to "/media/Linuxgames/Steam" where a bigger ext4 partition is mounted.

I found some other Threads reporting these problems but mostly it was like linking the wrong folder or linking to NTFS etc.

So when I do this correct symlinking, Steam isn't working. It says "Couldn't find Steam content, did you move it?"
Then I can select the folder or klick reinstall but neither is working. Selecting a folder reports that the folder is invalid, choosing reinstallation reports an Error: "Couldn't set up Steam data - please contact technical support"

Maybe theres a Problem with symlinks? Is it that Steam does or doesn't resolve symlinks?
Or did I simply move the wrong folder?
Console output stays quiet...
Legutóbb szerkesztette: X'grnsxs; 2012. dec. 10., 10:50
< >
110/10 megjegyzés mutatása
I wrote in the other thread that you mentioned. I currently have 2 partitions on my Linux hard disk: a small ext4 partition for /, and a large ext3 partition for /home. So, I'm unable to copy my Steam folder to my ext4 partition to see if that works, but I was able to move World of Goo to it and symlink without a problem. World of goo ran fine from the symlink.

My suggestions to debug your issue:

1. Try to only symlink the SteamApps folder. See if that works better.

2. Try to symlink from within the same partition. For example:
mv Steam SteamTest ln -s SteamTest Steam

Also, can you show us the content of /etc/fstab? Maybe you've found a bug that I can't reproduce on my system. What distribution and version are you using? Make sure you are using the latest version of Steam, fully updated before you try the symlink too. I think there was a version of Steam that didn't support it until recently.
Legutóbb szerkesztette: Pluffy; 2012. dec. 10., 9:35
Ah sorry i forgot to mention my sys-details:
I'm running Ubuntu 12.04 LTS x86_64 with Kernel 3.2.0-33-generic SMP

Steam Version is not available, its updating right now :D ;)
I will test your suggestions and post results, version information and relevant fstab lines when downloading is done.
thx so far
I think the issue has been resolved. Steam now runs fine wherever i point the symlink. I found out, my previous version was of Dec. 5 2012, just right now it updated to the version of Dec 7. 2012,
Steam API: v012
package versions 1354925460 / 13549254...

I just missed the update somehow,
Hmmm very strange:
It actually DOES NOT work...

I did some further testing:
I did
"mv Steam Steamtest"
"ln -s Steamtest Steam"
then I checked where the symlinks in ~/.steam/ point to. They point to "~/.local/share/Steamtest" and NOT to "~/.local/share/Steam" because chained symlinks seem to resolve. (do they really? seems unusual to me! )
Steam worked then because the symlinks in ~/.steam/ point to the real Steamfolder , and it remained on the small /home partition.

After that I did the following:
"cp ~/Steamtest /media/Steam"
where my ext4 partition fpr the games is mounted. Everything was succesfully copied, so i altered the symlink ~/.local/share/Steam to point to /media/Steam

Again I checked the symlinks in ~/.steam/ and ooops they still point to ~/.local/share/Steamtest/
I altered them to point to ~/.local/share/Steam again and hey this time the symlink chain does not resolve

Now i wonder why steam does not run. When i follow the symlinks, every path looks like it was when steam was normally installed in my home directory. Every symlink points to the correct location, replacing the Steam folder in my home directory with the one that is mounted in /media/Steam, but Steam does NOT work...

In short: symlinking works as long as the folder stays on the same partition, but does not, when the links point to a location on a different partition.
Legutóbb szerkesztette: X'grnsxs; 2012. dec. 10., 10:49
That's interesting. How about only moving the SteamApps folder and using a symlink for that?
I tried, Steam works, but it reports the wrong Disk size, so I still cannot download any Games. There are a lot of threads concerning the "Disk Space problem".
I will read there and see if I can find some more information...
That's odd. That worked just fine when I tried it myself, but my games were already downloaded, I didn't try to symlink the folder and then download. I'm running Kubuntu 12.04 with kernel 3.2.0-34-generic.

You're probably on to something with the disk size issue though. If it's looking at the space available on the partition where the symlink resides, and if you don't have enough space there, that could be the problem.
Hmm normally symlinks should be transparent to applications. I mean, an application normally doesn`t care if the folder it uses is a symlink or a real folder.
So symlinking the steam folder should not be visible to the application itself.

Did you also try to move the whole Steam folder? Did that work?

I think, moving the whole Steam infrastructure to a suitable partition, should definately resolve the diskspace issue, because I believe Steam only checks the diskspace that is free on the partition where the binary is running on. The diskspace issue has nothing to do with the symlinks in this case.
I cannot imagine why symlinks are intransparent to Steam...
Yes, I didn't have any problem moving the whole Steam folder to a different partition, so long as it wasn't the NTFS partition on my second drive.
Legutóbb szerkesztette: Pluffy; 2012. dec. 10., 13:48
Hmm okay... i think i will roll up the whole installation again... completely removing Steam, prepare the partition, clear everything up and then install Steam again into a already symlinked folder. Maybe theres a link thats been broken during all these experiments...
< >
110/10 megjegyzés mutatása
Laponként: 15 30 50

Steam for Linux > Limited Beta > Téma részletei
Közzétéve: 2012. dec. 10., 9:11
Hozzászólások: 10