Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Λεπτομέρειες θέματος
New TF2 black screen thread to discuss new fixes
This thread is to discuss new fixes for those who couldn't get tf2 to work using the fixes already suggested on the fora. Just to recap all the solutions I've seen so far;

1. Add -nojoy and -novid to the launch options. Also try -windowed -noborder and manually adding resolution (
2. Follow ALL of Frank's "getting started" instructions (
3. Follow some more instructions from Franck (
4. run "export force_s3tc_enable=true" then "steam" (without the quotes)
NOTE: This command advertises hardware support for s3tc compression to tf2. If you do not have hardware s3tc support, this will do nothing. For NVidia users, there are apparently options in the NVidia control panel that deal with s3tc compression
5. Although it has apparently been fixed, for the sake of being complete, also run "export LANG=C" and "export NUMERIC=POSIX" before running "steam" (without the quotes)
6. Try installing driconf (sudo apt-get install driconf, or just look for it in the software center) and play with the options (but be careful if you don't know what you're doing).
7. Also try playing with the options in ccsm (sudo apt-get install compizconfig-settings-manager)

For me, I think the problem is s3tc compression. Sound works fine, game starts fine, (as long as I use force_s3tc_enable). I have followed all the online instructions I could find to add s3tc support, and, as far as I can tell, it didn't work. Lastly, if anyone understands what this webpage says to do, please let everyone know, since I think this is the key to fixing the s3tc problem:

That's it for me, hopefully now we can roll up our sleeves and get this fixed.
Τελευταία επεξεργασία από Esophagus Now; 10 Δεκ 2012 στις 5:45
< >
Εμφάνιση 1-7 από 7 σχόλια
I think those fixes are useless. Nothing works for Intel GPUs (GMA, HD Graphics and Ironlake..). The problem is in Source Engine, exactly in OpenGL version I think. It requires unnecessarily higher version of OpenGL than is real required...because of translating layer from DirectX to OpenGL. (My GMA GPU support DirectX 10 and OpenGL 2.1 and I can't run source games, what...?)
Τελευταία επεξεργασία από play3man; 10 Δεκ 2012 στις 7:37
Do you know how to upgrade the opengl version? Is it just installing libraries or is it a driver thing? Maybe there is a way to make source think the opengl version is higher than it really is?
Τελευταία επεξεργασία από Esophagus Now; 10 Δεκ 2012 στις 7:18
It is HW limitation. Only Valve can fix it with 100% native port of Source Engine or reduce required of OpenGL version in DirectX to OpenGL translate layer... (Yes intel can fix that too, but it less likely than Valve..)
Those "fixes" does nothing for me. Not sure this thread is for the correct issue in that I only get a black screen that then returns to desktop, whereas the original poster states that their game runs fine...

Anyway. Starting steam from console reveals several warnings / errors:

1. Gtk-Message: Failed to load module "overlay-scrollbar" - however, I do have overlay-scrollbar installed and upgraded to latest version.
2. [1210/] Failed to load /home/soren/.local/share/Steam/SteamApps/sorenmogensen/Team Fortress 2 Beta/cef_gtk.pak - check the file system reveals that this file does not exist; validating steam files for TF2 claims all files correct but does not create/restore this file.
3. [1210/] PAC support disabled because there is no system implementation
4. /home/soren/.local/share/Steam/SteamApps/sorenmogensen/Team Fortress 2 Beta/ line 72: 5051 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 520 "Team Fortress 2 Beta", ProcID 5051

Not sure the GTK warning is relevant, but obviously a missing file is an issue, as is the segmentation fault in

System Info:
Processor Information:
Vendor: GenuineIntel
Speed: 3401 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-20-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 7800 Series

Driver Version: 4.2.11903 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x6819
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.08" x 11.42" (23.07" diag)
51.0cm x 29.0cm (58.6cm diag)
Primary VRAM Not Detected

Sound card:
Audio device:

RAM: 16005 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 104103 Mb
Largest Free Hard Disk Block: 75918 Mb

Installed software:

Recent Failure Reports:
Τελευταία επεξεργασία από Tig; 10 Δεκ 2012 στις 7:25
None of those fixes worked for me either, that's why I started the thread :P
@ play3man So we just have to wait for Valve to release an update? There's nothing that we can do? Is there some kind of bug report form to fill out?
Αναρτήθηκε αρχικά από Esophagus Now:
None of those fixes worked for me either, that's why I started the thread :P
@ play3man So we just have to wait for Valve to release an update? There's nothing that we can do? Is there some kind of bug report form to fill out?

You can try this -

Run in terminal "export MESA_GLSL_VERSION_OVERRIDE=130" and then run steam "steam". You will be propably see Valve logo and menu, but it will be with broken shaders.

But, I really don't know why that big silence from Valve side about this problem! :(
Τελευταία επεξεργασία από play3man; 10 Δεκ 2012 στις 7:36
I see all this problems with ATI GPUs and cry... it is OpenGL the real problem or is AMD who plays with this users... I purchased SS3 with this weekend discount and have to play it under windows with Ati HD4330 like it was SSI xDDD

Lucky that Trine 2 works well under Linux+ATI
< >
Εμφάνιση 1-7 από 7 σχόλια
Ανά σελίδα: 15 30 50

Steam for Linux > Limited Beta > Λεπτομέρειες θέματος
Ημ/νία ανάρτησης: 10 Δεκ 2012 στις 5:34
Αναρτήσεις: 7