Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Details van topic
Installing on non-Ubuntu
This is pretty simple, but some people are new.
Start by getting the .deb:
Then, if you're on a .deb based distro:
dpkg -i steam.deb
as root, there you go.

For non-.deb'ers (Fedora 17 here):
sudo yum install dpkg
or whatever package manager you use (YaST, pacman, etc)
Extract the .deb
dpkg -x steam.deb
"Install it"
sudo rsync -rv ./usr /
On first launch, I got a weird xterm-like window asking for the password for the user "user", I just closed it and everything worked. Use proprietary drivers by the way people. On fedora, rpmfusion has akmods for every card known to man (nVidia, AMD, AMD-Legacy).
This is pretty basic, but I just want to make sure that people DON'T USE ALIEN.
That horrendous piece of what can barely be called software will ruin your perms on / and basically force you to reinstall, hopefully your /home is on a separate partition/lvm.
< >
1-15 van 93 reacties weergegeven
Origineel geplaatst door Neptoess:
Then, if you're on a .deb based distro:
dpkg -i steam.deb
as root, there you go.

Weeeeell. Not quite. Unfortunately the package has some very Ubuntu-specific dependencies, so that your run-of-the-mill debian (even sid in my case) won't take it that easily.
However, have a look at This thread
Yeah this doesn't work on CentOS 6.3
dpkg -I steam.deb | grep Depends
Notice, capital 'i', not lowercase 'L'
This will be very annoying for .rpm people since the packages aren't of the same name, but using yum search and yum provides can help you find them.

My stuff just worked, I'm guessing, because I had Steam working and playing games fine under Wine. I have CentOS 6.3 x86_64 on my server, great OS. A lot of the problems with dependencies are going to likely be 32-bit things. My yum list installed | grep i686 is lonnnng, but I'll post it so you can get a slight idea.
SDL.i686 1.2.14-16.fc17 @fedora
alsa-lib.i686 1.0.26-1.fc17 @updates
atk.i686 2.4.0-1.fc17 @fedora
audit-libs.i686 2.2.1-1.fc17 @fedora
avahi-libs.i686 0.6.31-5.fc17 @updates
cairo.i686 1.10.2-7.fc17 @fedora
cdparanoia-libs.i686 10.2-11.fc17 @fedora
cups-libs.i686 1:1.5.4-11.fc17 @updates
cyrus-sasl-lib.i686 2.1.23-31.fc17 @updates
dbus-libs.i686 1:1.4.10-7.fc17 @updates
expat.i686 2.1.0-1.fc17 @fedora
flac.i686 1.2.1-9.fc17 @fedora
fontconfig.i686 2.8.0-8.fc17 @updates
freetype.i686 2.4.8-3.fc17 @fedora
gamin.i686 0.1.10-12.fc17 @fedora
gd.i686 2.0.35-17.fc17 @updates
gdk-pixbuf2.i686 2.26.1-1.fc17 @fedora
glib2.i686 2.32.4-2.fc17 @updates
glibc.i686 2.15-58.fc17 @updates
gnutls.i686 2.12.20-4.fc17 @updates
gsm.i686 1.0.13-6.fc17 @fedora
gstreamer.i686 0.10.36-1.fc17 @fedora
gstreamer-plugins-base.i686 0.10.36-2.fc17 @updates
gtk2.i686 2.24.13-1.fc17 @updates
jasper-libs.i686 1.900.1-19.fc17 @fedora
json-c.i686 0.9-4.fc17 @fedora
keyutils-libs.i686 1.5.5-2.fc17 @fedora
krb5-libs.i686 1.10.2-6.fc17 @updates
lcms-libs.i686 1.19-5.fc17 @fedora
libICE.i686 1.0.8-1.fc17 @fedora
libSM.i686 1.2.1-1.fc17 @fedora
libX11.i686 1.5.0-2.fc17 @updates
libXScrnSaver.i686 1.2.2-1.fc17 @fedora
libXau.i686 1.0.6-3.fc17 @fedora
libXcomposite.i686 0.4.3-3.fc17 @fedora
libXcursor.i686 1.1.13-1.fc17 @fedora
libXdamage.i686 1.1.3-3.fc17 @fedora
libXext.i686 1.3.1-1.fc17 @fedora
libXfixes.i686 5.0-2.fc17 @fedora
libXft.i686 2.3.0-2.fc17 @fedora
libXi.i686 1.6.1-1.fc17 @fedora
libXinerama.i686 1.1.2-1.fc17 @fedora
libXpm.i686 3.5.10-1.fc17 @fedora
libXrandr.i686 1.3.1-3.fc17 @fedora
libXrender.i686 0.9.7-1.fc17 @fedora
libXt.i686 1.1.2-2.fc17 @fedora
libXtst.i686 1.2.0-3.fc17 @fedora
libXv.i686 1.0.7-1.fc17 @fedora
libXxf86vm.i686 1.1.2-1.fc17 @fedora
libasyncns.i686 0.8-3.fc17 @fedora
libcom_err.i686 1.42.3-3.fc17 @updates
libcurl.i686 7.24.0-5.fc17 @updates
libdb.i686 5.2.36-5.fc17 @fedora
libdrm.i686 2.4.39-1.fc17 @updates
libexif.i686 0.6.20-2.fc17 @fedora
libffi.i686 3.0.10-2.fc17 @fedora
libgcc.i686 4.7.2-2.fc17 @updates
libgcrypt.i686 1.5.0-3.fc17 @fedora
libgpg-error.i686 1.10-2.fc17 @fedora
libgphoto2.i686 2.4.14-1.fc17 @updates
libidn.i686 1.24-1.fc17 @fedora
libjpeg-turbo.i686 1.2.1-1.fc17 @updates
libmng.i686 1.0.10-6.fc17 @fedora
libogg.i686 2:1.3.0-1.fc17 @updates
libpciaccess.i686 0.13.1-1.fc17 @updates
libpng.i686 2:1.5.10-1.fc17 @fedora
libpng-compat.i686 2:1.5.10-1.fc17 @fedora
libselinux.i686 2.1.10-3.fc17 @fedora
libsndfile.i686 1.0.25-2.fc17 @fedora
libssh2.i686 1.4.1-2.fc17 @fedora
libstdc++.i686 4.7.2-2.fc17 @updates
libtasn1.i686 2.12-1.fc17 @fedora
libthai.i686 0.1.14-5.fc17 @fedora
libtheora.i686 1:1.1.1-3.fc17 @fedora
libtiff.i686 3.9.6-2.fc17 @updates
libtool-ltdl.i686 2.4.2-3.1.fc17 @updates
libusb.i686 1:0.1.3-10.fc17 @fedora
libusb1.i686 1.0.9-0.6.rc1.fc17 @fedora
libuuid.i686 2.21.2-3.fc17 @updates
libvisual.i686 0.4.0-11.fc17 @fedora
libvorbis.i686 1:1.3.3-1.fc17 @fedora
libxcb.i686 1.9-1.fc17 @updates
libxml2.i686 2.7.8-9.fc17 @updates
lockdev.i686 1.0.4-0.4.20111007git.fc17
mesa-libGL.i686 8.0.4-1.fc17 @updates
mesa-libGLU.i686 8.0.4-1.fc17 @updates
mesa-libglapi.i686 8.0.4-1.fc17 @updates
nas-libs.i686 1.9.3-2.fc17 @fedora
ncurses-libs.i686 5.9-4.20120204.fc17 @fedora
nspr.i686 4.9.2-1.fc17 @updates
nss.i686 3.13.6-1.fc17 @updates
nss-mdns.i686 0.10-10.fc17 @fedora
nss-softokn.i686 3.13.6-2.fc17 @updates
nss-softokn-freebl.i686 3.13.6-2.fc17 @updates
nss-util.i686 3.13.6-2.fc17 @updates
openal-soft.i686 1.14-2.fc17 @updates
openldap.i686 2.4.33-3.fc17 @updates
openssl.i686 1:1.0.0j-2.fc17 @updates
orc.i686 0.4.16-5.fc17 @fedora
p11-kit.i686 0.12-1.fc17 @fedora
pango.i686 1.30.0-1.fc17 @fedora
pixman.i686 0.24.4-2.fc17 @fedora
popt.i686 1.13-10.fc17 @fedora
pulseaudio-libs.i686 1.1-9.fc17 @fedora
qt.i686 1:4.8.3-7.fc17 @updates
qt-x11.i686 1:4.8.3-7.fc17 @updates
readline.i686 6.2-4.fc17 @fedora
sqlite.i686 3.7.11-3.fc17 @updates
tcp_wrappers-libs.i686 7.6-69.fc17 @fedora
wine-capi.i686 1.5.17-1.fc17 @updates
wine-cms.i686 1.5.17-1.fc17 @updates
wine-core.i686 1.5.17-1.fc17 @updates
wine-ldap.i686 1.5.17-1.fc17 @updates
wine-openal.i686 1.5.17-1.fc17 @updates
wine-pulseaudio.i686 1.5.17-1.fc17 @updates
wine-twain.i686 1.5.17-1.fc17 @updates
zlib.i686 1.2.5-7.fc17 @updates
Laatst bewerkt door neptoess; 6 dec 2012 om 14:38
Now, you will NOT need everything I posted, I'm just showing how long the list is. My advice to people with dependency issues is:
->Install proprietary video drivers, get the 64-bit AND 32-bit libraries (notice my xorg-x11-drv-catalyst-legacy-libs.i686)
->Install PlayOnLinux
(Make sure it says 64-bit AND 32-bit direct rendering is good)
->Install steam through PlayOnLinux
->Launch PlayOnLinux steam and log in
->Now try extracting the deb, copying the files, and launching steam from the command line with:
and check for any errors
@Gordan, running alien as root is what killed my permissions. I've only used it on Fedora, and it's wrecked my ♥♥♥♥ every time. There's a reason alien isn't in rpmfusion or the official Fedora repos. Since alien ruined my ♥♥♥♥ twice, I've just done the manual method of installing .deb's. Dependency resolution isn't that annoying really. Usually it's only necessary to install a few packages if you've got a system with a decent amount of software on it already
No way to install in openSUSE.

After unpack and copy content of steam.deb package in openSUSE have:

/home/maks/.local/share/Steam/ubuntu12_32/steam: /lib/ version `GLIBC_2.12' not found (required by /home/maks/.local/share/Steam/ubuntu12_32/steam) /home/maks/.local/share/Steam/ubuntu12_32/steam: /lib/ version `GLIBC_2.15' not found (required by /home/maks/.local/share/Steam/ubuntu12_32/steam) /home/maks/.local/share/Steam/ubuntu12_32/steam: /lib/ version `GLIBC_2.12' not found (required by /home/maks/.local/share/Steam/ubuntu12_32/steam) /home/maks/.local/share/Steam/ubuntu12_32/steam: /lib/ version `GLIBC_2.15' not found (required by /home/maks/.local/share/Steam/ubuntu12_32/steam)

And installer try to run apt-get. Apt-get on SUSE?
Hi all. Just got into the beta today.
Here is my experience installing on Arch Linux x86_64...
1. Make sure you have the Multilib repo enabled and up-to-date.
2. Download the Steam tarball from the AUR.
3. Build the Steam package. It will need quite a few lib32 packages from the Multilib repo, as well as some lib32 packages from the AUR. Using Packer is recommended.
4. Once everything is built/installed, run the client with the command "steam". Watch the terminal output for errors.

In KDE4, there is an entry for the Steam client. Once everything is working right, you can use it instead. There doesn't seem to be any integration into the KDE4 system tray, so the client minimizes to your task manager instead.
installer tries apt-get if you don't have all the deps. if you have them all (which you clearly don't) it won't matter
also in fedora I could do like:
yum provides "*/"
yum provides "*/"
to find the packages I need to install to get those libs. Also, 32-bit or 64-bit openSuSe?
@Stranger, I'm gonna guess you'll be needing glibc.i686 from that error you posted
Laatst bewerkt door neptoess; 6 dec 2012 om 15:05
I'm on OpenSUSE and getting the '`GLIBC_2.15' not found' message. Apparently OpenSUSE 12.2 does give this version so I'm doing a distro update to get it.

Not seen any mention of apt-get though? I did have to edit the script at ~.local/share/Steam/ so that the detection routines used the uname command instead of the /etc/os-release file as that was giving error messages.

Will report back once the upgrade is done.
That detection thing doesn't matter. Again, it will only NEED apt-get/yum/YaST/pacman/etc if your dependecies aren't sufficient. My steam initially started with a window trying to apt-get something and I closed it. Afterwards, it launched and everything went fine. I'm thinking it doesn't know if you truly have the deps or not since it's trying to use dpkg to query the installed packages, and as rpm users, we have no debs at all installed
Laatst bewerkt door neptoess; 6 dec 2012 om 15:07
Opensuse users kan use
thanks to ryanbach
If you're using Archlinux, you can use the 'steam' package from AUR.
There's also a pretty extensive artcile there as well.
Nice. RPMFusion has yet to get a steam package for the Fedora/CentOS users of the audience.
< >
1-15 van 93 reacties weergegeven
Per pagina: 15 30 50

Steam for Linux > Limited Beta > Details van topic