Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Ämnesdetaljer
ison 6 dec, 2012 @ 8:44
[SOLVED] [TF2] Issue Report: Game crashes on map download
Running Gentoo 64-bit with OpenBox window manager.
At the loading screen if I already have the map on my machine (tested with maps like cp_dustbowl and pl_goldrush) then the loading goes well.
However, if I join a server with a custom map then at the loading screen when it says "Downloading map" it sits there for about 5-10 seconds with no progress, and then the game just crashes.
NOTE: I have downloaded custom maps without issue recently in the past, so I would guess either the latest update from TF2 (most likely) or the steam client itself somehow caused this.

I'm not sure if this is relevant, but because the output message of the crash mentions ALSA I should say that I don't have pulseaudio.

Here is the extra terminal output that only appears for the crash:
ALSA lib pcm.c:7339:(snd_pcm_recover) underrun occurred Uploading dump (in-process) [proxy ''] /tmp/dumps/crash_20121206103214_1.dmp success = yes response: CrashID=bp-339a5fa0-6da0-4680-8406-8d2ff2121206 /home/jason/.local/share/Steam/SteamApps/phoenix2005/Team Fortress 2/ line 72: 2777 Segmentation fault ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@" CCrossProcessPipe::BWrite wrote too few bytes: 32 (Broken pipe). Continuing. Game removed: AppID 440 "Team Fortress 2", ProcID 2777 saving roaming config store to 'sharedconfig.vdf' roaming config store 2 saved successfully

and here is my system information: (processor is an i7)
Processor Information: Vendor: GenuineIntel Speed: 2672 Mhz 8 logical processors 4 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: "Gentoo Base System release 2.1" (64 bit) Kernel Name: Linux Kernel Version: 3.5.7-gentoo X Server vendor: The X.Org Foundation X Server release: 11300000 Video Card: Driver: NVIDIA Corporation GeForce GTX 295/PCIe/SSE2 Driver Version: 3.3.0 NVIDIA 310.19 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 60 Hz VendorID: 0x10de DeviceID: 0x5e0 Number of Monitors: 1 Number of Video Cards Not Detected Primary Display Resolution: 1920 x 1080 Desktop Resolution: 1920 x 1080 Primary Display Size: 18.78" x 10.55" (21.54" diag) 47.7cm x 26.8cm (54.7cm diag) Primary Bus: PCI Express 16x Primary VRAM: 896 MB Supported MSAA Modes: 2x 4x 8x 16x Sound card: Audio device: Realtek ALC1200 Memory: RAM: 5961 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 460352 Mb Largest Free Hard Disk Block: 341911 Mb Installed software: Recent Failure Reports: Thu Dec 6 16:27:04 2012 GMT: file ''/tmp/dumps/crash_20121206102702_1.dmp'', upload yes: ''CrashID=bp-1aa55ea3-a385-4910-8e36-fd23d2121206'' Thu Dec 6 16:27:25 2012 GMT: file ''/tmp/dumps/crash_20121206102721_1.dmp'', upload yes: ''CrashID=bp-a70d6a02-b584-4ead-b6ea-270b82121206'' Thu Dec 6 16:28:10 2012 GMT: file ''/tmp/dumps/crash_20121206102808_1.dmp'', upload yes: ''CrashID=bp-013c0a4d-37ca-46a9-b22b-548172121206'' Thu Dec 6 16:29:17 2012 GMT: file ''/tmp/dumps/crash_20121206102912_1.dmp'', upload yes: ''CrashID=bp-886cfb2a-18bd-4039-a0c6-a40912121206'' Thu Dec 6 16:31:52 2012 GMT: file ''/tmp/dumps/crash_20121206103148_1.dmp'', upload yes: ''CrashID=bp-e24327ed-7801-4b7a-8065-f6bd12121206'' Thu Dec 6 16:32:18 2012 GMT: file ''/tmp/dumps/crash_20121206103214_1.dmp'', upload yes: ''CrashID=bp-339a5fa0-6da0-4680-8406-8d2ff2121206'' Thu Dec 6 16:40:58 2012 GMT: file ''/tmp/dumps/crash_20121206104055_1.dmp'', upload yes: ''CrashID=bp-1a0731eb-eef9-4227-b143-4de782121206''
Senast ändrad av ison; 28 dec, 2012 @ 8:36
< >
Visar 1-15 av 19 kommentarer
Lawd Reekris 6 dec, 2012 @ 11:13 
I think I'm having the same bug, only it crashed while downloading sounds.
pirata popò 6 dec, 2012 @ 12:12 
I also have encountered this bug. Any custom content make the game crash.
soupcan 6 dec, 2012 @ 12:17 
I have experienced this bug, however it seems to rarily happen. So far I've only experienced this once.
dDDDD 6 dec, 2012 @ 14:02 
Same bug, on ubuntu 12.04 64 bit.
Same here, Ubuntu 12.10 64bit (PulseAudio) and Arch 64bit (ALSA). Nvidia GPU
Senast ändrad av ZeXx86 [Linux]; 6 dec, 2012 @ 14:13
Cato 6 dec, 2012 @ 14:47 
Same here. Kubuntu 12.10 64bit.
NETabuse 17 dec, 2012 @ 10:44 
same here, ubuntu 12.10 64bit, for any additional resource downloads, today i can't get into any online game in tf2 :(
BJORN 17 dec, 2012 @ 11:27 
This has happened to me as well while attempting to download a custom map, I believe.
mikesart 17 dec, 2012 @ 16:17 
When it happens, can you post the CrashID you get for it? Thanks.
ison 17 dec, 2012 @ 22:31 
OP here. Just reporting back that this was actually fixed for me quite a while ago, and I just verified that it is still working again. I usually go back to threads, but I guess I forgot to mark this solved somehow.

So perhaps it is a different cause than what I was experiencing if some people have this bug now but I don't any more.

Are those of you who claim to currently have this problem certain that it is upon download of custom content? Are you able to join normal servers with none?
Senast ändrad av ison; 17 dec, 2012 @ 22:35
mruuh 18 dec, 2012 @ 0:19 
It only happens in TF2 Beta for me, my "production" TF2 can download all sorts of 3rd party stuff (maps, sounds, what have you). TF2 Beta, however, seems to crash on *any* download (I gave it three tries, different server each so far).
mruuh 18 dec, 2012 @ 8:55 
Tried it again today (in TF2 Beta), just to get you guys a crash ID: CrashID=bp-7099f4c7-75c3-4aad-965c-410442121218
mikesart 18 dec, 2012 @ 9:21 
TF2 Beta hasn't been updated in a while, so it doesn't have many of our Linux fixes in there. This crashid (7099f4c7-75c3-4aad-965c-410442121218) is one we've already fixed in regular TF2. I think they're going to sync TF2 Beta w/ TF2 at some point, but I'm not sure when that's happening. Thanks.
BartBM 27 dec, 2012 @ 14:12 
Kubuntu 12.10 64 bit, fglrx (Radeon 6970m) -> black screen for half a second, core dumped (line 72) error
mikesart 28 dec, 2012 @ 0:32 
Do you have a crashid?
< >
Visar 1-15 av 19 kommentarer
Per sida: 15 30 50

Steam for Linux > Limited Beta > Ämnesdetaljer