Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > Detalles del tema
Beamboom 4 DIC 2012 a las 12:09
Issue report: TF2 dependent on plugins/ [SOLVED]
When I tried to recreate this issue again today, to further investigate on the matter, I am unable to. TF2 runs perfectly regardless of the flash plugin being in the plugin directory or not.

I did however do one other thing before returning to this case: I've installed the libpci3:i386 package to get rid of the Serious Sam 3 error message (as described in this thread).

No idea if that was of any relevance, but either way: It works now. I'll update this thread again should the issue return, but my gutfeeling tells me it won't.



I almost can't believe it myself, but here goes:
I am running 64bit Ubuntu 12.04. Up until recently I've never gotten TF2 to work, it always crashed when I started a new game and got to the "chalkboard picture", then the game would just exit.

A few days ago, in order to get flash video playback to work in the Steam client I copied the 32 bit from Adobe into the ~/Steam/ubuntu12_32/plugins directory.

Then later I figured I'd file an issue report on my TF2 problem, since it seemed other Linux users seemed to be able to play it. So I fired up TF2 again, and what do you know... All of a sudden it worked.

The *only* thing I had done was to copy this flash file into the plugins directory. But just to get it confirmed, I have now twice moved the out of the plugins dir, started the game, experienced the crash, then moved back in again, and TF2 works again. Twice.

So, well... Hence this is my issue report. I have no idea *why* this happens, my logic tells me it has to be a coincidence, but my testing indicates otherwise.

Processor Information:
Vendor: GenuineIntel
Speed: 2997 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-34-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1200
Desktop Resolution: 1920 x 1200
Primary Display Size: 20,39" x 12,76" (24,02" diag)
51,8cm x 32,4cm (61,0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 767 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Nvidia GPU 12 HDMI/DP

RAM: 3954 Mb

UI Language: English
Microphone: Not set
Total Hard Disk Space Available: 228722 Mb
Largest Free Hard Disk Block: 157987 Mb

Installed software:

Recent Failure Reports:
Tue Dec 4 19:18:11 2012 GMT: file ''/tmp/dumps/assert_20121204201807_1.dmp'', upload yes: ''CrashID=bp-7c91cc75-39b3-4d43-a324-45d172121204
Tue Dec 4 19:19:59 2012 GMT: file ''/tmp/dumps/assert_20121204201955_2.dmp'', upload yes: ''CrashID=bp-dbfab6f0-e6d6-46a1-aed2-a23992121204
Tue Dec 4 19:32:14 2012 GMT: file ''/tmp/dumps/crash_20121204203208_1.dmp'', upload yes: ''CrashID=bp-8501e67f-4410-41ef-8556-bb3d42121204
Tue Dec 4 19:43:44 2012 GMT: file ''/tmp/dumps/crash_20121204204339_1.dmp'', upload yes: ''CrashID=bp-e8e2525b-67dc-422c-a56e-3d7872121204
Última edición por Beamboom; 5 DIC 2012 a las 11:48
< >
Mostrando 1-9 de 9 comentarios
Rain Shinobi 4 DIC 2012 a las 13:18 
That's odd, I dont even have Flash installed (just Gnash) and TF2 works fine.
Frank 4 DIC 2012 a las 15:52 
Beamboom, that does sound weird but we (the team) are in uncharted territory when it comes to 64-bit because our main efforts have been with Ubuntu 32-bit. We're learning more and more every day and every little bit of info helps. I will add your info to our bug database and if you find out anything more please add it to this thread.
Beamboom 5 DIC 2012 a las 1:47 
@Rain Ninja: But are you running Ubuntu 64bit? Cause that makes all the difference. I got 32bit Ubuntu running on my laptop and Steam is running out of the box there. On 64 bit you need to manually add a 32bit Flash driver in for flash to work in steam client.

@Frank: Yes it sounds really weird, I know. But if that part of the game (the chalkboard with the gameplay info) indeed is built using Flash then it would at least make *some* sense. Anyhow, I'll try to look more into it and see if I can get more info on this issue.

As for 64bit, I believe it is wise to also give 64bit a focus eventually, cause as far as I know most (educated) Linux users today install the 64bit version on their 64bit hardware. It simply is the better choise when it comes to other usage (but I'm sure there are some stats out there in these regards).
Just in case it helps: I’m on 64bit Ubuntu 12.04, don’t have Flash installed, and can get TF2 working perfectly. Can server’s MOTD website load Flash, could that have been it?
Beamboom 5 DIC 2012 a las 7:29 
That helps alot.

Hmm. I will have to try and see if there is a difference between starting a local/tutorial game, and going online. I mainly tried the tutorial modes. But the screen where the game crash is before the server is up and running, it's a step before you enter the game. You see a chalkboard with a scrollable window listing the objectives of the upcoming game. That's where it crashes.

But I'll try the different modes a bit more and see if this problem is related directly to that chalkboard or not.
Thanks, John.
mikesart 17 DIC 2012 a las 17:55 
TF2 shouldn't be relying on flash at all. I'm running 64-bit Ubuntu as my main dev box here and don't have anywhere on my machine. Can you try running with strace or pmap and see if that file is loaded? Thanks.
Beamboom 18 DIC 2012 a las 7:50 
Mikes, I got TF2 running now, I am not sure how/why it started working (unfortunately I did several things I thought would be unreated to this, but apparently wasn't) but I've not been able to recreate the issue.

However! I've discovered I have the exact same problem now with the TF2 BETA, and I shall be a bit more careful with how I progress now, to try to single out the problem here.
mikesart 18 DIC 2012 a las 9:23 
TF2 Beta hasn't been updated in a bit and doesn't have several of our Linux fixes in there. If you run into any issues with regular TF2 though, let me know. Thanks much.
Última edición por mikesart; 18 DIC 2012 a las 9:23
Beamboom 18 DIC 2012 a las 12:23 
Aha I see. Thanks Mikesart, then I'll ignore TF2 Beta for now and focus on the regular TF2.
< >
Mostrando 1-9 de 9 comentarios
Por página: 15 30 50

Steam for Linux > Limited Beta > Detalles del tema