Steam for Linux

Steam for Linux

Steam for Linux > Limited Beta > 제목 정보
destruct0r 2012년 11월 30일 오전 9시 23분
Issue Report: Restore Team Fortress 2 backup fails (from wine)
This might be a non issue as Wine is involved. I created a steam backup of TF2 on my machine running steam on Wine. It created folders as expected (Disk_1 and Disk_2) with appropriate file size (7GB). When restoring the backup with the native Linux Steam client, it does processing (of disk 1 I guess), and then asks me to insert Disk 2. Since the media isn't on physical disks, I can't exactly do that.

Only option is to cancel.
< >
1-77개 댓글 표시
Don Rego 2012년 11월 30일 오전 9시 26분 
Buddy, copy all the archives on Disk_2 folder to Disk_1. Works for me sometimes...
destruct0r 2012년 11월 30일 오후 1시 29분 
Thanks, I tried that, but got the same message. Will try using Windows Steam backups soon.

BTW, also couldn't get Cogs backup to work. It didn't give the same error, but didn't restore any data as well. Downloaded the whole game again.
destruct0r님이 마지막으로 수정; 2012년 11월 30일 오후 1시 30분
the_phrantom_menace 2012년 11월 30일 오후 2시 28분 
Could be related to this: - backups from the linux client limited to 2GiB in size

So maybe try re-doing the backup in Wine and specifying a smaller file size?
destruct0r 2012년 12월 1일 오전 12시 28분 
I don't think it would be that. The one file "Team Fortress 2_disk1_0.sid" is already 4.6G big. I suspect it is a combination of Wine's generation of the backup and Linux client's reading of the backup.
Thanks for the tip though.
RegSizedRudy 2012년 12월 1일 오전 10시 57분 
also related to this bug report i posted

see step 5 where I wrote that it asks for "disk2"
destruct0r 2012년 12월 2일 오전 6시 25분 
Thanks for pointing that out Roger Korby.
I have tried to make a backup of only one disk of TF2, and now it fails in a different way.

First time I did the restore, it was with DVD sized folders - failed, as described above.

Second time I tried it, it was with one folder. Restore started, and progressed , but I noticed that the download for the missing 12GB of game, has started, and is progressing nicely. Kinda defeats the point of restoring a backup. I cancelled the restore, paused the download, and restarted steam.

Steam reported that the TF2 download was paused. I retried the restore, but then steam crashed. Retrying again, it just stopped at 100%, not doing anything. (top did not list steam, and when it did, it was using less than 10% CPU).

Screenshot of 100% stuck, is here.

When I cancel the restore on 100%, and try and play the game, it resumes the download. Sometimes, it just gets stuck at "Preparing to launch Team Fortress 2"

Nowhere during the "Validating Steam files..." process, did I notice my free disk space decrease.

Like I mentioned at the beginning this is a restore from a backup made from Steam under Wine. I did the backup on a ext4 filesystem, and copied it over to a NTFS portable drive. From the portable I tried to get Linux Steam to read the backups.
destruct0r 2012년 12월 7일 오후 11시 16분 
Just for completeness sake, when I make a backup of games from the Linux steam client, and restore it to a Linux steam client, it works 100%
< >
1-77개 댓글 표시
페이지당 표시 개수: 15 30 50

Steam for Linux > Limited Beta > 제목 정보
게시된 날짜: 2012년 11월 30일 오전 9시 23분
게시글: 7