Steam for Linux

Steam for Linux

Mr. Lixo Nov 26, 2012 @ 7:13pm
TF2 worked perfectly, crashed after changing resolution, and never worked again.
Hi. I am not on the official beta, but I am playing around... I am having this problem with Team Fortress 2, and I was hoping anyone could suggest something for me to do.

I installed TF2, execute and it worked perfectly in the first try. I was sooo happy! I played it for a while. I even finished the first steps of the training. I think I also closed and opened again the game.

After I had a lot of fun, I decided to try poking at the configurations, to see if I could, for example, reduce the resolution to increase the frame rate. A terrible mistake...

When I tried to change the resolution, and also play in a separate window, TF2 crashed.

Now, that has been reported by a number of people... The thing is, now I can't make it work again! Ever since this crash I could not make TF2 start another time. I see the initial film, I see the large splash while it seems to be initializing the game, but after a while I eventually get this segmentation fault. I pasted the last messages from the log below.

My quesiton is: is there anything I should try? I tries using arguemnts such as -sw, -fullscreen, -w -h with my native screen size, etc, but nothing seems to make it work again. I ahve even re-installed it (updated...) But it never worked again.

Is there some config file I can manually delete, that might have been left after i removed the game?

Thank you... loaded for "Team Fortress"
Uploading dump (in-process) [proxy '']
success = yes
response: CrashID=bp-b335c697-4865-4680-b95b-62ebe2121126

/home/nwerneck/Steam/SteamApps/xor0110/Team Fortress 2/ line 72: 25534 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 25534
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Date Posted: Nov 26, 2012 @ 7:13pm
Posts: 0