Steam for Linux

Steam for Linux

Steam for Linux > Obecné diskuze > Detaily tématu
Steam on Ubuntu 12.10 AMD64 issues.
I had Steam running fine a couple days ago, running Ubuntu 12.10 64 bit with an AMD video card and using the beta proprietary drivers. It ran but had some buggy visuals. After today's update Steam won't start at all. From what I've gathered from the error in the terminal it is an issue with the 32 bit libraries but I've already installed all the dependencies Steam should require.

Terminal output:

Installing breakpad exception handler for appid(steam)/version(1352503901_client)
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 155 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 37
Current serial number in output stream: 37

Anyone else running 64 bit Ubuntu have an issue after the update today?
< >
Zobrazeno 13 z 3 komentářů
Hm. Try reinstalling the proprietary driver.
I seem to have fixed it, thought I'm not sure what exactly I did to get it working again. I'll detail the steps I took in case anyone else stumbles upon the problem.

I removed my AMD beta drivers and attempted to run Steam on the open drivers, got a libgl error. I proceeded to remove all the 32 bit libs (sudo apt-get remove libgl1-mesa-glx:i386), reinstalled them (sudo apt-get install libgl1-mesa-glx:i386), deleted the Steam directory in /home to prompt Steam to update/reinstall missing files, and Steam worked (better than before even?). I'm not sure why this happened, maybe some corrupted 32 bit libs from when I installed them first? Either way now my Steam isn't missing random text in places, looks nicer, and Big Picture runs (it crashed Steam before).

I've also reinstalled the proprietary beta drivers and Big Picture runs better than it does with the open ones and have no problems as of yet (:
I'm running the proprietary drivers from AMD's website and I'm still getting this error. I tried reinstalling it by running the uninstall sh in /usr/share/ati, then reinstalling the .run package but it's still doing the same thing.

Is the libgl1-mesa-glx package just about the opensource driver? I have reinstalled that to get rid of an ELFCLASS64 error but it doesn't fix the 155 (GLX) thing. Is there something else I should be reinstalling or doing? Or am I reinstalling the proprietary driver all wrong?
< >
Zobrazeno 13 z 3 komentářů
Na stránku: 15 30 50

Steam for Linux > Obecné diskuze > Detaily tématu
Datum odeslání: 12. lis. 2012 v 15.53
Počet příspěvků: 3