Steam for Linux

Steam for Linux

Steam for Linux > Discussões gerais > Detalhes do tópico
Orkestra 7/nov/2012 às 3:31
Steam won't start
I installed the steam.deb package without any issues but nothing happen when I try to launch steam. I also tried to launch it via the Terminal and got this error :

ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt". X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 45 (X_OpenFont) Serial number of failed request: 12 Current serial number in output stream: 13

There's nothing in my public folder.
My version of Ubuntu is in French, if that's of any help...

(Please excuse my english... :) )
Última edição por Orkestra; 7/nov/2012 às 3:32
< >
Exibindo comentários 115 de 25
FluX 7/nov/2012 às 3:39 
me too i fix it. Search in /home/USERNAME/Steam tmp folder and copy all files in /home/USERNAME/Steam

in terminal test

steam steam://open/store/ &

Orkestra 7/nov/2012 às 5:28 
I may have misunderstood your solution but I couldn't make it work.

In "/home/USERNAME/Steam", there's just a file ("") and two folders ("package" and "ubuntu12_32") with a single texte file ("beta") in the first one, and a steam executable in the second one. No hidden file.

In "home/USERNAME/", I found a ".steam" hidden folder but the two file shortcuts goes right into my actual "Steam" folder...

Did I miss something ?
Última edição por Orkestra; 7/nov/2012 às 5:28
paradigm 7/nov/2012 às 6:31 
I had a similar issue - the problem as I understand it is that steam cannot find the fonts it normally expects. Presumably these are installed and set up by default with Ubuntu - I'm doing some weird stuff with my not-exactly-Ubuntu distro such that I don't exactly get the defaults.

On Ubuntu, the relevant package seems to be "xfonts-100dpi". Install that with your package manager and it might just work from there. For me, X11 (the main back-end of the graphical part of your system) didn't seem to pick up that the newly installed fonts were there, so I had to tell it where to find them.

Running "dpkg -L xfonts-100dpi" shows me the files that were installed by that package were installed to "/usr/share/fonts/X11/100dpi/", and so I need to run the following: "xset +fp /usr/share/fonts/X11/100dpi" to add that directory to the font path. After that, X11 was able to show whatever font steam wants and steam was able to function properly.

I'm not sure how to properly add "/usr/share/fonts/X11/100dpi" to the font path in the long-term - I have that command run every time I start X11 (with .xinitrc).

Good luck!
Orkestra 7/nov/2012 às 8:01 
It works, I had to run "xset" too. Thank you !

I also tried cut/paste the "100dpi" folder from the "X11" one to the "fonts" one but it didn't solve the issue.
chris.ben9 7/nov/2012 às 13:24 
Thx for your help but for me it didn't work... same error;
Installing breakpad exception handler for appid(steam)/version(0) unlinked 0 orphaned pipes
shatsky 7/nov/2012 às 13:43 
You must install bitmap fonts which match -*-*-medium-r-normal--0-120-*-*-p-0-iso8859-1 XFLD, see
shatsky 7/nov/2012 às 13:46 
Escrito originalmente por chris.ben9:
same error;
Installing breakpad exception handler for appid(steam)/version(0) unlinked 0 orphaned pipes
These are normal messages. Try using DEBUGGER=strace and LD_DEBUG=libs to see what's wrong.
Última edição por shatsky; 7/nov/2012 às 13:46
chris.ben9 7/nov/2012 às 14:19 
thats what my debug gets:
13232: find [0]; searching 13232: trying file=/home/chris/Steam/ubuntu12_32/ 13232: trying file=tls/i686/sse2/cmov/ 13232: trying file=tls/i686/sse2/ 13232: trying file=tls/i686/cmov/ 13232: trying file=tls/i686/ 13232: trying file=tls/sse2/cmov/ 13232: trying file=tls/sse2/ 13232: trying file=tls/cmov/ 13232: trying file=tls/ 13232: trying file=i686/sse2/cmov/ 13232: trying file=i686/sse2/ 13232: trying file=i686/cmov/ 13232: trying file=i686/ 13232: trying file=sse2/cmov/ 13232: trying file=sse2/ 13232: trying file=cmov/ 13232: trying 13232: trying file=/lib/i386-linux-gnu/ 13232: calling init: /lib/i386-linux-gnu/ 13232: calling fini: /lib/i386-linux-gnu/ [0]

maybe its a good fact to know, that i am using Intel G33 as "Graphic"-Chip-replacement
Última edição por chris.ben9; 7/nov/2012 às 14:35
shatsky 7/nov/2012 às 14:47 
Escrito originalmente por chris.ben9:
thats what my debug gets
No, this is just a normal output about a shared library which contains 'error' in its name... Problem somewhere else.
I too received the public/steambootstraploader_english.txt errors.
I managed to get Steam running in Lubuntu:
-downloaded & ran Steam.deb
-enabled nvidia restricted drivers and repository
-installed the xfonts-100dpi package via Synaptic
Última edição por Agent Michael Scarn; 16/nov/2012 às 4:10
icg837 16/nov/2012 às 4:32 

I have a similar problem. In my case, my Steam client doesn't start since this week update. Now, when I run steam in a terminal, it shows this message:

"/usr/bin/steam: línea 64: / The file or directory doesn't exist"

I'm not in the beta.
kenny_727 7/dez/2012 às 15:04 
Thanks, just installed lubuntu to get a bit more performance out of my system, ran into this problem but using the xset command worked
NM4500 26/jan/2013 às 13:45 
After the installign process i cnat launch steam and there is no steam folder
Steam should be under ~/.steam/ or ~/.local/share/Steam
NM4500 27/jan/2013 às 4:41 
There is no folder like this
< >
Exibindo comentários 115 de 25
Por página: 15 30 50

Steam for Linux > Discussões gerais > Detalhes do tópico
Publicado em: 7/nov/2012 às 3:31
Mensagens: 25