Steam for Linux

Steam for Linux

TechG4m3r 5. Juli 2013 um 17:22 Uhr
Fedora 19 GLX Error.[SOLVED]
I have installed Fedora 19 and the nvidia akmod driver from the RPMFusion Rawhide repo, and I get this GLX error everytime I start Steam saying that I have direct rendering disabled. I'm guessing that I'm missing a 32bit dependency of some sort because if I install the binary nvidia driver Steam runs absolutely fine. All other OpenGL apps work fine on this akmod driver so I'm sure I have direct rendering enabled, would appreciate any help on how to fix this error.
Zuletzt bearbeitet von TechG4m3r; 6. Juli 2013 um 3:11 Uhr
< >
Beiträge 17 von 7
thetargos 5. Juli 2013 um 17:33 Uhr 
akmod = automatic building tool for the proprietary driver. So, if you are missing anyhing would be the nvidia-libraries.i686 package, if you wanted to use the proprietary driver.

If you are intending to use the Mesa driver with nouveau (aka the Open/Free drivers), you have to install the mesa and dri 32-bit libraries if you run 64-bits.

edit if running the Open/Free drivers, you have to ensure to install the libxtc-dxtn texture compression library in order to get S3TC support (and hence many games) to work.
Zuletzt bearbeitet von thetargos; 5. Juli 2013 um 17:35 Uhr
instabilis 5. Juli 2013 um 18:56 Uhr 
sudo yum install xorg-x11-drv-nvidia-libs.i686 libtxc_dxtn libtxc_dxtn.i686
then
sudo reboot
Commands for thetargos' suggestion if you need them :)
Zuletzt bearbeitet von instabilis; 5. Juli 2013 um 19:01 Uhr
TechG4m3r 6. Juli 2013 um 3:06 Uhr 
Ursprünglich geschrieben von instabilis:
sudo yum install xorg-x11-drv-nvidia-libs.i686 libtxc_dxtn libtxc_dxtn.i686
then
sudo reboot
Commands for thetargos' suggestion if you need them :)
I tried that, I get this output


Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: mirror.isoc.org.il
* rpmfusion-free: mirror.proserve.nl
* rpmfusion-free-updates: mirror.proserve.nl
* rpmfusion-nonfree: mirror.de.leaseweb.net
* rpmfusion-nonfree-updates: mirror.proserve.nl
* updates: mirror.isoc.org.il
Package 1:libtxc_dxtn-1.0.0-3.fc19.x86_64 already installed and latest version
Package 1:libtxc_dxtn-1.0.0-3.fc19.i686 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package xorg-x11-drv-nvidia-libs.i686 1:319.23-5.fc19 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia = 1:319.23-5.fc19 for package: 1:xorg-x11-drv-nvidia-libs-319.23-5.fc19.i686
--> Processing Dependency: libvdpau(x86-32) >= 0.5 for package: 1:xorg-x11-drv-nvidia-libs-319.23-5.fc19.i686
--> Running transaction check
---> Package libvdpau.i686 0:0.6-1.fc19 will be installed
---> Package xorg-x11-drv-nvidia-libs.i686 1:319.23-5.fc19 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia = 1:319.23-5.fc19 for package: 1:xorg-x11-drv-nvidia-libs-319.23-5.fc19.i686
--> Finished Dependency Resolution
Error: Package: 1:xorg-x11-drv-nvidia-libs-319.23-5.fc19.i686 (rpmfusion-nonfree)
Requires: xorg-x11-drv-nvidia = 1:319.23-5.fc19
Installed: 1:xorg-x11-drv-nvidia-319.32-1.fc20.x86_64 (@rpmfusion-nonfree-rawhide)
xorg-x11-drv-nvidia = 1:319.32-1.fc20
Available: 1:xorg-x11-drv-nvidia-319.23-5.fc19.x86_64 (rpmfusion-nonfree)
xorg-x11-drv-nvidia = 1:319.23-5.fc19
Available: xorg-x11-drv-nvidia-304xx-304.88-5.fc19.x86_64 (rpmfusion-nonfree)
xorg-x11-drv-nvidia = 1:304.88-1001
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
TechG4m3r 6. Juli 2013 um 3:07 Uhr 
I'm sure I don't have broken packages, but it doesn't let me install these libraries.
TechG4m3r 6. Juli 2013 um 3:11 Uhr 
Okay, I figured it out. All I needed to do while installing those libraries was to temporarily enable RPMFusion-Nonfree-Rawhide repo. Thanks for the help and for giving me the required libraries to install, Steam works great now! :D
OMBER 16. Okt. 2013 um 23:12 Uhr 
Wish we could upvote/have a Wiki - Ive spent an hour looking for a solution to basically same issue on F19. As above solution is to:

sudo yum install xorg-x11-drv-nvidia-libs-325.15-1.fc19.i686

Where 325.15.1 should be replaced with driver version you are already using. If you arent sure but youre using kmod/akmod from RPMfusion just do this:

rpm -qa | grep xorg-x11-drv-nvidia-libs

This will print list of installed nvidia-libs already (which should be the 64bit version of above library). Yes you need to have RPMfusion non-free installed for your Fedora version.
thetargos 22. Nov. 2013 um 21:26 Uhr 
Hippie Killer, from the looks of your yum output you have mixed F19 and rawhide packages installed, which is why you needed to enable the rawhide repo.
< >
Beiträge 17 von 7
Pro Seite: 15 30 50

Geschrieben am: 5. Juli 2013 um 17:22 Uhr
Beiträge: 7