Steam for Linux

Steam for Linux

Falassion Jan 18, 2013 @ 2:37pm
Xubunu update broke my Steam?
Yesterday I recall installing some header updates, just the usual updates available notification, then I click install. Well I used Steam all night to chat with people, then eventually went to sleep. I awoke a bit ago to learn my Steam client is no longer open, and will not launch.

I tried removing it and reinstalling it, but I can't even get past the initial Ubuntu Software Center install. I'm not sure what to do.

I'm running on Xubuntu 12.10 64-bit, 8GB RAM, FX-6100 3.3GHz, Radeon HD 6790 with AMD 12.11 beta drivers.
< >
Showing 1-8 of 8 comments
Blumimic Jan 18, 2013 @ 3:10pm 
Kernel updates can cause programs to not launch (totem) until you restart.
Found out the hard way you could say.
Last edited by Blumimic; Jan 18, 2013 @ 3:10pm
Falassion Jan 18, 2013 @ 3:15pm 
I neglected to mention I have performed a restart. However, I'll give it another shot!
Blumimic Jan 18, 2013 @ 3:43pm 
Run steam from a terminal and see if it gives any clues.
Falassion Jan 18, 2013 @ 3:44pm 
Here's what I get

Installing breakpad exception handler for appid(steam)/version(1358286427_client)
/home/devon/.local/share/Steam/ line 337: 3989 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/devon/.local/share/Steam/bootstrap.tar.xz
Installing breakpad exception handler for appid(steam)/version(1358286427_client)
/home/devon/.local/share/Steam/ line 337: 4040 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Kirix Jan 18, 2013 @ 4:24pm 
I had to delete .steam, which was a hidden folder in the Home directory, to get it to work again on Xubuntu.
Falassion Jan 18, 2013 @ 7:08pm 
I've actually tried that as well.. still no luck
Ast Jan 19, 2013 @ 3:56am 
I think I have a similar problem. My Ubuntu just upgraded a few things, including the kernel and removed a few libraries on the way. Now I cannot install steam anymore. The software centrer refuses install and gives the error message "libsdl1.2debian:i386 could not be installed".

I'm running Ubuntu 12.4.1 64 bit and I tried to install the newest *.deb from
< >
Showing 1-8 of 8 comments
Per page: 15 30 50

Date Posted: Jan 18, 2013 @ 2:37pm
Posts: 8