Steam for Linux

Steam for Linux

Duralex Dec 21, 2012 @ 1:52am
SteamAPI_IsSteamRunning() Failed after no system changes
As soon as I was invited to the BETA I showed my support and got SS3 (well it helped it was on sale right ;) ). As can be seen from my profile I have been playing it quite a bit since then but now all of a sudden after one day in which I made no changes to my system I am getting:

SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

Neither SS3 or the world of Goo work now and both spit out this same error. I disabled the in game overlay, copied the steam api library to lib32 (changed the permissions), attempted to launch the games from both the steam gui and from the command line but its the same thing every time.

An ldd on the Sam3 binary shows that all the libraries are found and the same for

The wierd part is that I recently did a major update to my system which included upgrading my kernel, a ton of libraries and also my NVIDIA drivers but SS3 still worked afterwards and in fact received a 15 fps boost.

I can confirm this same error on both kernel 3.4.9 and 3.5.7 (gentoo x64 sources) with either NVIDIA 310 or 313 drivers and a 560 2G card.
< >
Showing 1-3 of 3 comments
flugga [FR] Jan 11, 2013 @ 11:27pm 
For people coming here with the same issue : try installing

This happens if your steam launcher doesn't update (e.g. because valve isn't in your repos list) while your client has updated itself to the latest version.

Solution from here :
Ancoplays Mar 4, 2017 @ 8:42am 
Where i have to upload thid steam_lates.deb?
Last edited by Ancoplays; Mar 4, 2017 @ 8:42am
Maleko Mar 4, 2017 @ 12:20pm 
Originally posted by Ancoplays:
Where i have to upload thid steam_lates.deb?

This is a very old thread you've bumped. Get Steam from your distro's repos instead.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Dec 21, 2012 @ 1:52am
Posts: 3